Mogware.VisualStudio.ColladaNet Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet]

Classes

Class | Description
Accessor |
ColladaDocument |
ColladaDocumentRoot |
Input |
InputList |
Matrix |
Source |
SourceList |
UIUpdate |
Uri |

Interfaces

Interface | Description
ISource |

Delegates

Delegate | Description
UIUpdate..::.UIUpdateEvent |

Enumerations

Enumeration | Description
InputSemantic |
Source..::.SourceType |

www.mogare.com/Collada.Net


Accessor Class

[image]

Mogware's Collada.Net Class Library
Accessor Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Accessor]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Accessor
Visual Basic (Declaration)
Public Class Accessor
Visual C++
public ref class Accessor

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.Accessor

See Also

Accessor Members
Mogware.VisualStudio.ColladaNet Namespace


Accessor Members

[image] [image]

Mogware's Collada.Net Class Library
Accessor Members
Accessor Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Accessor type exposes the following members.

Constructors

Name | Description
Accessor | Initializes a new instance of the Accessor class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Count |
Item |
Stride |

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Accessor Constructor

[image]

Mogware's Collada.Net Class Library
Accessor Constructor
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Accessor class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Accessor(
    XmlElement element,
    ISource source
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    source As ISource _
)
Visual C++
public:
Accessor(
    XmlElement^ element,
    ISource^ source
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Accessor.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ISource)"]

source
Type: Mogware.VisualStudio.ColladaNet..::.ISource

[Missing <param name="source"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Accessor.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ISource)"]

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Accessor Methods

[image] [image]

Mogware's Collada.Net Class Library
Accessor Methods
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Accessor type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


IndexOf Method

[image]

Mogware's Collada.Net Class Library
Accessor..::.IndexOf Method
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Accessor.IndexOf(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int IndexOf(
    Object item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Accessor.IndexOf(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Accessor.IndexOf(System.Object)]

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Accessor..::.Presave Method
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Accessor.Presave]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Accessor Properties

[image] [image]

Mogware's Collada.Net Class Library
Accessor Properties
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Accessor type exposes the following members.

Properties

Name | Description
Count |
Item |
Stride |

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Count Property

[image]

Mogware's Collada.Net Class Library
Accessor..::.Count Property
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Accessor.Count]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Count { get; }
Visual Basic (Declaration)
Public ReadOnly Property Count As Integer
Visual C++
public:
property int Count {
    int get ();
}

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Item Property

[image]

Mogware's Collada.Net Class Library
Accessor..::.Item Property
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Accessor.Item(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::.Int32

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


Stride Property

[image]

Mogware's Collada.Net Class Library
Accessor..::.Stride Property
Accessor Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Accessor.Stride]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Stride { get; }
Visual Basic (Declaration)
Public ReadOnly Property Stride As Integer
Visual C++
public:
property int Stride {
    int get ();
}

See Also

Accessor Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocument Class

[image]

Mogware's Collada.Net Class Library
ColladaDocument Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.ColladaDocument]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ColladaDocument : ColladaDocumentRoot
Visual Basic (Declaration)
Public Class ColladaDocument _
    Inherits ColladaDocumentRoot
Visual C++
public ref class ColladaDocument : public ColladaDocumentRoot

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.ColladaDocumentRoot
Mogware.VisualStudio.ColladaNet..::.ColladaDocument

See Also

ColladaDocument Members
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocument Members

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocument Members
ColladaDocument Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocument type exposes the following members.

Constructors

Name | Description
ColladaDocument | Initializes a new instance of the ColladaDocument class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | (Overrides ColladaDocumentRoot..::.Save()()().)
SaveAs | (Overrides ColladaDocumentRoot..::.SaveAs(String).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnimationGroups |
Cameras |
ControllerInstances |
Controllers |
Effects |
Filename |
Geometries |
Images |
IsDirty | (Overrides ColladaDocumentRoot..::.IsDirty.)
MaterialInstances |
Materials |
VisualScenes |

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocument Constructor

[image]

Mogware's Collada.Net Class Library
ColladaDocument Constructor
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ColladaDocument class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColladaDocument(
    string filename
)
Visual Basic (Declaration)
Public Sub New ( _
    filename As String _
)
Visual C++
public:
ColladaDocument(
    String^ filename
)

Parameters

filename
Type: System..::.String

[Missing <param name="filename"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ColladaDocument.#ctor(System.String)"]

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocument Methods

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocument Methods
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocument type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save | (Overrides ColladaDocumentRoot..::.Save()()().)
SaveAs | (Overrides ColladaDocumentRoot..::.SaveAs(String).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Save Method

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Save Method
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ColladaDocument.Save]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Save()
Visual Basic (Declaration)
Public Overrides Sub Save
Visual C++
public:
virtual void Save() override

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


SaveAs Method

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.SaveAs Method
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ColladaDocument.SaveAs(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void SaveAs(
    string filename
)
Visual Basic (Declaration)
Public Overrides Sub SaveAs ( _
    filename As String _
)
Visual C++
public:
virtual void SaveAs(
    String^ filename
) override

Parameters

filename
Type: System..::.String

[Missing <param name="filename"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ColladaDocument.SaveAs(System.String)"]

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocument Properties

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocument Properties
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocument type exposes the following members.

Properties

Name | Description
AnimationGroups |
Cameras |
ControllerInstances |
Controllers |
Effects |
Filename |
Geometries |
Images |
IsDirty | (Overrides ColladaDocumentRoot..::.IsDirty.)
MaterialInstances |
Materials |
VisualScenes |

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


AnimationGroups Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.AnimationGroups Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.AnimationGroups]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationGroupList AnimationGroups { get; }
Visual Basic (Declaration)
Public ReadOnly Property AnimationGroups As AnimationGroupList
Visual C++
public:
property AnimationGroupList^ AnimationGroups {
    AnimationGroupList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Cameras Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Cameras Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Cameras]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Camera> Cameras { get; }
Visual Basic (Declaration)
Public ReadOnly Property Cameras As List(Of Camera)
Visual C++
public:
property List<Camera^>^ Cameras {
    List<Camera^>^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


ControllerInstances Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.ControllerInstances Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.ControllerInstances]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerInstanceList ControllerInstances { get; }
Visual Basic (Declaration)
Public ReadOnly Property ControllerInstances As ControllerInstanceList
Visual C++
public:
property ControllerInstanceList^ ControllerInstances {
    ControllerInstanceList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Controllers Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Controllers Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Controllers]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerList Controllers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Controllers As ControllerList
Visual C++
public:
property ControllerList^ Controllers {
    ControllerList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Effects Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Effects Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Effects]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public EffectList Effects { get; set; }
Visual Basic (Declaration)
Public Property Effects As EffectList
Visual C++
public:
property EffectList^ Effects {
    EffectList^ get ();
    void set (EffectList^ value);
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Filename Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Filename Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Filename]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Filename { get; set; }
Visual Basic (Declaration)
Public Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Geometries Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Geometries Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Geometries]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public GeometryList Geometries { get; }
Visual Basic (Declaration)
Public ReadOnly Property Geometries As GeometryList
Visual C++
public:
property GeometryList^ Geometries {
    GeometryList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Images Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Images Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Images]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ImageList Images { get; set; }
Visual Basic (Declaration)
Public Property Images As ImageList
Visual C++
public:
property ImageList^ Images {
    ImageList^ get ();
    void set (ImageList^ value);
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


IsDirty Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.IsDirty Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.IsDirty]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override bool IsDirty { get; set; }
Visual Basic (Declaration)
Public Overrides Property IsDirty As Boolean
Visual C++
public:
virtual property bool IsDirty {
    bool get () override;
    void set (bool value) override;
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


MaterialInstances Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.MaterialInstances Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.MaterialInstances]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialInstanceList MaterialInstances { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaterialInstances As MaterialInstanceList
Visual C++
public:
property MaterialInstanceList^ MaterialInstances {
    MaterialInstanceList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


Materials Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.Materials Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.Materials]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialList Materials { get; }
Visual Basic (Declaration)
Public ReadOnly Property Materials As MaterialList
Visual C++
public:
property MaterialList^ Materials {
    MaterialList^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


VisualScenes Property

[image]

Mogware's Collada.Net Class Library
ColladaDocument..::.VisualScenes Property
ColladaDocument Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocument.VisualScenes]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<VisualScene> VisualScenes { get; }
Visual Basic (Declaration)
Public ReadOnly Property VisualScenes As List(Of VisualScene)
Visual C++
public:
property List<VisualScene^>^ VisualScenes {
    List<VisualScene^>^ get ();
}

See Also

ColladaDocument Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocumentRoot Class

[image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.ColladaDocumentRoot]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class ColladaDocumentRoot
Visual Basic (Declaration)
Public MustInherit Class ColladaDocumentRoot
Visual C++
public ref class ColladaDocumentRoot abstract

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.ColladaDocumentRoot
Mogware.VisualStudio.ColladaNet..::.ColladaDocument

See Also

ColladaDocumentRoot Members
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocumentRoot Members

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot Members
ColladaDocumentRoot Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocumentRoot type exposes the following members.

Constructors

Name | Description
ColladaDocumentRoot | Initializes a new instance of the ColladaDocumentRoot class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save |
SaveAs |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
IsDirty |

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocumentRoot Constructor

[image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot Constructor
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ColladaDocumentRoot class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected ColladaDocumentRoot()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
ColladaDocumentRoot()

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocumentRoot Methods

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot Methods
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocumentRoot type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Save |
SaveAs |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


Save Method

[image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot..::.Save Method
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ColladaDocumentRoot.Save]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract void Save()
Visual Basic (Declaration)
Public MustOverride Sub Save
Visual C++
public:
virtual void Save() abstract

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


SaveAs Method

[image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot..::.SaveAs Method
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ColladaDocumentRoot.SaveAs(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract void SaveAs(
    string filename
)
Visual Basic (Declaration)
Public MustOverride Sub SaveAs ( _
    filename As String _
)
Visual C++
public:
virtual void SaveAs(
    String^ filename
) abstract

Parameters

filename
Type: System..::.String

[Missing <param name="filename"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ColladaDocumentRoot.SaveAs(System.String)"]

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


ColladaDocumentRoot Properties

[image] [image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot Properties
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColladaDocumentRoot type exposes the following members.

Properties

Name | Description
IsDirty |

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


IsDirty Property

[image]

Mogware's Collada.Net Class Library
ColladaDocumentRoot..::.IsDirty Property
ColladaDocumentRoot Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ColladaDocumentRoot.IsDirty]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract bool IsDirty { get; set; }
Visual Basic (Declaration)
Public MustOverride Property IsDirty As Boolean
Visual C++
public:
virtual property bool IsDirty {
    bool get () abstract;
    void set (bool value) abstract;
}

See Also

ColladaDocumentRoot Class
Mogware.VisualStudio.ColladaNet Namespace


Input Class

[image]

Mogware's Collada.Net Class Library
Input Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Input]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Input
Visual Basic (Declaration)
Public Class Input
Visual C++
public ref class Input

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.Input

See Also

Input Members
Mogware.VisualStudio.ColladaNet Namespace


Input Members

[image] [image]

Mogware's Collada.Net Class Library
Input Members
Input Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Input type exposes the following members.

Constructors

Name | Description
Input | Initializes a new instance of the Input class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
InputElement |
Item |
Offset |
Semantic |
Source |

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Input Constructor

[image]

Mogware's Collada.Net Class Library
Input Constructor
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Input class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Input(
    XmlElement element,
    ISource source
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    source As ISource _
)
Visual C++
public:
Input(
    XmlElement^ element,
    ISource^ source
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Input.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ISource)"]

source
Type: Mogware.VisualStudio.ColladaNet..::.ISource

[Missing <param name="source"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Input.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ISource)"]

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Input Methods

[image] [image]

Mogware's Collada.Net Class Library
Input Methods
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Input type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Input Properties

[image] [image]

Mogware's Collada.Net Class Library
Input Properties
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Input type exposes the following members.

Properties

Name | Description
InputElement |
Item |
Offset |
Semantic |
Source |

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


InputElement Property

[image]

Mogware's Collada.Net Class Library
Input..::.InputElement Property
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Input.InputElement]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public XmlElement InputElement { get; set; }
Visual Basic (Declaration)
Public Property InputElement As XmlElement
Visual C++
public:
property XmlElement^ InputElement {
    XmlElement^ get ();
    void set (XmlElement^ value);
}

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Item Property

[image]

Mogware's Collada.Net Class Library
Input..::.Item Property
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Input.Item(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::.Int32

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Offset Property

[image]

Mogware's Collada.Net Class Library
Input..::.Offset Property
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Input.Offset]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Offset { get; set; }
Visual Basic (Declaration)
Public Property Offset As Integer
Visual C++
public:
property int Offset {
    int get ();
    void set (int value);
}

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Semantic Property

[image]

Mogware's Collada.Net Class Library
Input..::.Semantic Property
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Input.Semantic]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InputSemantic Semantic { get; set; }
Visual Basic (Declaration)
Public Property Semantic As InputSemantic
Visual C++
public:
property InputSemantic Semantic {
    InputSemantic get ();
    void set (InputSemantic value);
}

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


Source Property

[image]

Mogware's Collada.Net Class Library
Input..::.Source Property
Input Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Input.Source]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ISource Source { get; set; }
Visual Basic (Declaration)
Public Property Source As ISource
Visual C++
public:
property ISource^ Source {
    ISource^ get ();
    void set (ISource^ value);
}

See Also

Input Class
Mogware.VisualStudio.ColladaNet Namespace


InputList Class

[image]

Mogware's Collada.Net Class Library
InputList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.InputList]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class InputList : List<Input>
Visual Basic (Declaration)
Public Class InputList _
    Inherits List(Of Input)
Visual C++
public ref class InputList : public List<Input^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Input >)>)
Mogware.VisualStudio.ColladaNet..::.InputList

See Also

InputList Members
Mogware.VisualStudio.ColladaNet Namespace


InputList Members

[image] [image]

Mogware's Collada.Net Class Library
InputList Members
InputList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InputList type exposes the following members.

Constructors

Name | Description
InputList | Initializes a new instance of the InputList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Input >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Input >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Input >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Input >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Input >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Input >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Input >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Input >)>).)
Size |

See Also

InputList Class
Mogware.VisualStudio.ColladaNet Namespace


InputList Constructor

[image]

Mogware's Collada.Net Class Library
InputList Constructor
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the InputList class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InputList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InputList()

See Also

InputList Class
Mogware.VisualStudio.ColladaNet Namespace


InputList Methods

[image] [image]

Mogware's Collada.Net Class Library
InputList Methods
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InputList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Input >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Input >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Input >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Input >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Input >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Input >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
Mogware.VisualStudio.ColladaNet Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.BinarySearch Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Input >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Input >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.CopyTo Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Input >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Input >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.Find Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Find(InputSemantic) |

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


Find Method (InputSemantic)

[image]

Mogware's Collada.Net Class Library
InputList..::.Find Method (InputSemantic)
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.InputList.Find(Mogware.VisualStudio.ColladaNet.InputSemantic)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Input Find(
    InputSemantic semantic
)
Visual Basic (Declaration)
Public Function Find ( _
    semantic As InputSemantic _
) As Input
Visual C++
public:
Input^ Find(
    InputSemantic semantic
)

Parameters

semantic
Type: Mogware.VisualStudio.ColladaNet..::.InputSemantic

[Missing <param name="semantic"/> documentation for "M:Mogware.VisualStudio.ColladaNet.InputList.Find(Mogware.VisualStudio.ColladaNet.InputSemantic)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.InputList.Find(Mogware.VisualStudio.ColladaNet.InputSemantic)]

See Also

InputList Class
Find Overload
Mogware.VisualStudio.ColladaNet Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.FindIndex Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Input >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.FindLastIndex Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Input >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.IndexOf Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Input >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.LastIndexOf Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Input >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.Reverse Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
InputList..::.Sort Method
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Input >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Input >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Input >)>).)

See Also

InputList Class
InputList Members
Mogware.VisualStudio.ColladaNet Namespace


InputList Properties

[image] [image]

Mogware's Collada.Net Class Library
InputList Properties
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InputList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Input >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Input >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Input >)>).)
Size |

See Also

InputList Class
Mogware.VisualStudio.ColladaNet Namespace


Size Property

[image]

Mogware's Collada.Net Class Library
InputList..::.Size Property
InputList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.InputList.Size]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Size { get; }
Visual Basic (Declaration)
Public ReadOnly Property Size As Integer
Visual C++
public:
property int Size {
    int get ();
}

See Also

InputList Class
Mogware.VisualStudio.ColladaNet Namespace


InputSemantic Enumeration

[image]

Mogware's Collada.Net Class Library
InputSemantic Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.InputSemantic]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum InputSemantic
Visual Basic (Declaration)
Public Enumeration InputSemantic
Visual C++
public enum class InputSemantic

Members

Member name | Description
VERTEX |
POSITION |
COLOR |
NORMAL |
TEXCOORD |
TEXTURE |
TANGENT |
BINORMAL |
UV |
INPUT |
OUTPUT |
IN_TANGENT |
OUT_TANGENT |
INTERPOLATION |
JOINT |
WEIGHT |
INV_BIND_MATRIX |
MORPH_TARGET |
MORPH_WEIGHT |

See Also

Mogware.VisualStudio.ColladaNet Namespace


ISource Interface

[image]

Mogware's Collada.Net Class Library
ISource Interface
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.ISource]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public interface ISource
Visual Basic (Declaration)
Public Interface ISource
Visual C++
public interface class ISource

See Also

ISource Members
Mogware.VisualStudio.ColladaNet Namespace


ISource Members

[image] [image]

Mogware's Collada.Net Class Library
ISource Members
ISource Interface Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ISource type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
GetIndex |
IndexOf |
Presave |

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


ISource Methods

[image] [image]

Mogware's Collada.Net Class Library
ISource Methods
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ISource type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
GetIndex |
IndexOf |
Presave |

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Add Method

[image]

Mogware's Collada.Net Class Library
ISource..::.Add Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.Add(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
bool Add(
    Object item
)
Visual Basic (Declaration)
Function Add ( _
    item As Object _
) As Boolean
Visual C++
bool Add(
    Object^ item
)

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ISource.Add(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.Add(System.Object)]

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


AddRange Method

[image]

Mogware's Collada.Net Class Library
ISource..::.AddRange Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.AddRange(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
int AddRange(
    IList range
)
Visual Basic (Declaration)
Function AddRange ( _
    range As IList _
) As Integer
Visual C++
int AddRange(
    IList^ range
)

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ISource.AddRange(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.AddRange(System.Collections.IList)]

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Clear Method

[image]

Mogware's Collada.Net Class Library
ISource..::.Clear Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.Clear]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
void Clear()
Visual Basic (Declaration)
Sub Clear
Visual C++
void Clear()

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


GetIndex Method

[image]

Mogware's Collada.Net Class Library
ISource..::.GetIndex Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.GetIndex(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
int GetIndex(
    IList range
)
Visual Basic (Declaration)
Function GetIndex ( _
    range As IList _
) As Integer
Visual C++
int GetIndex(
    IList^ range
)

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ISource.GetIndex(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.GetIndex(System.Collections.IList)]

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


IndexOf Method

[image]

Mogware's Collada.Net Class Library
ISource..::.IndexOf Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.IndexOf(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
int IndexOf(
    Object item
)
Visual Basic (Declaration)
Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
int IndexOf(
    Object^ item
)

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.ISource.IndexOf(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.IndexOf(System.Object)]

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
ISource..::.Presave Method
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.ISource.Presave]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
void Presave()
Visual Basic (Declaration)
Sub Presave
Visual C++
void Presave()

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


ISource Properties

[image] [image]

Mogware's Collada.Net Class Library
ISource Properties
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ISource type exposes the following members.

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


AllowDuplicates Property

[image]

Mogware's Collada.Net Class Library
ISource..::.AllowDuplicates Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.AllowDuplicates]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
bool AllowDuplicates { get; set; }
Visual Basic (Declaration)
Property AllowDuplicates As Boolean
Visual C++
property bool AllowDuplicates {
    bool get ();
    void set (bool value);
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Data Property

[image]

Mogware's Collada.Net Class Library
ISource..::.Data Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.Data]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
IList<Object> Data { get; }
Visual Basic (Declaration)
ReadOnly Property Data As IList(Of Object)
Visual C++
property IList<Object^>^ Data {
    IList<Object^>^ get ();
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Hash Property

[image]

Mogware's Collada.Net Class Library
ISource..::.Hash Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.Hash]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
Hashtable Hash { get; }
Visual Basic (Declaration)
ReadOnly Property Hash As Hashtable
Visual C++
property Hashtable^ Hash {
    Hashtable^ get ();
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
ISource..::.Id Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.Id]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
string Id { get; }
Visual Basic (Declaration)
ReadOnly Property Id As String
Visual C++
property String^ Id {
    String^ get ();
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Item Property

[image]

Mogware's Collada.Net Class Library
ISource..::.Item Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.Item(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Default Property Item ( _
    index As Integer _
) As Object
Visual C++
property Object^ default[int index] {
    Object^ get (int index);
    void set (int index, Object^ value);
}

Parameters

index
Type: System..::.Int32

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


ItemCount Property

[image]

Mogware's Collada.Net Class Library
ISource..::.ItemCount Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.ItemCount]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
int ItemCount { get; }
Visual Basic (Declaration)
ReadOnly Property ItemCount As Integer
Visual C++
property int ItemCount {
    int get ();
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
ISource..::.Name Property
ISource Interface See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.ISource.Name]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
string Name { get; }
Visual Basic (Declaration)
ReadOnly Property Name As String
Visual C++
property String^ Name {
    String^ get ();
}

See Also

ISource Interface
Mogware.VisualStudio.ColladaNet Namespace


Matrix Class

[image]

Mogware's Collada.Net Class Library
Matrix Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Matrix]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Matrix
Visual Basic (Declaration)
Public Class Matrix
Visual C++
public ref class Matrix

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.Matrix

See Also

Matrix Members
Mogware.VisualStudio.ColladaNet Namespace


Matrix Members

[image] [image]

Mogware's Collada.Net Class Library
Matrix Members
Matrix Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Matrix type exposes the following members.

Constructors

Name | Description
Matrix | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotation |
GetRotationMatrix |
GetScale |
GetTranslation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

Properties

Name | Description
DXMatrix |
Elements |

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


Matrix Constructor

[image] [image]

Mogware's Collada.Net Class Library
Matrix Constructor
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Matrix(Matrix) | Initializes a new instance of the Matrix class
Matrix(List<(Of <(Object>)>)) | Initializes a new instance of the Matrix class
Matrix(array<Single>[]()[]) | Initializes a new instance of the Matrix class

See Also

Matrix Class
Matrix Members
Mogware.VisualStudio.ColladaNet Namespace


Matrix Constructor ()

[image]

Mogware's Collada.Net Class Library
Matrix Constructor ()
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Matrix class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix(
    Matrix m
)
Visual Basic (Declaration)
Public Sub New ( _
    m As Matrix _
)
Visual C++
public:
Matrix(
    Matrix m
)

Parameters

m
Type: Matrix

[Missing <param name="m"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Matrix.#ctor(Microsoft.DirectX.Matrix)"]

See Also

Matrix Class
Matrix Overload
Mogware.VisualStudio.ColladaNet Namespace


Matrix Constructor (List(Object))

[image]

Mogware's Collada.Net Class Library
Matrix Constructor (List<(Of <(Object>)>))
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Matrix class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix(
    List<Object> elements
)
Visual Basic (Declaration)
Public Sub New ( _
    elements As List(Of Object) _
)
Visual C++
public:
Matrix(
    List<Object^>^ elements
)

Parameters

elements
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="elements"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Matrix.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

Matrix Class
Matrix Overload
Mogware.VisualStudio.ColladaNet Namespace


Matrix Constructor (Single[])

[image]

Mogware's Collada.Net Class Library
Matrix Constructor (array<Single>[]()[])
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Matrix class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix(
    float[] elements
)
Visual Basic (Declaration)
Public Sub New ( _
    elements As Single() _
)
Visual C++
public:
Matrix(
    array<float>^ elements
)

Parameters

elements
Type: array< System..::.Single >[]()[]

[Missing <param name="elements"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Matrix.#ctor(System.Single[])"]

See Also

Matrix Class
Matrix Overload
Mogware.VisualStudio.ColladaNet Namespace


Matrix Methods

[image] [image]

Mogware's Collada.Net Class Library
Matrix Methods
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Matrix type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotation |
GetRotationMatrix |
GetScale |
GetTranslation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | (Overrides Object..::.ToString()()().)

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


GetRotation Method

[image]

Mogware's Collada.Net Class Library
Matrix..::.GetRotation Method
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetRotation]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetRotation()
Visual Basic (Declaration)
Public Function GetRotation As Vector3
Visual C++
public:
Vector3 GetRotation()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetRotation]

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


GetRotationMatrix Method

[image]

Mogware's Collada.Net Class Library
Matrix..::.GetRotationMatrix Method
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetRotationMatrix]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix GetRotationMatrix()
Visual Basic (Declaration)
Public Function GetRotationMatrix As Matrix
Visual C++
public:
Matrix GetRotationMatrix()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetRotationMatrix]

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


GetScale Method

[image]

Mogware's Collada.Net Class Library
Matrix..::.GetScale Method
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetScale]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetScale()
Visual Basic (Declaration)
Public Function GetScale As Vector3
Visual C++
public:
Vector3 GetScale()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetScale]

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


GetTranslation Method

[image]

Mogware's Collada.Net Class Library
Matrix..::.GetTranslation Method
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetTranslation]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetTranslation()
Visual Basic (Declaration)
Public Function GetTranslation As Vector3
Visual C++
public:
Vector3 GetTranslation()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.GetTranslation]

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


ToString Method

[image]

Mogware's Collada.Net Class Library
Matrix..::.ToString Method
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.ToString]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override string ToString()
Visual Basic (Declaration)
Public Overrides Function ToString As String
Visual C++
public:
virtual String^ ToString() override

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Matrix.ToString]

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


Matrix Properties

[image] [image]

Mogware's Collada.Net Class Library
Matrix Properties
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Matrix type exposes the following members.

Properties

Name | Description
DXMatrix |
Elements |

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


DXMatrix Property

[image]

Mogware's Collada.Net Class Library
Matrix..::.DXMatrix Property
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Matrix.DXMatrix]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix DXMatrix { get; }
Visual Basic (Declaration)
Public ReadOnly Property DXMatrix As Matrix
Visual C++
public:
property Matrix DXMatrix {
    Matrix get ();
}

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


Elements Property

[image]

Mogware's Collada.Net Class Library
Matrix..::.Elements Property
Matrix Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Matrix.Elements]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float[,] Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As Single(,)
Visual C++
public:
property array<float,2>^ Elements {
    array<float,2>^ get ();
}

See Also

Matrix Class
Mogware.VisualStudio.ColladaNet Namespace


Source Class

[image]

Mogware's Collada.Net Class Library
Source Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Source]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Source : ISource
Visual Basic (Declaration)
Public Class Source _
    Implements ISource
Visual C++
public ref class Source : ISource

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.Source

See Also

Source Members
Mogware.VisualStudio.ColladaNet Namespace


Source Members

[image] [image]

Mogware's Collada.Net Class Library
Source Members
Source Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Source type exposes the following members.

Constructors

Name | Description
Source | Initializes a new instance of the Source class

Methods

Name | Description
Add |
AddRange |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIndex |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Source Constructor

[image]

Mogware's Collada.Net Class Library
Source Constructor
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Source class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Source(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Source(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Source.#ctor(System.Xml.XmlElement)"]

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Source Methods

[image] [image]

Mogware's Collada.Net Class Library
Source Methods
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Source type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIndex |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Add Method

[image]

Mogware's Collada.Net Class Library
Source..::.Add Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.Add(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Add(
    Object item
)
Visual Basic (Declaration)
Public Function Add ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Add(
    Object^ item
) sealed

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Source.Add(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Source.Add(System.Object)]

Implements

ISource..::.Add(Object)

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


AddRange Method

[image]

Mogware's Collada.Net Class Library
Source..::.AddRange Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.AddRange(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int AddRange(
    IList range
)
Visual Basic (Declaration)
Public Function AddRange ( _
    range As IList _
) As Integer
Visual C++
public:
virtual int AddRange(
    IList^ range
) sealed

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Source.AddRange(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Source.AddRange(System.Collections.IList)]

Implements

ISource..::.AddRange(IList)

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Clear Method

[image]

Mogware's Collada.Net Class Library
Source..::.Clear Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.Clear]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ISource..::.Clear()()()

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


GetIndex Method

[image]

Mogware's Collada.Net Class Library
Source..::.GetIndex Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.GetIndex(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int GetIndex(
    IList range
)
Visual Basic (Declaration)
Public Function GetIndex ( _
    range As IList _
) As Integer
Visual C++
public:
virtual int GetIndex(
    IList^ range
) sealed

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Source.GetIndex(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Source.GetIndex(System.Collections.IList)]

Implements

ISource..::.GetIndex(IList)

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


IndexOf Method

[image]

Mogware's Collada.Net Class Library
Source..::.IndexOf Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.IndexOf(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int IndexOf(
    Object item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
) sealed

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Source.IndexOf(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Source.IndexOf(System.Object)]

Implements

ISource..::.IndexOf(Object)

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Source..::.Presave Method
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Source.Presave]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
virtual void Presave() sealed

Implements

ISource..::.Presave()()()

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Source Properties

[image] [image]

Mogware's Collada.Net Class Library
Source Properties
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Source type exposes the following members.

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


AllowDuplicates Property

[image]

Mogware's Collada.Net Class Library
Source..::.AllowDuplicates Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.AllowDuplicates]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool AllowDuplicates { get; set; }
Visual Basic (Declaration)
Public Property AllowDuplicates As Boolean
Visual C++
public:
virtual property bool AllowDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISource..::.AllowDuplicates

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Data Property

[image]

Mogware's Collada.Net Class Library
Source..::.Data Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.Data]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public IList<Object> Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As IList(Of Object)
Visual C++
public:
virtual property IList<Object^>^ Data {
    IList<Object^>^ get () sealed;
}

Implements

ISource..::.Data

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Hash Property

[image]

Mogware's Collada.Net Class Library
Source..::.Hash Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.Hash]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Hashtable Hash { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hash As Hashtable
Visual C++
public:
virtual property Hashtable^ Hash {
    Hashtable^ get () sealed;
}

Implements

ISource..::.Hash

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Source..::.Id Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.Id]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
virtual property String^ Id {
    String^ get () sealed;
}

Implements

ISource..::.Id

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Item Property

[image]

Mogware's Collada.Net Class Library
Source..::.Item Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.Item(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

ISource..::.Item[([(Int32])])

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


ItemCount Property

[image]

Mogware's Collada.Net Class Library
Source..::.ItemCount Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.ItemCount]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
virtual property int ItemCount {
    int get () sealed;
}

Implements

ISource..::.ItemCount

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Source..::.Name Property
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Source.Name]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ISource..::.Name

See Also

Source Class
Mogware.VisualStudio.ColladaNet Namespace


Source.SourceType Enumeration

[image]

Mogware's Collada.Net Class Library
Source..::.SourceType Enumeration
Source Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Source.SourceType]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum SourceType
Visual Basic (Declaration)
Public Enumeration SourceType
Visual C++
public enum class SourceType

Members

Member name | Description
float_array |
int_array |
bool_array |
IDREF_array |
Name_array |

See Also

Mogware.VisualStudio.ColladaNet Namespace


SourceList Class

[image]

Mogware's Collada.Net Class Library
SourceList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.SourceList]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class SourceList : List<ISource>
Visual Basic (Declaration)
Public Class SourceList _
    Inherits List(Of ISource)
Visual C++
public ref class SourceList : public List<ISource^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( ISource >)>)
Mogware.VisualStudio.ColladaNet..::.SourceList

See Also

SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


SourceList Members

[image] [image]

Mogware's Collada.Net Class Library
SourceList Members
SourceList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SourceList type exposes the following members.

Constructors

Name | Description
SourceList | Initializes a new instance of the SourceList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( ISource >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( ISource >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ISource >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ISource >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( ISource >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( ISource >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( ISource >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
Mogware.VisualStudio.ColladaNet Namespace


SourceList Constructor

[image]

Mogware's Collada.Net Class Library
SourceList Constructor
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the SourceList class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SourceList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SourceList()

See Also

SourceList Class
Mogware.VisualStudio.ColladaNet Namespace


SourceList Methods

[image] [image]

Mogware's Collada.Net Class Library
SourceList Methods
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SourceList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( ISource >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( ISource >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ISource >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ISource >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( ISource >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( ISource >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
Mogware.VisualStudio.ColladaNet Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.BinarySearch Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ISource >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ISource >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.CopyTo Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( ISource >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( ISource >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.Find Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Find(String) |

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
SourceList..::.Find Method (String)
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.SourceList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ISource Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As ISource
Visual C++
public:
ISource^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.SourceList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.SourceList.Find(System.String)]

See Also

SourceList Class
Find Overload
Mogware.VisualStudio.ColladaNet Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.FindIndex Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( ISource >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.FindLastIndex Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( ISource >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.IndexOf Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( ISource >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.LastIndexOf Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( ISource >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.Reverse Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
SourceList..::.Sort Method
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( ISource >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( ISource >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
SourceList Members
Mogware.VisualStudio.ColladaNet Namespace


SourceList Properties

[image] [image]

Mogware's Collada.Net Class Library
SourceList Properties
SourceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SourceList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( ISource >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( ISource >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( ISource >)>).)

See Also

SourceList Class
Mogware.VisualStudio.ColladaNet Namespace


UIUpdate Class

[image]

Mogware's Collada.Net Class Library
UIUpdate Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.UIUpdate]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class UIUpdate
Visual Basic (Declaration)
Public Class UIUpdate
Visual C++
public ref class UIUpdate

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.UIUpdate

See Also

UIUpdate Members
Mogware.VisualStudio.ColladaNet Namespace


UIUpdate Members

[image] [image]

Mogware's Collada.Net Class Library
UIUpdate Members
UIUpdate Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UIUpdate type exposes the following members.

Constructors

Name | Description
UIUpdate | Initializes a new instance of the UIUpdate class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIUpdate Class
Mogware.VisualStudio.ColladaNet Namespace


UIUpdate Constructor

[image]

Mogware's Collada.Net Class Library
UIUpdate Constructor
UIUpdate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the UIUpdate class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public UIUpdate()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
UIUpdate()

See Also

UIUpdate Class
Mogware.VisualStudio.ColladaNet Namespace


UIUpdate Methods

[image] [image]

Mogware's Collada.Net Class Library
UIUpdate Methods
UIUpdate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The UIUpdate type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

UIUpdate Class
Mogware.VisualStudio.ColladaNet Namespace


UIUpdate.UIUpdateEvent Delegate

[image]

Mogware's Collada.Net Class Library
UIUpdate..::.UIUpdateEvent Delegate
UIUpdate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public delegate void UIUpdateEvent(
    string message,
    bool option
)
Visual Basic (Declaration)
Public Delegate Sub UIUpdateEvent ( _
    message As String, _
    option As Boolean _
)
Visual C++
public delegate void UIUpdateEvent(
    String^ message,
    bool option
)

Parameters

message
Type: System..::.String
option
Type: System..::.Boolean

See Also

Mogware.VisualStudio.ColladaNet Namespace


Uri Class

[image]

Mogware's Collada.Net Class Library
Uri Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Uri]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Uri
Visual Basic (Declaration)
Public Class Uri
Visual C++
public ref class Uri

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet..::.Uri

See Also

Uri Members
Mogware.VisualStudio.ColladaNet Namespace


Uri Members

[image] [image]

Mogware's Collada.Net Class Library
Uri Members
Uri Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Uri type exposes the following members.

Constructors

Name | Description
Uri | Initializes a new instance of the Uri class

Methods

Name | Description
Collada2Windows |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Windows2Collada |

See Also

Uri Class
Mogware.VisualStudio.ColladaNet Namespace


Uri Constructor

[image]

Mogware's Collada.Net Class Library
Uri Constructor
Uri Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Uri class

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Uri()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Uri()

See Also

Uri Class
Mogware.VisualStudio.ColladaNet Namespace


Uri Methods

[image] [image]

Mogware's Collada.Net Class Library
Uri Methods
Uri Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Uri type exposes the following members.

Methods

Name | Description
Collada2Windows |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Windows2Collada |

See Also

Uri Class
Mogware.VisualStudio.ColladaNet Namespace


Collada2Windows Method

[image]

Mogware's Collada.Net Class Library
Uri..::.Collada2Windows Method
Uri Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Uri.Collada2Windows(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static string Collada2Windows(
    string colladaUri
)
Visual Basic (Declaration)
Public Shared Function Collada2Windows ( _
    colladaUri As String _
) As String
Visual C++
public:
static String^ Collada2Windows(
    String^ colladaUri
)

Parameters

colladaUri
Type: System..::.String

[Missing <param name="colladaUri"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Uri.Collada2Windows(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Uri.Collada2Windows(System.String)]

See Also

Uri Class
Mogware.VisualStudio.ColladaNet Namespace


Windows2Collada Method

[image]

Mogware's Collada.Net Class Library
Uri..::.Windows2Collada Method
Uri Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Uri.Windows2Collada(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static string Windows2Collada(
    string windowsPath
)
Visual Basic (Declaration)
Public Shared Function Windows2Collada ( _
    windowsPath As String _
) As String
Visual C++
public:
static String^ Windows2Collada(
    String^ windowsPath
)

Parameters

windowsPath
Type: System..::.String

[Missing <param name="windowsPath"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Uri.Windows2Collada(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Uri.Windows2Collada(System.String)]

See Also

Uri Class
Mogware.VisualStudio.ColladaNet Namespace


Mogware.VisualStudio.ColladaNet.Animations Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Animations Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Animations]

Classes

Class | Description
Angle |
Animation |
AnimationGroup |
AnimationGroupList |
AnimationList |
AnimationSet |
Channel |
Interpolation |
Keyframe |
KeyframeFloatOutput |
KeyframeOutput |
KeyframeVectorOutput |
Sampler |
SamplerList |
Target |

Enumerations

Enumeration | Description
InterpolationType |
TargetAttribute |


Angle Class

[image]

Mogware's Collada.Net Class Library
Angle Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Angle]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Angle
Visual Basic (Declaration)
Public Class Angle
Visual C++
public ref class Angle

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Angle

See Also

Angle Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Angle Members

[image] [image]

Mogware's Collada.Net Class Library
Angle Members
Angle Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Angle type exposes the following members.

Constructors

Name | Description
Angle | Initializes a new instance of the Angle class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Degrees |

See Also

Angle Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Angle Constructor

[image]

Mogware's Collada.Net Class Library
Angle Constructor
Angle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Angle class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Angle(
    float degrees
)
Visual Basic (Declaration)
Public Sub New ( _
    degrees As Single _
)
Visual C++
public:
Angle(
    float degrees
)

Parameters

degrees
Type: System..::.Single

[Missing <param name="degrees"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Angle.#ctor(System.Single)"]

See Also

Angle Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Angle Methods

[image] [image]

Mogware's Collada.Net Class Library
Angle Methods
Angle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Angle type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Angle Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Angle Properties

[image] [image]

Mogware's Collada.Net Class Library
Angle Properties
Angle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Angle type exposes the following members.

Properties

Name | Description
Degrees |

See Also

Angle Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Degrees Property

[image]

Mogware's Collada.Net Class Library
Angle..::.Degrees Property
Angle Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Angle.Degrees]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Degrees { get; set; }
Visual Basic (Declaration)
Public Property Degrees As Single
Visual C++
public:
property float Degrees {
    float get ();
    void set (float value);
}

See Also

Angle Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Class

[image]

Mogware's Collada.Net Class Library
Animation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Animation]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Animation
Visual Basic (Declaration)
Public Class Animation
Visual C++
public ref class Animation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Animation

See Also

Animation Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Members

[image] [image]

Mogware's Collada.Net Class Library
Animation Members
Animation Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Animation type exposes the following members.

Constructors

Name | Description
Animation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutput |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Channels |
Id |
KeyFrames |
MaxFrame |
MinFrame |
Samplers |
Sources |

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Constructor

[image] [image]

Mogware's Collada.Net Class Library
Animation Constructor
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Animation(XmlElement) | Initializes a new instance of the Animation class
Animation(Single, Single) | Initializes a new instance of the Animation class
Animation(Single, KeyframeOutput, Single, KeyframeOutput) | Initializes a new instance of the Animation class

See Also

Animation Class
Animation Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
Animation Constructor (XmlElement)
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Animation class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Animation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Xml.XmlElement)"]

See Also

Animation Class
Animation Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Constructor (Single, Single)

[image]

Mogware's Collada.Net Class Library
Animation Constructor (Single, Single)
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Animation class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation(
    float frame0,
    float frame1
)
Visual Basic (Declaration)
Public Sub New ( _
    frame0 As Single, _
    frame1 As Single _
)
Visual C++
public:
Animation(
    float frame0,
    float frame1
)

Parameters

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,System.Single)"]

See Also

Animation Class
Animation Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Constructor (Single, KeyframeOutput, Single, KeyframeOutput)

[image]

Mogware's Collada.Net Class Library
Animation Constructor (Single, KeyframeOutput, Single, KeyframeOutput)
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Animation class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation(
    float frame0,
    KeyframeOutput output0,
    float frame1,
    KeyframeOutput output1
)
Visual Basic (Declaration)
Public Sub New ( _
    frame0 As Single, _
    output0 As KeyframeOutput, _
    frame1 As Single, _
    output1 As KeyframeOutput _
)
Visual C++
public:
Animation(
    float frame0,
    KeyframeOutput^ output0,
    float frame1,
    KeyframeOutput^ output1
)

Parameters

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

output0
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

output1
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

See Also

Animation Class
Animation Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Methods

[image] [image]

Mogware's Collada.Net Class Library
Animation Methods
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Animation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetOutput |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


GetOutput Method

[image]

Mogware's Collada.Net Class Library
Animation..::.GetOutput Method
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Animation.GetOutput(System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public KeyframeOutput GetOutput(
    float frame
)
Visual Basic (Declaration)
Public Function GetOutput ( _
    frame As Single _
) As KeyframeOutput
Visual C++
public:
KeyframeOutput^ GetOutput(
    float frame
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Animation.GetOutput(System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Animation.GetOutput(System.Single)]

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
Animation..::.Preremove Method
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Animation.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animation Properties

[image] [image]

Mogware's Collada.Net Class Library
Animation Properties
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Animation type exposes the following members.

Properties

Name | Description
Channels |
Id |
KeyFrames |
MaxFrame |
MinFrame |
Samplers |
Sources |

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channels Property

[image]

Mogware's Collada.Net Class Library
Animation..::.Channels Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.Channels]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Channel> Channels { get; }
Visual Basic (Declaration)
Public ReadOnly Property Channels As List(Of Channel)
Visual C++
public:
property List<Channel^>^ Channels {
    List<Channel^>^ get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Animation..::.Id Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyFrames Property

[image]

Mogware's Collada.Net Class Library
Animation..::.KeyFrames Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.KeyFrames]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Keyframe> KeyFrames { get; }
Visual Basic (Declaration)
Public ReadOnly Property KeyFrames As List(Of Keyframe)
Visual C++
public:
property List<Keyframe^>^ KeyFrames {
    List<Keyframe^>^ get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


MaxFrame Property

[image]

Mogware's Collada.Net Class Library
Animation..::.MaxFrame Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.MaxFrame]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float MaxFrame { get; }
Visual Basic (Declaration)
Public ReadOnly Property MaxFrame As Single
Visual C++
public:
property float MaxFrame {
    float get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


MinFrame Property

[image]

Mogware's Collada.Net Class Library
Animation..::.MinFrame Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.MinFrame]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float MinFrame { get; }
Visual Basic (Declaration)
Public ReadOnly Property MinFrame As Single
Visual C++
public:
property float MinFrame {
    float get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Samplers Property

[image]

Mogware's Collada.Net Class Library
Animation..::.Samplers Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.Samplers]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SamplerList Samplers { get; }
Visual Basic (Declaration)
Public ReadOnly Property Samplers As SamplerList
Visual C++
public:
property SamplerList^ Samplers {
    SamplerList^ get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sources Property

[image]

Mogware's Collada.Net Class Library
Animation..::.Sources Property
Animation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Animation.Sources]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SourceList Sources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sources As SourceList
Visual C++
public:
property SourceList^ Sources {
    SourceList^ get ();
}

See Also

Animation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroup Class

[image]

Mogware's Collada.Net Class Library
AnimationGroup Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroup]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class AnimationGroup
Visual Basic (Declaration)
Public Class AnimationGroup
Visual C++
public ref class AnimationGroup

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.AnimationGroup

See Also

AnimationGroup Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroup Members

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroup Members
AnimationGroup Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroup type exposes the following members.

Constructors

Name | Description
AnimationGroup | Initializes a new instance of the AnimationGroup class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Animations |
JointName |

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroup Constructor

[image]

Mogware's Collada.Net Class Library
AnimationGroup Constructor
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the AnimationGroup class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationGroup(
    string jointName
)
Visual Basic (Declaration)
Public Sub New ( _
    jointName As String _
)
Visual C++
public:
AnimationGroup(
    String^ jointName
)

Parameters

jointName
Type: System..::.String

[Missing <param name="jointName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroup.#ctor(System.String)"]

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroup Methods

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroup Methods
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroup type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
AnimationGroup..::.Preremove Method
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroup.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroup Properties

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroup Properties
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroup type exposes the following members.

Properties

Name | Description
Animations |
JointName |

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Animations Property

[image]

Mogware's Collada.Net Class Library
AnimationGroup..::.Animations Property
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroup.Animations]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationList Animations { get; set; }
Visual Basic (Declaration)
Public Property Animations As AnimationList
Visual C++
public:
property AnimationList^ Animations {
    AnimationList^ get ();
    void set (AnimationList^ value);
}

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


JointName Property

[image]

Mogware's Collada.Net Class Library
AnimationGroup..::.JointName Property
AnimationGroup Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroup.JointName]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string JointName { get; set; }
Visual Basic (Declaration)
Public Property JointName As String
Visual C++
public:
property String^ JointName {
    String^ get ();
    void set (String^ value);
}

See Also

AnimationGroup Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroupList Class

[image]

Mogware's Collada.Net Class Library
AnimationGroupList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class AnimationGroupList : List<AnimationGroup>
Visual Basic (Declaration)
Public Class AnimationGroupList _
    Inherits List(Of AnimationGroup)
Visual C++
public ref class AnimationGroupList : public List<AnimationGroup^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( AnimationGroup >)>)
Mogware.VisualStudio.ColladaNet.Animations..::.AnimationGroupList

See Also

AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroupList Members

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList Members
AnimationGroupList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroupList type exposes the following members.

Constructors

Name | Description
AnimationGroupList | Initializes a new instance of the AnimationGroupList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
AddAnimation |
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( AnimationGroup >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( AnimationGroup >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( AnimationGroup >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( AnimationGroup >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( AnimationGroup >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroupList Constructor

[image]

Mogware's Collada.Net Class Library
AnimationGroupList Constructor
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the AnimationGroupList class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationGroupList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnimationGroupList()

See Also

AnimationGroupList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroupList Methods

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList Methods
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroupList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
AddAnimation |
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( AnimationGroup >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( AnimationGroup >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( AnimationGroup >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( AnimationGroup >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AddAnimation Method

[image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.AddAnimation Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.AddAnimation(Mogware.VisualStudio.ColladaNet.Animations.Animation)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void AddAnimation(
    Animation anim
)
Visual Basic (Declaration)
Public Sub AddAnimation ( _
    anim As Animation _
)
Visual C++
public:
void AddAnimation(
    Animation^ anim
)

Parameters

anim
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="anim"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.AddAnimation(Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

See Also

AnimationGroupList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.BinarySearch Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( AnimationGroup >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( AnimationGroup >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.CopyTo Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( AnimationGroup >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( AnimationGroup >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Find Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Find(String) |

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Find Method (String)
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationGroup Find(
    string jointName
)
Visual Basic (Declaration)
Public Function Find ( _
    jointName As String _
) As AnimationGroup
Visual C++
public:
AnimationGroup^ Find(
    String^ jointName
)

Parameters

jointName
Type: System..::.String

[Missing <param name="jointName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.Find(System.String)]

See Also

AnimationGroupList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.FindIndex Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( AnimationGroup >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.FindLastIndex Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.IndexOf Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( AnimationGroup >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.LastIndexOf Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Remove Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Remove Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Remove(String) |

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Remove Method (String)

[image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Remove Method (String)
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.Remove(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    string jointName
)
Visual Basic (Declaration)
Public Sub Remove ( _
    jointName As String _
)
Visual C++
public:
void Remove(
    String^ jointName
)

Parameters

jointName
Type: System..::.String

[Missing <param name="jointName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationGroupList.Remove(System.String)"]

See Also

AnimationGroupList Class
Remove Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Reverse Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList..::.Sort Method
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( AnimationGroup >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( AnimationGroup >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
AnimationGroupList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationGroupList Properties

[image] [image]

Mogware's Collada.Net Class Library
AnimationGroupList Properties
AnimationGroupList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationGroupList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( AnimationGroup >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( AnimationGroup >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( AnimationGroup >)>).)

See Also

AnimationGroupList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationList Class

[image]

Mogware's Collada.Net Class Library
AnimationList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.AnimationList]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class AnimationList : List<Animation>
Visual Basic (Declaration)
Public Class AnimationList _
    Inherits List(Of Animation)
Visual C++
public ref class AnimationList : public List<Animation^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Animation >)>)
Mogware.VisualStudio.ColladaNet.Animations..::.AnimationList

See Also

AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationList Members

[image] [image]

Mogware's Collada.Net Class Library
AnimationList Members
AnimationList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationList type exposes the following members.

Constructors

Name | Description
AnimationList | Initializes a new instance of the AnimationList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Animation >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Animation >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Animation >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Animation >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Animation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Animation >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Animation >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationList Constructor

[image]

Mogware's Collada.Net Class Library
AnimationList Constructor
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the AnimationList class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
AnimationList()

See Also

AnimationList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationList Methods

[image] [image]

Mogware's Collada.Net Class Library
AnimationList Methods
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Animation >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Animation >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Animation >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Animation >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Animation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Animation >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.BinarySearch Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Animation >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Animation >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.CopyTo Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Animation >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Animation >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.Find Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Find(String) |
Find(String, TargetAttribute) |

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
AnimationList..::.Find Method (String)
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Animation
Visual C++
public:
Animation^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String)]

See Also

AnimationList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method (String, TargetAttribute)

[image]

Mogware's Collada.Net Class Library
AnimationList..::.Find Method (String, TargetAttribute)
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String,Mogware.VisualStudio.ColladaNet.Animations.TargetAttribute)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation Find(
    string jointName,
    TargetAttribute attribute
)
Visual Basic (Declaration)
Public Function Find ( _
    jointName As String, _
    attribute As TargetAttribute _
) As Animation
Visual C++
public:
Animation^ Find(
    String^ jointName,
    TargetAttribute attribute
)

Parameters

jointName
Type: System..::.String

[Missing <param name="jointName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String,Mogware.VisualStudio.ColladaNet.Animations.TargetAttribute)"]

attribute
Type: Mogware.VisualStudio.ColladaNet.Animations..::.TargetAttribute

[Missing <param name="attribute"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String,Mogware.VisualStudio.ColladaNet.Animations.TargetAttribute)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.AnimationList.Find(System.String,Mogware.VisualStudio.ColladaNet.Animations.TargetAttribute)]

See Also

AnimationList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.FindIndex Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Animation >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.FindLastIndex Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Animation >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.IndexOf Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Animation >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.LastIndexOf Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Animation >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.Reverse Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
AnimationList..::.Sort Method
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Animation >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Animation >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
AnimationList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationList Properties

[image] [image]

Mogware's Collada.Net Class Library
AnimationList Properties
AnimationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Animation >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Animation >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Animation >)>).)

See Also

AnimationList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationSet Class

[image]

Mogware's Collada.Net Class Library
AnimationSet Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class AnimationSet
Visual Basic (Declaration)
Public Class AnimationSet
Visual C++
public ref class AnimationSet

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.AnimationSet

See Also

AnimationSet Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationSet Members

[image] [image]

Mogware's Collada.Net Class Library
AnimationSet Members
AnimationSet Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationSet type exposes the following members.

Constructors

Name | Description
AnimationSet | Initializes a new instance of the AnimationSet class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AnimationX |
AnimationY |
AnimationZ |
KeyFrames |

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationSet Constructor

[image]

Mogware's Collada.Net Class Library
AnimationSet Constructor
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the AnimationSet class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public AnimationSet(
    Animation animx,
    Animation animy,
    Animation animz
)
Visual Basic (Declaration)
Public Sub New ( _
    animx As Animation, _
    animy As Animation, _
    animz As Animation _
)
Visual C++
public:
AnimationSet(
    Animation^ animx,
    Animation^ animy,
    Animation^ animz
)

Parameters

animx
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="animx"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.#ctor(Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

animy
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="animy"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.#ctor(Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

animz
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="animz"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.#ctor(Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationSet Methods

[image] [image]

Mogware's Collada.Net Class Library
AnimationSet Methods
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationSet type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationSet Properties

[image] [image]

Mogware's Collada.Net Class Library
AnimationSet Properties
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The AnimationSet type exposes the following members.

Properties

Name | Description
AnimationX |
AnimationY |
AnimationZ |
KeyFrames |

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationX Property

[image]

Mogware's Collada.Net Class Library
AnimationSet..::.AnimationX Property
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.AnimationX]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation AnimationX { get; set; }
Visual Basic (Declaration)
Public Property AnimationX As Animation
Visual C++
public:
property Animation^ AnimationX {
    Animation^ get ();
    void set (Animation^ value);
}

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationY Property

[image]

Mogware's Collada.Net Class Library
AnimationSet..::.AnimationY Property
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.AnimationY]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation AnimationY { get; set; }
Visual Basic (Declaration)
Public Property AnimationY As Animation
Visual C++
public:
property Animation^ AnimationY {
    Animation^ get ();
    void set (Animation^ value);
}

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


AnimationZ Property

[image]

Mogware's Collada.Net Class Library
AnimationSet..::.AnimationZ Property
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.AnimationZ]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Animation AnimationZ { get; set; }
Visual Basic (Declaration)
Public Property AnimationZ As Animation
Visual C++
public:
property Animation^ AnimationZ {
    Animation^ get ();
    void set (Animation^ value);
}

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyFrames Property

[image]

Mogware's Collada.Net Class Library
AnimationSet..::.KeyFrames Property
AnimationSet Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.AnimationSet.KeyFrames]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Keyframe> KeyFrames { get; }
Visual Basic (Declaration)
Public ReadOnly Property KeyFrames As List(Of Keyframe)
Visual C++
public:
property List<Keyframe^>^ KeyFrames {
    List<Keyframe^>^ get ();
}

See Also

AnimationSet Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channel Class

[image]

Mogware's Collada.Net Class Library
Channel Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Channel]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Channel
Visual Basic (Declaration)
Public Class Channel
Visual C++
public ref class Channel

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Channel

See Also

Channel Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channel Members

[image] [image]

Mogware's Collada.Net Class Library
Channel Members
Channel Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Channel type exposes the following members.

Constructors

Name | Description
Channel | Initializes a new instance of the Channel class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Sampler |
Target |

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channel Constructor

[image]

Mogware's Collada.Net Class Library
Channel Constructor
Channel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Channel class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Channel(
    XmlElement element,
    Animation animation
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    animation As Animation _
)
Visual C++
public:
Channel(
    XmlElement^ element,
    Animation^ animation
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Channel.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

animation
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="animation"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Channel.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channel Methods

[image] [image]

Mogware's Collada.Net Class Library
Channel Methods
Channel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Channel type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Channel Properties

[image] [image]

Mogware's Collada.Net Class Library
Channel Properties
Channel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Channel type exposes the following members.

Properties

Name | Description
Sampler |
Target |

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Property

[image]

Mogware's Collada.Net Class Library
Channel..::.Sampler Property
Channel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Channel.Sampler]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Sampler Sampler { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sampler As Sampler
Visual C++
public:
property Sampler^ Sampler {
    Sampler^ get ();
}

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Property

[image]

Mogware's Collada.Net Class Library
Channel..::.Target Property
Channel Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Channel.Target]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Target Target { get; }
Visual Basic (Declaration)
Public ReadOnly Property Target As Target
Visual C++
public:
property Target^ Target {
    Target^ get ();
}

See Also

Channel Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolation Class

[image]

Mogware's Collada.Net Class Library
Interpolation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Interpolation]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Interpolation
Visual Basic (Declaration)
Public Class Interpolation
Visual C++
public ref class Interpolation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Interpolation

See Also

Interpolation Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolation Members

[image] [image]

Mogware's Collada.Net Class Library
Interpolation Members
Interpolation Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Interpolation type exposes the following members.

Constructors

Name | Description
Interpolation | Initializes a new instance of the Interpolation class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate |
InterpolateBezier |
InterpolateBSpline |
InterpolateCardinal |
InterpolateHermite |
InterpolateLinear |
InterpolateStep |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolation Constructor

[image]

Mogware's Collada.Net Class Library
Interpolation Constructor
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Interpolation class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Interpolation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Interpolation()

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolation Methods

[image] [image]

Mogware's Collada.Net Class Library
Interpolation Methods
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Interpolation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate |
InterpolateBezier |
InterpolateBSpline |
InterpolateCardinal |
InterpolateHermite |
InterpolateLinear |
InterpolateStep |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Parse |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.Interpolate Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float Interpolate(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1,
    InterpolationType type
)
Visual Basic (Declaration)
Public Shared Function Interpolate ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single, _
    type As InterpolationType _
) As Single
Visual C++
public:
static float Interpolate(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1,
    InterpolationType type
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

type
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Interpolate(System.Single,System.Single,System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateBezier Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateBezier Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateBezier(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateBezier ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateBezier(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBezier(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateBSpline Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateBSpline Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateBSpline(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateBSpline ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateBSpline(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateBSpline(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateCardinal Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateCardinal Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateCardinal(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateCardinal ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateCardinal(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateCardinal(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateHermite Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateHermite Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateHermite(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateHermite ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateHermite(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateHermite(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateLinear Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateLinear Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateLinear(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateLinear ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateLinear(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateLinear(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolateStep Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.InterpolateStep Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static float InterpolateStep(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)
Visual Basic (Declaration)
Public Shared Function InterpolateStep ( _
    frame As Single, _
    frame0 As Single, _
    output0 As Single, _
    frame1 As Single, _
    output1 As Single _
) As Single
Visual C++
public:
static float InterpolateStep(
    float frame,
    float frame0,
    float output0,
    float frame1,
    float output1
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output0
Type: System..::.Single

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)"]

output1
Type: System..::.Single

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.InterpolateStep(System.Single,System.Single,System.Single,System.Single,System.Single)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Parse Method

[image]

Mogware's Collada.Net Class Library
Interpolation..::.Parse Method
Interpolation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Parse(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static InterpolationType Parse(
    string interpolation
)
Visual Basic (Declaration)
Public Shared Function Parse ( _
    interpolation As String _
) As InterpolationType
Visual C++
public:
static InterpolationType Parse(
    String^ interpolation
)

Parameters

interpolation
Type: System..::.String

[Missing <param name="interpolation"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Parse(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.Interpolation.Parse(System.String)]

See Also

Interpolation Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


InterpolationType Enumeration

[image]

Mogware's Collada.Net Class Library
InterpolationType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.InterpolationType]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum InterpolationType
Visual Basic (Declaration)
Public Enumeration InterpolationType
Visual C++
public enum class InterpolationType

Members

Member name | Description
STEP |
LINEAR |
BEZIER |
HERMITE |
CARDINAL |
BSPLINE |

See Also

Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Class

[image]

Mogware's Collada.Net Class Library
Keyframe Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Keyframe]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Keyframe
Visual Basic (Declaration)
Public Class Keyframe
Visual C++
public ref class Keyframe

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Keyframe

See Also

Keyframe Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Members

[image] [image]

Mogware's Collada.Net Class Library
Keyframe Members
Keyframe Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Keyframe type exposes the following members.

Constructors

Name | Description
Keyframe | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Frame |
Interpolation |
Output |

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Constructor

[image] [image]

Mogware's Collada.Net Class Library
Keyframe Constructor
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Keyframe(Single, KeyframeOutput) | Initializes a new instance of the Keyframe class
Keyframe(Single, KeyframeOutput, InterpolationType) | Initializes a new instance of the Keyframe class

See Also

Keyframe Class
Keyframe Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Constructor (Single, KeyframeOutput)

[image]

Mogware's Collada.Net Class Library
Keyframe Constructor (Single, KeyframeOutput)
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Keyframe class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Keyframe(
    float frame,
    KeyframeOutput output
)
Visual Basic (Declaration)
Public Sub New ( _
    frame As Single, _
    output As KeyframeOutput _
)
Visual C++
public:
Keyframe(
    float frame,
    KeyframeOutput^ output
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

output
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput)"]

See Also

Keyframe Class
Keyframe Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Constructor (Single, KeyframeOutput, InterpolationType)

[image]

Mogware's Collada.Net Class Library
Keyframe Constructor (Single, KeyframeOutput, InterpolationType)
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Keyframe class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Keyframe(
    float frame,
    KeyframeOutput output,
    InterpolationType interpolation
)
Visual Basic (Declaration)
Public Sub New ( _
    frame As Single, _
    output As KeyframeOutput, _
    interpolation As InterpolationType _
)
Visual C++
public:
Keyframe(
    float frame,
    KeyframeOutput^ output,
    InterpolationType interpolation
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

interpolation
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="interpolation"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.#ctor(System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

See Also

Keyframe Class
Keyframe Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Methods

[image] [image]

Mogware's Collada.Net Class Library
Keyframe Methods
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Keyframe type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Keyframe Properties

[image] [image]

Mogware's Collada.Net Class Library
Keyframe Properties
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Keyframe type exposes the following members.

Properties

Name | Description
Frame |
Interpolation |
Output |

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Frame Property

[image]

Mogware's Collada.Net Class Library
Keyframe..::.Frame Property
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.Frame]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Frame { get; set; }
Visual Basic (Declaration)
Public Property Frame As Single
Visual C++
public:
property float Frame {
    float get ();
    void set (float value);
}

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolation Property

[image]

Mogware's Collada.Net Class Library
Keyframe..::.Interpolation Property
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.Interpolation]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InterpolationType Interpolation { get; set; }
Visual Basic (Declaration)
Public Property Interpolation As InterpolationType
Visual C++
public:
property InterpolationType Interpolation {
    InterpolationType get ();
    void set (InterpolationType value);
}

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Output Property

[image]

Mogware's Collada.Net Class Library
Keyframe..::.Output Property
Keyframe Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Keyframe.Output]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public KeyframeOutput Output { get; set; }
Visual Basic (Declaration)
Public Property Output As KeyframeOutput
Visual C++
public:
property KeyframeOutput^ Output {
    KeyframeOutput^ get ();
    void set (KeyframeOutput^ value);
}

See Also

Keyframe Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeFloatOutput Class

[image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class KeyframeFloatOutput : KeyframeOutput
Visual Basic (Declaration)
Public Class KeyframeFloatOutput _
    Inherits KeyframeOutput
Visual C++
public ref class KeyframeFloatOutput : public KeyframeOutput

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeFloatOutput

See Also

KeyframeFloatOutput Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeFloatOutput Members

[image] [image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput Members
KeyframeFloatOutput Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeFloatOutput type exposes the following members.

Constructors

Name | Description
KeyframeFloatOutput | Initializes a new instance of the KeyframeFloatOutput class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | (Overrides KeyframeOutput..::.Interpolate(Single, Single, Single, KeyframeOutput, InterpolationType).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Float |

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeFloatOutput Constructor

[image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput Constructor
KeyframeFloatOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the KeyframeFloatOutput class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public KeyframeFloatOutput(
    float output
)
Visual Basic (Declaration)
Public Sub New ( _
    output As Single _
)
Visual C++
public:
KeyframeFloatOutput(
    float output
)

Parameters

output
Type: System..::.Single

[Missing <param name="output"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.#ctor(System.Single)"]

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeFloatOutput Methods

[image] [image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput Methods
KeyframeFloatOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeFloatOutput type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | (Overrides KeyframeOutput..::.Interpolate(Single, Single, Single, KeyframeOutput, InterpolationType).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method

[image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput..::.Interpolate Method
KeyframeFloatOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected override KeyframeOutput Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput output1,
    InterpolationType type
)
Visual Basic (Declaration)
Protected Overrides Function Interpolate ( _
    frame As Single, _
    frame0 As Single, _
    frame1 As Single, _
    output1 As KeyframeOutput, _
    type As InterpolationType _
) As KeyframeOutput
Visual C++
protected:
virtual KeyframeOutput^ Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput^ output1,
    InterpolationType type
) override

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output1
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

type
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeFloatOutput Properties

[image] [image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput Properties
KeyframeFloatOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeFloatOutput type exposes the following members.

Properties

Name | Description
Float |

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Float Property

[image]

Mogware's Collada.Net Class Library
KeyframeFloatOutput..::.Float Property
KeyframeFloatOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.KeyframeFloatOutput.Float]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Float { get; set; }
Visual Basic (Declaration)
Public Property Float As Single
Visual C++
public:
property float Float {
    float get ();
    void set (float value);
}

See Also

KeyframeFloatOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeOutput Class

[image]

Mogware's Collada.Net Class Library
KeyframeOutput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class KeyframeOutput
Visual Basic (Declaration)
Public MustInherit Class KeyframeOutput
Visual C++
public ref class KeyframeOutput abstract

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeFloatOutput
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeVectorOutput

See Also

KeyframeOutput Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeOutput Members

[image] [image]

Mogware's Collada.Net Class Library
KeyframeOutput Members
KeyframeOutput Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeOutput type exposes the following members.

Constructors

Name | Description
KeyframeOutput | Initializes a new instance of the KeyframeOutput class

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyframeOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeOutput Constructor

[image]

Mogware's Collada.Net Class Library
KeyframeOutput Constructor
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the KeyframeOutput class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected KeyframeOutput()
Visual Basic (Declaration)
Protected Sub New
Visual C++
protected:
KeyframeOutput()

See Also

KeyframeOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeOutput Methods

[image] [image]

Mogware's Collada.Net Class Library
KeyframeOutput Methods
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeOutput type exposes the following members.

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyframeOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Create Method

[image]

Mogware's Collada.Net Class Library
KeyframeOutput..::.Create Method
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Create(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static KeyframeOutput Create(
    Object output
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    output As Object _
) As KeyframeOutput
Visual C++
public:
static KeyframeOutput^ Create(
    Object^ output
)

Parameters

output
Type: System..::.Object

[Missing <param name="output"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Create(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Create(System.Object)]

See Also

KeyframeOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method

[image] [image]

Mogware's Collada.Net Class Library
KeyframeOutput..::.Interpolate Method
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Interpolate(Single, Single, Single, KeyframeOutput, InterpolationType) |
Interpolate(Single, Single, KeyframeOutput, Single, KeyframeOutput, InterpolationType) |

See Also

KeyframeOutput Class
KeyframeOutput Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method (Single, Single, Single, KeyframeOutput, InterpolationType)

[image]

Mogware's Collada.Net Class Library
KeyframeOutput..::.Interpolate Method (Single, Single, Single, KeyframeOutput, InterpolationType)
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected abstract KeyframeOutput Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput output1,
    InterpolationType interpolation
)
Visual Basic (Declaration)
Protected MustOverride Function Interpolate ( _
    frame As Single, _
    frame0 As Single, _
    frame1 As Single, _
    output1 As KeyframeOutput, _
    interpolation As InterpolationType _
) As KeyframeOutput
Visual C++
protected:
virtual KeyframeOutput^ Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput^ output1,
    InterpolationType interpolation
) abstract

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output1
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

interpolation
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="interpolation"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

See Also

KeyframeOutput Class
Interpolate Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method (Single, Single, KeyframeOutput, Single, KeyframeOutput, InterpolationType)

[image]

Mogware's Collada.Net Class Library
KeyframeOutput..::.Interpolate Method (Single, Single, KeyframeOutput, Single, KeyframeOutput, InterpolationType)
KeyframeOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static KeyframeOutput Interpolate(
    float frame,
    float frame0,
    KeyframeOutput output0,
    float frame1,
    KeyframeOutput output1,
    InterpolationType type
)
Visual Basic (Declaration)
Public Shared Function Interpolate ( _
    frame As Single, _
    frame0 As Single, _
    output0 As KeyframeOutput, _
    frame1 As Single, _
    output1 As KeyframeOutput, _
    type As InterpolationType _
) As KeyframeOutput
Visual C++
public:
static KeyframeOutput^ Interpolate(
    float frame,
    float frame0,
    KeyframeOutput^ output0,
    float frame1,
    KeyframeOutput^ output1,
    InterpolationType type
)

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output0
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output1
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

type
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput.Interpolate(System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

See Also

KeyframeOutput Class
Interpolate Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeVectorOutput Class

[image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class KeyframeVectorOutput : KeyframeOutput
Visual Basic (Declaration)
Public Class KeyframeVectorOutput _
    Inherits KeyframeOutput
Visual C++
public ref class KeyframeVectorOutput : public KeyframeOutput

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput
Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeVectorOutput

See Also

KeyframeVectorOutput Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeVectorOutput Members

[image] [image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput Members
KeyframeVectorOutput Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeVectorOutput type exposes the following members.

Constructors

Name | Description
KeyframeVectorOutput | Initializes a new instance of the KeyframeVectorOutput class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | (Overrides KeyframeOutput..::.Interpolate(Single, Single, Single, KeyframeOutput, InterpolationType).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Vector |

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeVectorOutput Constructor

[image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput Constructor
KeyframeVectorOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the KeyframeVectorOutput class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public KeyframeVectorOutput(
    float x,
    float y,
    float z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
KeyframeVectorOutput(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.#ctor(System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.#ctor(System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.#ctor(System.Single,System.Single,System.Single)"]

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeVectorOutput Methods

[image] [image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput Methods
KeyframeVectorOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeVectorOutput type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Interpolate | (Overrides KeyframeOutput..::.Interpolate(Single, Single, Single, KeyframeOutput, InterpolationType).)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Interpolate Method

[image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput..::.Interpolate Method
KeyframeVectorOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected override KeyframeOutput Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput output1,
    InterpolationType type
)
Visual Basic (Declaration)
Protected Overrides Function Interpolate ( _
    frame As Single, _
    frame0 As Single, _
    frame1 As Single, _
    output1 As KeyframeOutput, _
    type As InterpolationType _
) As KeyframeOutput
Visual C++
protected:
virtual KeyframeOutput^ Interpolate(
    float frame,
    float frame0,
    float frame1,
    KeyframeOutput^ output1,
    InterpolationType type
) override

Parameters

frame
Type: System..::.Single

[Missing <param name="frame"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame0
Type: System..::.Single

[Missing <param name="frame0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

frame1
Type: System..::.Single

[Missing <param name="frame1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

output1
Type: Mogware.VisualStudio.ColladaNet.Animations..::.KeyframeOutput

[Missing <param name="output1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

type
Type: Mogware.VisualStudio.ColladaNet.Animations..::.InterpolationType

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Interpolate(System.Single,System.Single,System.Single,Mogware.VisualStudio.ColladaNet.Animations.KeyframeOutput,Mogware.VisualStudio.ColladaNet.Animations.InterpolationType)]

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


KeyframeVectorOutput Properties

[image] [image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput Properties
KeyframeVectorOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The KeyframeVectorOutput type exposes the following members.

Properties

Name | Description
Vector |

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Vector Property

[image]

Mogware's Collada.Net Class Library
KeyframeVectorOutput..::.Vector Property
KeyframeVectorOutput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.KeyframeVectorOutput.Vector]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 Vector { get; set; }
Visual Basic (Declaration)
Public Property Vector As Vector3
Visual C++
public:
property Vector3 Vector {
    Vector3 get ();
    void set (Vector3 value);
}

See Also

KeyframeVectorOutput Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Class

[image]

Mogware's Collada.Net Class Library
Sampler Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Sampler]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Sampler
Visual Basic (Declaration)
Public Class Sampler
Visual C++
public ref class Sampler

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Sampler

See Also

Sampler Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Members

[image] [image]

Mogware's Collada.Net Class Library
Sampler Members
Sampler Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Constructors

Name | Description
Sampler | Initializes a new instance of the Sampler class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Inputs |

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Constructor

[image]

Mogware's Collada.Net Class Library
Sampler Constructor
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Sampler class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Sampler(
    XmlElement element,
    Animation animation
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    animation As Animation _
)
Visual C++
public:
Sampler(
    XmlElement^ element,
    Animation^ animation
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Sampler.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

animation
Type: Mogware.VisualStudio.ColladaNet.Animations..::.Animation

[Missing <param name="animation"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Sampler.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Animations.Animation)"]

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Methods

[image] [image]

Mogware's Collada.Net Class Library
Sampler Methods
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sampler Properties

[image] [image]

Mogware's Collada.Net Class Library
Sampler Properties
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Properties

Name | Description
Id |
Inputs |

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.Id Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Sampler.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Inputs Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.Inputs Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Sampler.Inputs]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InputList Inputs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inputs As InputList
Visual C++
public:
property InputList^ Inputs {
    InputList^ get ();
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


SamplerList Class

[image]

Mogware's Collada.Net Class Library
SamplerList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.SamplerList]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class SamplerList : List<Sampler>
Visual Basic (Declaration)
Public Class SamplerList _
    Inherits List(Of Sampler)
Visual C++
public ref class SamplerList : public List<Sampler^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Sampler >)>)
Mogware.VisualStudio.ColladaNet.Animations..::.SamplerList

See Also

SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


SamplerList Members

[image] [image]

Mogware's Collada.Net Class Library
SamplerList Members
SamplerList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SamplerList type exposes the following members.

Constructors

Name | Description
SamplerList | Initializes a new instance of the SamplerList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Sampler >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Sampler >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Sampler >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Sampler >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Sampler >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Sampler >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Sampler >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


SamplerList Constructor

[image]

Mogware's Collada.Net Class Library
SamplerList Constructor
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the SamplerList class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SamplerList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
SamplerList()

See Also

SamplerList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


SamplerList Methods

[image] [image]

Mogware's Collada.Net Class Library
SamplerList Methods
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SamplerList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Sampler >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Sampler >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Sampler >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Sampler >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Sampler >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Sampler >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.BinarySearch Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Sampler >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Sampler >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.CopyTo Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Sampler >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Sampler >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.Find Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Find(String) |

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
SamplerList..::.Find Method (String)
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.SamplerList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Sampler Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Sampler
Visual C++
public:
Sampler^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.SamplerList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Animations.SamplerList.Find(System.String)]

See Also

SamplerList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.FindIndex Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Sampler >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.FindLastIndex Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Sampler >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.IndexOf Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Sampler >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.LastIndexOf Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Sampler >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.Reverse Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
SamplerList..::.Sort Method
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Sampler >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Sampler >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
SamplerList Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


SamplerList Properties

[image] [image]

Mogware's Collada.Net Class Library
SamplerList Properties
SamplerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The SamplerList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Sampler >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Sampler >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Sampler >)>).)

See Also

SamplerList Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Class

[image]

Mogware's Collada.Net Class Library
Target Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.Target]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Target
Visual Basic (Declaration)
Public Class Target
Visual C++
public ref class Target

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Animations..::.Target

See Also

Target Members
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Members

[image] [image]

Mogware's Collada.Net Class Library
Target Members
Target Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Target type exposes the following members.

Constructors

Name | Description
Target | Initializes a new instance of the Target class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Name |
TargetType |

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Constructor

[image]

Mogware's Collada.Net Class Library
Target Constructor
Target Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Target class

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Target(
    string text
)
Visual Basic (Declaration)
Public Sub New ( _
    text As String _
)
Visual C++
public:
Target(
    String^ text
)

Parameters

text
Type: System..::.String

[Missing <param name="text"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Animations.Target.#ctor(System.String)"]

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Methods

[image] [image]

Mogware's Collada.Net Class Library
Target Methods
Target Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Target type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Target Properties

[image] [image]

Mogware's Collada.Net Class Library
Target Properties
Target Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Target type exposes the following members.

Properties

Name | Description
Name |
TargetType |

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Target..::.Name Property
Target Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Target.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


TargetType Property

[image]

Mogware's Collada.Net Class Library
Target..::.TargetType Property
Target Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Animations.Target.TargetType]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TargetAttribute TargetType { get; set; }
Visual Basic (Declaration)
Public Property TargetType As TargetAttribute
Visual C++
public:
property TargetAttribute TargetType {
    TargetAttribute get ();
    void set (TargetAttribute value);
}

See Also

Target Class
Mogware.VisualStudio.ColladaNet.Animations Namespace


TargetAttribute Enumeration

[image]

Mogware's Collada.Net Class Library
TargetAttribute Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Animations.TargetAttribute]

Namespace: Mogware.VisualStudio.ColladaNet.Animations
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum TargetAttribute
Visual Basic (Declaration)
Public Enumeration TargetAttribute
Visual C++
public enum class TargetAttribute

Members

Member name | Description
Rotate |
RotateX |
RotateY |
RotateZ |
Translate |
TranslateX |
TranslateY |
TranslateZ |
Scale |
ScaleX |
ScaleY |
ScaleZ |

See Also

Mogware.VisualStudio.ColladaNet.Animations Namespace


Mogware.VisualStudio.ColladaNet.Camera Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Camera Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Camera]

Classes

Class | Description
Camera |
Lens |

Enumerations

Enumeration | Description
LensType |


Camera Class

[image]

Mogware's Collada.Net Class Library
Camera Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Camera.Camera]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Camera
Visual Basic (Declaration)
Public Class Camera
Visual C++
public ref class Camera

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Camera..::.Camera

See Also

Camera Members
Mogware.VisualStudio.ColladaNet.Camera Namespace


Camera Members

[image] [image]

Mogware's Collada.Net Class Library
Camera Members
Camera Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Camera type exposes the following members.

Constructors

Name | Description
Camera | Initializes a new instance of the Camera class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Lens |
Name |

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Camera Constructor

[image]

Mogware's Collada.Net Class Library
Camera Constructor
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Camera class

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Camera(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Camera(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Camera.Camera.#ctor(System.Xml.XmlElement)"]

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Camera Methods

[image] [image]

Mogware's Collada.Net Class Library
Camera Methods
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Camera type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Camera..::.Presave Method
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Camera.Camera.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Camera Properties

[image] [image]

Mogware's Collada.Net Class Library
Camera Properties
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Camera type exposes the following members.

Properties

Name | Description
Id |
Lens |
Name |

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Camera..::.Id Property
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Camera.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Property

[image]

Mogware's Collada.Net Class Library
Camera..::.Lens Property
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Camera.Lens]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Lens Lens { get; set; }
Visual Basic (Declaration)
Public Property Lens As Lens
Visual C++
public:
property Lens^ Lens {
    Lens^ get ();
    void set (Lens^ value);
}

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Camera..::.Name Property
Camera Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Camera.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Camera Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Class

[image]

Mogware's Collada.Net Class Library
Lens Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Camera.Lens]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Lens
Visual Basic (Declaration)
Public Class Lens
Visual C++
public ref class Lens

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Camera..::.Lens

See Also

Lens Members
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Members

[image] [image]

Mogware's Collada.Net Class Library
Lens Members
Lens Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lens type exposes the following members.

Constructors

Name | Description
Lens | Initializes a new instance of the Lens class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AspectRatio |
LensType |
XFov |
XMag |
YFov |
YMag |
ZFar |
ZNear |

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Constructor

[image]

Mogware's Collada.Net Class Library
Lens Constructor
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Lens class

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Lens(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Lens(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Camera.Lens.#ctor(System.Xml.XmlElement)"]

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Methods

[image] [image]

Mogware's Collada.Net Class Library
Lens Methods
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lens type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


Lens Properties

[image] [image]

Mogware's Collada.Net Class Library
Lens Properties
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lens type exposes the following members.

Properties

Name | Description
AspectRatio |
LensType |
XFov |
XMag |
YFov |
YMag |
ZFar |
ZNear |

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


AspectRatio Property

[image]

Mogware's Collada.Net Class Library
Lens..::.AspectRatio Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.AspectRatio]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float AspectRatio { get; set; }
Visual Basic (Declaration)
Public Property AspectRatio As Single
Visual C++
public:
property float AspectRatio {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


LensType Property

[image]

Mogware's Collada.Net Class Library
Lens..::.LensType Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.LensType]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public LensType LensType { get; set; }
Visual Basic (Declaration)
Public Property LensType As LensType
Visual C++
public:
property LensType LensType {
    LensType get ();
    void set (LensType value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


XFov Property

[image]

Mogware's Collada.Net Class Library
Lens..::.XFov Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.XFov]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float XFov { get; set; }
Visual Basic (Declaration)
Public Property XFov As Single
Visual C++
public:
property float XFov {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


XMag Property

[image]

Mogware's Collada.Net Class Library
Lens..::.XMag Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.XMag]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float XMag { get; set; }
Visual Basic (Declaration)
Public Property XMag As Single
Visual C++
public:
property float XMag {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


YFov Property

[image]

Mogware's Collada.Net Class Library
Lens..::.YFov Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.YFov]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float YFov { get; set; }
Visual Basic (Declaration)
Public Property YFov As Single
Visual C++
public:
property float YFov {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


YMag Property

[image]

Mogware's Collada.Net Class Library
Lens..::.YMag Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.YMag]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float YMag { get; set; }
Visual Basic (Declaration)
Public Property YMag As Single
Visual C++
public:
property float YMag {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


ZFar Property

[image]

Mogware's Collada.Net Class Library
Lens..::.ZFar Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.ZFar]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float ZFar { get; set; }
Visual Basic (Declaration)
Public Property ZFar As Single
Visual C++
public:
property float ZFar {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


ZNear Property

[image]

Mogware's Collada.Net Class Library
Lens..::.ZNear Property
Lens Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Camera.Lens.ZNear]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float ZNear { get; set; }
Visual Basic (Declaration)
Public Property ZNear As Single
Visual C++
public:
property float ZNear {
    float get ();
    void set (float value);
}

See Also

Lens Class
Mogware.VisualStudio.ColladaNet.Camera Namespace


LensType Enumeration

[image]

Mogware's Collada.Net Class Library
LensType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Camera.LensType]

Namespace: Mogware.VisualStudio.ColladaNet.Camera
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum LensType
Visual Basic (Declaration)
Public Enumeration LensType
Visual C++
public enum class LensType

Members

Member name | Description
Perspective |
Orthographic |

See Also

Mogware.VisualStudio.ColladaNet.Camera Namespace


Mogware.VisualStudio.ColladaNet.Effects Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Effects Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Effects]

Classes

Class | Description
Blinn |
ChannelInput |
ColorInput |
Effect |
EffectList |
Lambert |
Parameter |
ParameterContainer |
ParameterList |
ParameterTexture |
Phong |
Profile |
ProfileList |
Sampler |
Surface |
Technique |
TechniqueList |
Texture |
TextureInput |

Enumerations

Enumeration | Description
FilterType |
ProfileType |
SamplerType |
SurfaceFormat |
SurfaceType |
WrapMode |


Blinn Class

[image]

Mogware's Collada.Net Class Library
Blinn Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Blinn]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Blinn : Technique
Visual Basic (Declaration)
Public Class Blinn _
    Inherits Technique
Visual C++
public ref class Blinn : public Technique

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Technique
Mogware.VisualStudio.ColladaNet.Effects..::.Blinn
Mogware.VisualStudio.ColladaNet.Effects..::.Phong

See Also

Blinn Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blinn Members

[image] [image]

Mogware's Collada.Net Class Library
Blinn Members
Blinn Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Blinn type exposes the following members.

Constructors

Name | Description
Blinn | Initializes a new instance of the Blinn class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Ambient |
Diffuse |
Document | (Inherited from ParameterContainer.)
Emission |
Id | (Inherited from Technique.)
IndexOfRefraction |
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Reflective |
Reflectivity |
Shininess |
Sid | (Inherited from Technique.)
Specular |
Transparency |
Transparent |

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blinn Constructor

[image]

Mogware's Collada.Net Class Library
Blinn Constructor
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Blinn class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Blinn(
    XmlElement element,
    Profile profile
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    profile As Profile _
)
Visual C++
public:
Blinn(
    XmlElement^ element,
    Profile^ profile
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Blinn.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

profile
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Profile

[Missing <param name="profile"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Blinn.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blinn Fields

[image] [image]

Mogware's Collada.Net Class Library
Blinn Fields
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Blinn type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blinn Methods

[image] [image]

Mogware's Collada.Net Class Library
Blinn Methods
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Blinn type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blinn Properties

[image] [image]

Mogware's Collada.Net Class Library
Blinn Properties
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Blinn type exposes the following members.

Properties

Name | Description
Ambient |
Diffuse |
Document | (Inherited from ParameterContainer.)
Emission |
Id | (Inherited from Technique.)
IndexOfRefraction |
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Reflective |
Reflectivity |
Shininess |
Sid | (Inherited from Technique.)
Specular |
Transparency |
Transparent |

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Ambient Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Ambient Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Ambient]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Ambient { get; set; }
Visual Basic (Declaration)
Public Property Ambient As ColorInput
Visual C++
public:
property ColorInput^ Ambient {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Diffuse Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Diffuse Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Diffuse]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ChannelInput Diffuse { get; set; }
Visual Basic (Declaration)
Public Property Diffuse As ChannelInput
Visual C++
public:
property ChannelInput^ Diffuse {
    ChannelInput^ get ();
    void set (ChannelInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Emission Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Emission Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Emission]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Emission { get; set; }
Visual Basic (Declaration)
Public Property Emission As ColorInput
Visual C++
public:
property ColorInput^ Emission {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


IndexOfRefraction Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.IndexOfRefraction Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.IndexOfRefraction]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float IndexOfRefraction { get; set; }
Visual Basic (Declaration)
Public Property IndexOfRefraction As Single
Visual C++
public:
property float IndexOfRefraction {
    float get ();
    void set (float value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reflective Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Reflective Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Reflective]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Reflective { get; set; }
Visual Basic (Declaration)
Public Property Reflective As ColorInput
Visual C++
public:
property ColorInput^ Reflective {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reflectivity Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Reflectivity Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Reflectivity]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Reflectivity { get; set; }
Visual Basic (Declaration)
Public Property Reflectivity As Single
Visual C++
public:
property float Reflectivity {
    float get ();
    void set (float value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Shininess Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Shininess Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Shininess]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Shininess { get; set; }
Visual Basic (Declaration)
Public Property Shininess As Single
Visual C++
public:
property float Shininess {
    float get ();
    void set (float value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Specular Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Specular Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Specular]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Specular { get; set; }
Visual Basic (Declaration)
Public Property Specular As ColorInput
Visual C++
public:
property ColorInput^ Specular {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Transparency Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Transparency Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Transparency]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Transparency { get; set; }
Visual Basic (Declaration)
Public Property Transparency As Single
Visual C++
public:
property float Transparency {
    float get ();
    void set (float value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Transparent Property

[image]

Mogware's Collada.Net Class Library
Blinn..::.Transparent Property
Blinn Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Blinn.Transparent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Transparent { get; set; }
Visual Basic (Declaration)
Public Property Transparent As ColorInput
Visual C++
public:
property ColorInput^ Transparent {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Blinn Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ChannelInput Class

[image]

Mogware's Collada.Net Class Library
ChannelInput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ChannelInput
Visual Basic (Declaration)
Public Class ChannelInput
Visual C++
public ref class ChannelInput

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ChannelInput
Mogware.VisualStudio.ColladaNet.Effects..::.ColorInput
Mogware.VisualStudio.ColladaNet.Effects..::.TextureInput

See Also

ChannelInput Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ChannelInput Members

[image] [image]

Mogware's Collada.Net Class Library
ChannelInput Members
ChannelInput Class Constructors Methods See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChannelInput type exposes the following members.

Constructors

Name | Description
ChannelInput | Initializes a new instance of the ChannelInput class

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ChannelInput Constructor

[image]

Mogware's Collada.Net Class Library
ChannelInput Constructor
ChannelInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ChannelInput class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected ChannelInput(
    XmlElement element
)
Visual Basic (Declaration)
Protected Sub New ( _
    element As XmlElement _
)
Visual C++
protected:
ChannelInput(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput.#ctor(System.Xml.XmlElement)"]

See Also

ChannelInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ChannelInput Methods

[image] [image]

Mogware's Collada.Net Class Library
ChannelInput Methods
ChannelInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ChannelInput type exposes the following members.

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ChannelInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Create Method

[image]

Mogware's Collada.Net Class Library
ChannelInput..::.Create Method
ChannelInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static ChannelInput Create(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    element As XmlElement, _
    container As ParameterContainer _
) As ChannelInput
Visual C++
public:
static ChannelInput^ Create(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ChannelInput.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)]

See Also

ChannelInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ColorInput Class

[image]

Mogware's Collada.Net Class Library
ColorInput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ColorInput]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ColorInput : ChannelInput
Visual Basic (Declaration)
Public Class ColorInput _
    Inherits ChannelInput
Visual C++
public ref class ColorInput : public ChannelInput

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ChannelInput
Mogware.VisualStudio.ColladaNet.Effects..::.ColorInput

See Also

ColorInput Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ColorInput Members

[image] [image]

Mogware's Collada.Net Class Library
ColorInput Members
ColorInput Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColorInput type exposes the following members.

Constructors

Name | Description
ColorInput | Initializes a new instance of the ColorInput class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Alpha |
Blue |
Color |
Green |
Red |

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ColorInput Constructor

[image]

Mogware's Collada.Net Class Library
ColorInput Constructor
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ColorInput class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
ColorInput(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.#ctor(System.Xml.XmlElement)"]

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ColorInput Methods

[image] [image]

Mogware's Collada.Net Class Library
ColorInput Methods
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColorInput type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ColorInput Properties

[image] [image]

Mogware's Collada.Net Class Library
ColorInput Properties
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ColorInput type exposes the following members.

Properties

Name | Description
Alpha |
Blue |
Color |
Green |
Red |

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Alpha Property

[image]

Mogware's Collada.Net Class Library
ColorInput..::.Alpha Property
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.Alpha]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Alpha { get; set; }
Visual Basic (Declaration)
Public Property Alpha As Single
Visual C++
public:
property float Alpha {
    float get ();
    void set (float value);
}

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Blue Property

[image]

Mogware's Collada.Net Class Library
ColorInput..::.Blue Property
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.Blue]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Blue { get; set; }
Visual Basic (Declaration)
Public Property Blue As Single
Visual C++
public:
property float Blue {
    float get ();
    void set (float value);
}

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Color Property

[image]

Mogware's Collada.Net Class Library
ColorInput..::.Color Property
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.Color]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Color Color { get; }
Visual Basic (Declaration)
Public ReadOnly Property Color As Color
Visual C++
public:
property Color Color {
    Color get ();
}

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Green Property

[image]

Mogware's Collada.Net Class Library
ColorInput..::.Green Property
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.Green]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Green { get; set; }
Visual Basic (Declaration)
Public Property Green As Single
Visual C++
public:
property float Green {
    float get ();
    void set (float value);
}

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Red Property

[image]

Mogware's Collada.Net Class Library
ColorInput..::.Red Property
ColorInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ColorInput.Red]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Red { get; set; }
Visual Basic (Declaration)
Public Property Red As Single
Visual C++
public:
property float Red {
    float get ();
    void set (float value);
}

See Also

ColorInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Class

[image]

Mogware's Collada.Net Class Library
Effect Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Effect]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Effect : ParameterContainer
Visual Basic (Declaration)
Public Class Effect _
    Inherits ParameterContainer
Visual C++
public ref class Effect : public ParameterContainer

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Effect

See Also

Effect Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Members

[image] [image]

Mogware's Collada.Net Class Library
Effect Members
Effect Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Effect type exposes the following members.

Constructors

Name | Description
Effect | Initializes a new instance of the Effect class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Document | (Overrides ParameterContainer..::.Document.)
Id |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Profiles |

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Constructor

[image]

Mogware's Collada.Net Class Library
Effect Constructor
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Effect class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Effect(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
Effect(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Effect.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Effect.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Fields

[image] [image]

Mogware's Collada.Net Class Library
Effect Fields
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Effect type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Methods

[image] [image]

Mogware's Collada.Net Class Library
Effect Methods
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Effect type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Properties

[image] [image]

Mogware's Collada.Net Class Library
Effect Properties
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Effect type exposes the following members.

Properties

Name | Description
Document | (Overrides ParameterContainer..::.Document.)
Id |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Profiles |

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Document Property

[image]

Mogware's Collada.Net Class Library
Effect..::.Document Property
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Effect.Document]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override ColladaDocument Document { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Document As ColladaDocument
Visual C++
public:
virtual property ColladaDocument^ Document {
    ColladaDocument^ get () override;
}

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Effect..::.Id Property
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Effect.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parent Property

[image]

Mogware's Collada.Net Class Library
Effect..::.Parent Property
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Effect.Parent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override ParameterContainer Parent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Parent As ParameterContainer
Visual C++
public:
virtual property ParameterContainer^ Parent {
    ParameterContainer^ get () override;
}

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profiles Property

[image]

Mogware's Collada.Net Class Library
Effect..::.Profiles Property
Effect Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Effect.Profiles]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ProfileList Profiles { get; }
Visual Basic (Declaration)
Public ReadOnly Property Profiles As ProfileList
Visual C++
public:
property ProfileList^ Profiles {
    ProfileList^ get ();
}

See Also

Effect Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


EffectList Class

[image]

Mogware's Collada.Net Class Library
EffectList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.EffectList]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class EffectList : List<Effect>
Visual Basic (Declaration)
Public Class EffectList _
    Inherits List(Of Effect)
Visual C++
public ref class EffectList : public List<Effect^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Effect >)>)
Mogware.VisualStudio.ColladaNet.Effects..::.EffectList

See Also

EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


EffectList Members

[image] [image]

Mogware's Collada.Net Class Library
EffectList Members
EffectList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EffectList type exposes the following members.

Constructors

Name | Description
EffectList | Initializes a new instance of the EffectList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Effect >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Effect >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Effect >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Effect >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Effect >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Effect >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Effect >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


EffectList Constructor

[image]

Mogware's Collada.Net Class Library
EffectList Constructor
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the EffectList class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public EffectList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
EffectList()

See Also

EffectList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


EffectList Methods

[image] [image]

Mogware's Collada.Net Class Library
EffectList Methods
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EffectList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Effect >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Effect >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Effect >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Effect >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Effect >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Effect >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.BinarySearch Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Effect >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Effect >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.CopyTo Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Effect >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Effect >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.Find Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Find(String) |

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
EffectList..::.Find Method (String)
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.EffectList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Effect Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Effect
Visual C++
public:
Effect^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.EffectList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.EffectList.Find(System.String)]

See Also

EffectList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.FindIndex Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Effect >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.FindLastIndex Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Effect >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.IndexOf Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Effect >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.LastIndexOf Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Effect >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.Reverse Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
EffectList..::.Sort Method
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Effect >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Effect >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
EffectList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


EffectList Properties

[image] [image]

Mogware's Collada.Net Class Library
EffectList Properties
EffectList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The EffectList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Effect >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Effect >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Effect >)>).)

See Also

EffectList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


FilterType Enumeration

[image]

Mogware's Collada.Net Class Library
FilterType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.FilterType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum FilterType
Visual Basic (Declaration)
Public Enumeration FilterType
Visual C++
public enum class FilterType

Members

Member name | Description
Linear |
LinearMipmapLinear |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Class

[image]

Mogware's Collada.Net Class Library
Lambert Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Lambert]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Lambert : Technique
Visual Basic (Declaration)
Public Class Lambert _
    Inherits Technique
Visual C++
public ref class Lambert : public Technique

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Technique
Mogware.VisualStudio.ColladaNet.Effects..::.Lambert

See Also

Lambert Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Members

[image] [image]

Mogware's Collada.Net Class Library
Lambert Members
Lambert Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lambert type exposes the following members.

Constructors

Name | Description
Lambert | Initializes a new instance of the Lambert class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Ambient |
Diffuse |
Document | (Inherited from ParameterContainer.)
Id | (Inherited from Technique.)
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Sid | (Inherited from Technique.)
Transparency |
Transparent |

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Constructor

[image]

Mogware's Collada.Net Class Library
Lambert Constructor
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Lambert class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Lambert(
    XmlElement element,
    Profile profile
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    profile As Profile _
)
Visual C++
public:
Lambert(
    XmlElement^ element,
    Profile^ profile
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Lambert.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

profile
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Profile

[Missing <param name="profile"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Lambert.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Fields

[image] [image]

Mogware's Collada.Net Class Library
Lambert Fields
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lambert type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Methods

[image] [image]

Mogware's Collada.Net Class Library
Lambert Methods
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lambert type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Lambert Properties

[image] [image]

Mogware's Collada.Net Class Library
Lambert Properties
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lambert type exposes the following members.

Properties

Name | Description
Ambient |
Diffuse |
Document | (Inherited from ParameterContainer.)
Id | (Inherited from Technique.)
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Sid | (Inherited from Technique.)
Transparency |
Transparent |

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Ambient Property

[image]

Mogware's Collada.Net Class Library
Lambert..::.Ambient Property
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Lambert.Ambient]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColorInput Ambient { get; set; }
Visual Basic (Declaration)
Public Property Ambient As ColorInput
Visual C++
public:
property ColorInput^ Ambient {
    ColorInput^ get ();
    void set (ColorInput^ value);
}

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Diffuse Property

[image]

Mogware's Collada.Net Class Library
Lambert..::.Diffuse Property
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Lambert.Diffuse]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ChannelInput Diffuse { get; set; }
Visual Basic (Declaration)
Public Property Diffuse As ChannelInput
Visual C++
public:
property ChannelInput^ Diffuse {
    ChannelInput^ get ();
    void set (ChannelInput^ value);
}

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Transparency Property

[image]

Mogware's Collada.Net Class Library
Lambert..::.Transparency Property
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Lambert.Transparency]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Transparency { get; set; }
Visual Basic (Declaration)
Public Property Transparency As Single
Visual C++
public:
property float Transparency {
    float get ();
    void set (float value);
}

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Transparent Property

[image]

Mogware's Collada.Net Class Library
Lambert..::.Transparent Property
Lambert Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Lambert.Transparent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ChannelInput Transparent { get; set; }
Visual Basic (Declaration)
Public Property Transparent As ChannelInput
Visual C++
public:
property ChannelInput^ Transparent {
    ChannelInput^ get ();
    void set (ChannelInput^ value);
}

See Also

Lambert Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Class

[image]

Mogware's Collada.Net Class Library
Parameter Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Parameter]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Parameter
Visual Basic (Declaration)
Public Class Parameter
Visual C++
public ref class Parameter

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.Parameter
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterTexture
Mogware.VisualStudio.ColladaNet.Effects..::.Surface

See Also

Parameter Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Members

[image] [image]

Mogware's Collada.Net Class Library
Parameter Members
Parameter Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Parameter type exposes the following members.

Constructors

Name | Description
Parameter | Initializes a new instance of the Parameter class

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mContainer |
mSid |

Properties

Name | Description
Sid |

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Constructor

[image]

Mogware's Collada.Net Class Library
Parameter Constructor
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Parameter class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected Parameter(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Protected Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
protected:
Parameter(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Fields

[image] [image]

Mogware's Collada.Net Class Library
Parameter Fields
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Parameter type exposes the following members.

Fields

Name | Description
mContainer |
mSid |

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


mContainer Field

[image]

Mogware's Collada.Net Class Library
Parameter..::.mContainer Field
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Effects.Parameter.mContainer]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected ParameterContainer mContainer
Visual Basic (Declaration)
Protected mContainer As ParameterContainer
Visual C++
protected:
ParameterContainer^ mContainer

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


mSid Field

[image]

Mogware's Collada.Net Class Library
Parameter..::.mSid Field
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Effects.Parameter.mSid]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected string mSid
Visual Basic (Declaration)
Protected mSid As String
Visual C++
protected:
String^ mSid

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Methods

[image] [image]

Mogware's Collada.Net Class Library
Parameter Methods
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Parameter type exposes the following members.

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Create Method

[image]

Mogware's Collada.Net Class Library
Parameter..::.Create Method
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static Parameter Create(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    element As XmlElement, _
    container As ParameterContainer _
) As Parameter
Visual C++
public:
static Parameter^ Create(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.Parameter.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)]

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameter Properties

[image] [image]

Mogware's Collada.Net Class Library
Parameter Properties
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Parameter type exposes the following members.

Properties

Name | Description
Sid |

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sid Property

[image]

Mogware's Collada.Net Class Library
Parameter..::.Sid Property
Parameter Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Parameter.Sid]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Sid { get; set; }
Visual Basic (Declaration)
Public Property Sid As String
Visual C++
public:
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

Parameter Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Class

[image]

Mogware's Collada.Net Class Library
ParameterContainer Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class ParameterContainer
Visual Basic (Declaration)
Public MustInherit Class ParameterContainer
Visual C++
public ref class ParameterContainer abstract

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Effect
Mogware.VisualStudio.ColladaNet.Effects..::.Profile
Mogware.VisualStudio.ColladaNet.Effects..::.Technique

See Also

ParameterContainer Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Members

[image] [image]

Mogware's Collada.Net Class Library
ParameterContainer Members
ParameterContainer Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterContainer type exposes the following members.

Constructors

Name | Description
ParameterContainer | Initializes a new instance of the ParameterContainer class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement |

Properties

Name | Description
Document |
Parameters |
Parent |

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Constructor

[image]

Mogware's Collada.Net Class Library
ParameterContainer Constructor
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ParameterContainer class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ParameterContainer(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
ParameterContainer(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.#ctor(System.Xml.XmlElement)"]

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Fields

[image] [image]

Mogware's Collada.Net Class Library
ParameterContainer Fields
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterContainer type exposes the following members.

Fields

Name | Description
mElement |

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


mElement Field

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.mElement Field
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.mElement]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected XmlElement mElement
Visual Basic (Declaration)
Protected mElement As XmlElement
Visual C++
protected:
XmlElement^ mElement

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Methods

[image] [image]

Mogware's Collada.Net Class Library
ParameterContainer Methods
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterContainer type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindParameter Method

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.FindParameter Method
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.FindParameter(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Parameter FindParameter(
    string sid
)
Visual Basic (Declaration)
Public Function FindParameter ( _
    sid As String _
) As Parameter
Visual C++
public:
Parameter^ FindParameter(
    String^ sid
)

Parameters

sid
Type: System..::.String

[Missing <param name="sid"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.FindParameter(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.FindParameter(System.String)]

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ReadParameters Method

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.ReadParameters Method
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.ReadParameters]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected void ReadParameters()
Visual Basic (Declaration)
Protected Sub ReadParameters
Visual C++
protected:
void ReadParameters()

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterContainer Properties

[image] [image]

Mogware's Collada.Net Class Library
ParameterContainer Properties
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterContainer type exposes the following members.

Properties

Name | Description
Document |
Parameters |
Parent |

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Document Property

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.Document Property
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.Document]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public virtual ColladaDocument Document { get; }
Visual Basic (Declaration)
Public Overridable ReadOnly Property Document As ColladaDocument
Visual C++
public:
virtual property ColladaDocument^ Document {
    ColladaDocument^ get ();
}

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parameters Property

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.Parameters Property
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.Parameters]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ParameterList Parameters { get; }
Visual Basic (Declaration)
Public ReadOnly Property Parameters As ParameterList
Visual C++
public:
property ParameterList^ Parameters {
    ParameterList^ get ();
}

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parent Property

[image]

Mogware's Collada.Net Class Library
ParameterContainer..::.Parent Property
ParameterContainer Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer.Parent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract ParameterContainer Parent { get; }
Visual Basic (Declaration)
Public MustOverride ReadOnly Property Parent As ParameterContainer
Visual C++
public:
virtual property ParameterContainer^ Parent {
    ParameterContainer^ get () abstract;
}

See Also

ParameterContainer Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterList Class

[image]

Mogware's Collada.Net Class Library
ParameterList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ParameterList]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ParameterList : List<Parameter>
Visual Basic (Declaration)
Public Class ParameterList _
    Inherits List(Of Parameter)
Visual C++
public ref class ParameterList : public List<Parameter^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Parameter >)>)
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterList

See Also

ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterList Members

[image] [image]

Mogware's Collada.Net Class Library
ParameterList Members
ParameterList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterList type exposes the following members.

Constructors

Name | Description
ParameterList | Initializes a new instance of the ParameterList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Parameter >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Parameter >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Parameter >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Parameter >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Parameter >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Parameter >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Parameter >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterList Constructor

[image]

Mogware's Collada.Net Class Library
ParameterList Constructor
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ParameterList class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ParameterList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ParameterList()

See Also

ParameterList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterList Methods

[image] [image]

Mogware's Collada.Net Class Library
ParameterList Methods
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Parameter >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Parameter >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Parameter >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Parameter >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Parameter >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Parameter >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.BinarySearch Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Parameter >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Parameter >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.CopyTo Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Parameter >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Parameter >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.Find Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Find(String) |

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
ParameterList..::.Find Method (String)
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ParameterList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Parameter Find(
    string sid
)
Visual Basic (Declaration)
Public Function Find ( _
    sid As String _
) As Parameter
Visual C++
public:
Parameter^ Find(
    String^ sid
)

Parameters

sid
Type: System..::.String

[Missing <param name="sid"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ParameterList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ParameterList.Find(System.String)]

See Also

ParameterList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.FindIndex Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Parameter >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.FindLastIndex Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Parameter >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.IndexOf Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Parameter >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.LastIndexOf Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Parameter >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.Reverse Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
ParameterList..::.Sort Method
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Parameter >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Parameter >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
ParameterList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterList Properties

[image] [image]

Mogware's Collada.Net Class Library
ParameterList Properties
ParameterList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Parameter >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Parameter >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Parameter >)>).)

See Also

ParameterList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Class

[image]

Mogware's Collada.Net Class Library
ParameterTexture Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ParameterTexture : Parameter
Visual Basic (Declaration)
Public Class ParameterTexture _
    Inherits Parameter
Visual C++
public ref class ParameterTexture : public Parameter

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.Parameter
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterTexture
Mogware.VisualStudio.ColladaNet.Effects..::.Sampler
Mogware.VisualStudio.ColladaNet.Effects..::.Texture

See Also

ParameterTexture Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Members

[image] [image]

Mogware's Collada.Net Class Library
ParameterTexture Members
ParameterTexture Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterTexture type exposes the following members.

Constructors

Name | Description
ParameterTexture | Initializes a new instance of the ParameterTexture class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

Properties

Name | Description
Filename |
Id |
Name |
Sid | (Inherited from Parameter.)

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Constructor

[image]

Mogware's Collada.Net Class Library
ParameterTexture Constructor
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ParameterTexture class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ParameterTexture(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
public:
ParameterTexture(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Fields

[image] [image]

Mogware's Collada.Net Class Library
ParameterTexture Fields
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterTexture type exposes the following members.

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Methods

[image] [image]

Mogware's Collada.Net Class Library
ParameterTexture Methods
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterTexture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ParameterTexture Properties

[image] [image]

Mogware's Collada.Net Class Library
ParameterTexture Properties
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ParameterTexture type exposes the following members.

Properties

Name | Description
Filename |
Id |
Name |
Sid | (Inherited from Parameter.)

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Filename Property

[image]

Mogware's Collada.Net Class Library
ParameterTexture..::.Filename Property
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture.Filename]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Filename { get; set; }
Visual Basic (Declaration)
Public Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
ParameterTexture..::.Id Property
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
ParameterTexture..::.Name Property
ParameterTexture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.ParameterTexture.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

ParameterTexture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Class

[image]

Mogware's Collada.Net Class Library
Phong Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Phong]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Phong : Blinn
Visual Basic (Declaration)
Public Class Phong _
    Inherits Blinn
Visual C++
public ref class Phong : public Blinn

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Technique
Mogware.VisualStudio.ColladaNet.Effects..::.Blinn
Mogware.VisualStudio.ColladaNet.Effects..::.Phong

See Also

Phong Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Members

[image] [image]

Mogware's Collada.Net Class Library
Phong Members
Phong Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Phong type exposes the following members.

Constructors

Name | Description
Phong | Initializes a new instance of the Phong class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Ambient | (Inherited from Blinn.)
Diffuse | (Inherited from Blinn.)
Document | (Inherited from ParameterContainer.)
Emission | (Inherited from Blinn.)
Id | (Inherited from Technique.)
IndexOfRefraction | (Inherited from Blinn.)
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Reflective | (Inherited from Blinn.)
Reflectivity | (Inherited from Blinn.)
Shininess | (Inherited from Blinn.)
Sid | (Inherited from Technique.)
Specular | (Inherited from Blinn.)
Transparency | (Inherited from Blinn.)
Transparent | (Inherited from Blinn.)

See Also

Phong Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Constructor

[image]

Mogware's Collada.Net Class Library
Phong Constructor
Phong Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Phong class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Phong(
    XmlElement element,
    Profile profile
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    profile As Profile _
)
Visual C++
public:
Phong(
    XmlElement^ element,
    Profile^ profile
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Phong.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

profile
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Profile

[Missing <param name="profile"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Phong.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

See Also

Phong Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Fields

[image] [image]

Mogware's Collada.Net Class Library
Phong Fields
Phong Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Phong type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Phong Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Methods

[image] [image]

Mogware's Collada.Net Class Library
Phong Methods
Phong Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Phong type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Phong Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Phong Properties

[image] [image]

Mogware's Collada.Net Class Library
Phong Properties
Phong Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Phong type exposes the following members.

Properties

Name | Description
Ambient | (Inherited from Blinn.)
Diffuse | (Inherited from Blinn.)
Document | (Inherited from ParameterContainer.)
Emission | (Inherited from Blinn.)
Id | (Inherited from Technique.)
IndexOfRefraction | (Inherited from Blinn.)
Parameters | (Inherited from ParameterContainer.)
Parent | (Inherited from Technique.)
Profile | (Inherited from Technique.)
Reflective | (Inherited from Blinn.)
Reflectivity | (Inherited from Blinn.)
Shininess | (Inherited from Blinn.)
Sid | (Inherited from Technique.)
Specular | (Inherited from Blinn.)
Transparency | (Inherited from Blinn.)
Transparent | (Inherited from Blinn.)

See Also

Phong Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Class

[image]

Mogware's Collada.Net Class Library
Profile Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Profile]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Profile : ParameterContainer
Visual Basic (Declaration)
Public Class Profile _
    Inherits ParameterContainer
Visual C++
public ref class Profile : public ParameterContainer

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Profile

See Also

Profile Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Members

[image] [image]

Mogware's Collada.Net Class Library
Profile Members
Profile Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Profile type exposes the following members.

Constructors

Name | Description
Profile | Initializes a new instance of the Profile class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Document | (Inherited from ParameterContainer.)
Effect |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Platform |
ProfileType |
Techniques |

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Constructor

[image]

Mogware's Collada.Net Class Library
Profile Constructor
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Profile class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Profile(
    XmlElement element,
    Effect effect
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    effect As Effect _
)
Visual C++
public:
Profile(
    XmlElement^ element,
    Effect^ effect
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Profile.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Effect)"]

effect
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Effect

[Missing <param name="effect"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Profile.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Effect)"]

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Fields

[image] [image]

Mogware's Collada.Net Class Library
Profile Fields
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Profile type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Methods

[image] [image]

Mogware's Collada.Net Class Library
Profile Methods
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Profile type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Properties

[image] [image]

Mogware's Collada.Net Class Library
Profile Properties
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Profile type exposes the following members.

Properties

Name | Description
Document | (Inherited from ParameterContainer.)
Effect |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Platform |
ProfileType |
Techniques |

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Effect Property

[image]

Mogware's Collada.Net Class Library
Profile..::.Effect Property
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Profile.Effect]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Effect Effect { get; set; }
Visual Basic (Declaration)
Public Property Effect As Effect
Visual C++
public:
property Effect^ Effect {
    Effect^ get ();
    void set (Effect^ value);
}

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parent Property

[image]

Mogware's Collada.Net Class Library
Profile..::.Parent Property
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Profile.Parent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override ParameterContainer Parent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Parent As ParameterContainer
Visual C++
public:
virtual property ParameterContainer^ Parent {
    ParameterContainer^ get () override;
}

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Platform Property

[image]

Mogware's Collada.Net Class Library
Profile..::.Platform Property
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Profile.Platform]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Platform { get; set; }
Visual Basic (Declaration)
Public Property Platform As String
Visual C++
public:
property String^ Platform {
    String^ get ();
    void set (String^ value);
}

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileType Property

[image]

Mogware's Collada.Net Class Library
Profile..::.ProfileType Property
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Profile.ProfileType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ProfileType ProfileType { get; set; }
Visual Basic (Declaration)
Public Property ProfileType As ProfileType
Visual C++
public:
property ProfileType ProfileType {
    ProfileType get ();
    void set (ProfileType value);
}

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Techniques Property

[image]

Mogware's Collada.Net Class Library
Profile..::.Techniques Property
Profile Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Profile.Techniques]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TechniqueList Techniques { get; }
Visual Basic (Declaration)
Public ReadOnly Property Techniques As TechniqueList
Visual C++
public:
property TechniqueList^ Techniques {
    TechniqueList^ get ();
}

See Also

Profile Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileList Class

[image]

Mogware's Collada.Net Class Library
ProfileList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ProfileList]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ProfileList : List<Profile>
Visual Basic (Declaration)
Public Class ProfileList _
    Inherits List(Of Profile)
Visual C++
public ref class ProfileList : public List<Profile^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Profile >)>)
Mogware.VisualStudio.ColladaNet.Effects..::.ProfileList

See Also

ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileList Members

[image] [image]

Mogware's Collada.Net Class Library
ProfileList Members
ProfileList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProfileList type exposes the following members.

Constructors

Name | Description
ProfileList | Initializes a new instance of the ProfileList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Profile >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Profile >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Profile >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Profile >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Profile >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Profile >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Profile >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileList Constructor

[image]

Mogware's Collada.Net Class Library
ProfileList Constructor
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ProfileList class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ProfileList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ProfileList()

See Also

ProfileList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileList Methods

[image] [image]

Mogware's Collada.Net Class Library
ProfileList Methods
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProfileList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Profile >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Profile >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Profile >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Profile >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Profile >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Profile >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.BinarySearch Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Profile >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Profile >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.CopyTo Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Profile >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Profile >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.Find Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Find(ProfileType) |

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method (ProfileType)

[image]

Mogware's Collada.Net Class Library
ProfileList..::.Find Method (ProfileType)
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ProfileList.Find(Mogware.VisualStudio.ColladaNet.Effects.ProfileType)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Profile Find(
    ProfileType type
)
Visual Basic (Declaration)
Public Function Find ( _
    type As ProfileType _
) As Profile
Visual C++
public:
Profile^ Find(
    ProfileType type
)

Parameters

type
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ProfileType

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.ProfileList.Find(Mogware.VisualStudio.ColladaNet.Effects.ProfileType)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.ProfileList.Find(Mogware.VisualStudio.ColladaNet.Effects.ProfileType)]

See Also

ProfileList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.FindIndex Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Profile >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.FindLastIndex Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Profile >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.IndexOf Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Profile >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.LastIndexOf Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Profile >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.Reverse Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
ProfileList..::.Sort Method
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Profile >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Profile >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
ProfileList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileList Properties

[image] [image]

Mogware's Collada.Net Class Library
ProfileList Properties
ProfileList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ProfileList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Profile >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Profile >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Profile >)>).)

See Also

ProfileList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


ProfileType Enumeration

[image]

Mogware's Collada.Net Class Library
ProfileType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.ProfileType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum ProfileType
Visual Basic (Declaration)
Public Enumeration ProfileType
Visual C++
public enum class ProfileType

Members

Member name | Description
COMMON |
CG |
GLSL |
GLES |
HLSL |
GLES_20 |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Class

[image]

Mogware's Collada.Net Class Library
Sampler Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Sampler]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Sampler : ParameterTexture
Visual Basic (Declaration)
Public Class Sampler _
    Inherits ParameterTexture
Visual C++
public ref class Sampler : public ParameterTexture

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.Parameter
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterTexture
Mogware.VisualStudio.ColladaNet.Effects..::.Sampler

See Also

Sampler Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Members

[image] [image]

Mogware's Collada.Net Class Library
Sampler Members
Sampler Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Constructors

Name | Description
Sampler | Initializes a new instance of the Sampler class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

Properties

Name | Description
Filename | (Inherited from ParameterTexture.)
Id | (Inherited from ParameterTexture.)
MagFilter |
MinFilter |
MipFilter |
Name | (Inherited from ParameterTexture.)
Sid | (Inherited from Parameter.)
Source |
Type |
WrapS |
WrapT |

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Constructor

[image]

Mogware's Collada.Net Class Library
Sampler Constructor
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Sampler class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Sampler(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
public:
Sampler(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Sampler.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Sampler.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Fields

[image] [image]

Mogware's Collada.Net Class Library
Sampler Fields
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Methods

[image] [image]

Mogware's Collada.Net Class Library
Sampler Methods
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Properties

[image] [image]

Mogware's Collada.Net Class Library
Sampler Properties
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Sampler type exposes the following members.

Properties

Name | Description
Filename | (Inherited from ParameterTexture.)
Id | (Inherited from ParameterTexture.)
MagFilter |
MinFilter |
MipFilter |
Name | (Inherited from ParameterTexture.)
Sid | (Inherited from Parameter.)
Source |
Type |
WrapS |
WrapT |

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


MagFilter Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.MagFilter Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.MagFilter]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public FilterType MagFilter { get; set; }
Visual Basic (Declaration)
Public Property MagFilter As FilterType
Visual C++
public:
property FilterType MagFilter {
    FilterType get ();
    void set (FilterType value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


MinFilter Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.MinFilter Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.MinFilter]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public FilterType MinFilter { get; set; }
Visual Basic (Declaration)
Public Property MinFilter As FilterType
Visual C++
public:
property FilterType MinFilter {
    FilterType get ();
    void set (FilterType value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


MipFilter Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.MipFilter Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.MipFilter]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public FilterType MipFilter { get; set; }
Visual Basic (Declaration)
Public Property MipFilter As FilterType
Visual C++
public:
property FilterType MipFilter {
    FilterType get ();
    void set (FilterType value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Source Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.Source Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.Source]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Surface Source { get; set; }
Visual Basic (Declaration)
Public Property Source As Surface
Visual C++
public:
property Surface^ Source {
    Surface^ get ();
    void set (Surface^ value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Type Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.Type Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.Type]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Type { get; set; }
Visual Basic (Declaration)
Public Property Type As String
Visual C++
public:
property String^ Type {
    String^ get ();
    void set (String^ value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


WrapS Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.WrapS Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.WrapS]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public WrapMode WrapS { get; set; }
Visual Basic (Declaration)
Public Property WrapS As WrapMode
Visual C++
public:
property WrapMode WrapS {
    WrapMode get ();
    void set (WrapMode value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


WrapT Property

[image]

Mogware's Collada.Net Class Library
Sampler..::.WrapT Property
Sampler Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Sampler.WrapT]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public WrapMode WrapT { get; set; }
Visual Basic (Declaration)
Public Property WrapT As WrapMode
Visual C++
public:
property WrapMode WrapT {
    WrapMode get ();
    void set (WrapMode value);
}

See Also

Sampler Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


SamplerType Enumeration

[image]

Mogware's Collada.Net Class Library
SamplerType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.SamplerType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum SamplerType
Visual Basic (Declaration)
Public Enumeration SamplerType
Visual C++
public enum class SamplerType

Members

Member name | Description
_1D |
_2D |
_3D |
RECT |
CUBE |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Class

[image]

Mogware's Collada.Net Class Library
Surface Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Surface]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Surface : Parameter
Visual Basic (Declaration)
Public Class Surface _
    Inherits Parameter
Visual C++
public ref class Surface : public Parameter

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.Parameter
Mogware.VisualStudio.ColladaNet.Effects..::.Surface

See Also

Surface Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Members

[image] [image]

Mogware's Collada.Net Class Library
Surface Members
Surface Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Surface type exposes the following members.

Constructors

Name | Description
Surface | Initializes a new instance of the Surface class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

Properties

Name | Description
Format |
Image |
Sid | (Inherited from Parameter.)
SurfaceType |

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Constructor

[image]

Mogware's Collada.Net Class Library
Surface Constructor
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Surface class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Surface(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
public:
Surface(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Surface.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Surface.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Fields

[image] [image]

Mogware's Collada.Net Class Library
Surface Fields
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Surface type exposes the following members.

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Methods

[image] [image]

Mogware's Collada.Net Class Library
Surface Methods
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Surface type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Surface Properties

[image] [image]

Mogware's Collada.Net Class Library
Surface Properties
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Surface type exposes the following members.

Properties

Name | Description
Format |
Image |
Sid | (Inherited from Parameter.)
SurfaceType |

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Format Property

[image]

Mogware's Collada.Net Class Library
Surface..::.Format Property
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Surface.Format]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Format { get; set; }
Visual Basic (Declaration)
Public Property Format As String
Visual C++
public:
property String^ Format {
    String^ get ();
    void set (String^ value);
}

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Image Property

[image]

Mogware's Collada.Net Class Library
Surface..::.Image Property
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Surface.Image]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Image Image { get; set; }
Visual Basic (Declaration)
Public Property Image As Image
Visual C++
public:
property Image^ Image {
    Image^ get ();
    void set (Image^ value);
}

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


SurfaceType Property

[image]

Mogware's Collada.Net Class Library
Surface..::.SurfaceType Property
Surface Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Surface.SurfaceType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string SurfaceType { get; set; }
Visual Basic (Declaration)
Public Property SurfaceType As String
Visual C++
public:
property String^ SurfaceType {
    String^ get ();
    void set (String^ value);
}

See Also

Surface Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


SurfaceFormat Enumeration

[image]

Mogware's Collada.Net Class Library
SurfaceFormat Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.SurfaceFormat]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum SurfaceFormat
Visual Basic (Declaration)
Public Enumeration SurfaceFormat
Visual C++
public enum class SurfaceFormat

Members

Member name | Description
A8R8G8B8 |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


SurfaceType Enumeration

[image]

Mogware's Collada.Net Class Library
SurfaceType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.SurfaceType]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum SurfaceType
Visual Basic (Declaration)
Public Enumeration SurfaceType
Visual C++
public enum class SurfaceType

Members

Member name | Description
UNTYPED |
_1D |
_2D |
_3D |
RECT |
CUBE |
DEPTH |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Class

[image]

Mogware's Collada.Net Class Library
Technique Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Technique]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Technique : ParameterContainer
Visual Basic (Declaration)
Public Class Technique _
    Inherits ParameterContainer
Visual C++
public ref class Technique : public ParameterContainer

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer
Mogware.VisualStudio.ColladaNet.Effects..::.Technique
Mogware.VisualStudio.ColladaNet.Effects..::.Blinn
Mogware.VisualStudio.ColladaNet.Effects..::.Lambert

See Also

Technique Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Members

[image] [image]

Mogware's Collada.Net Class Library
Technique Members
Technique Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Technique type exposes the following members.

Constructors

Name | Description
Technique | Initializes a new instance of the Technique class

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

Properties

Name | Description
Document | (Inherited from ParameterContainer.)
Id |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Profile |
Sid |

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Constructor

[image]

Mogware's Collada.Net Class Library
Technique Constructor
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Technique class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Technique(
    XmlElement element,
    Profile profile
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    profile As Profile _
)
Visual C++
public:
Technique(
    XmlElement^ element,
    Profile^ profile
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Technique.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

profile
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Profile

[Missing <param name="profile"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Technique.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Fields

[image] [image]

Mogware's Collada.Net Class Library
Technique Fields
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Technique type exposes the following members.

Fields

Name | Description
mElement | (Inherited from ParameterContainer.)

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Methods

[image] [image]

Mogware's Collada.Net Class Library
Technique Methods
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Technique type exposes the following members.

Methods

Name | Description
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
FindParameter | (Inherited from ParameterContainer.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ReadParameters | (Inherited from ParameterContainer.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Create Method

[image]

Mogware's Collada.Net Class Library
Technique..::.Create Method
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.Technique.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static Technique Create(
    XmlElement element,
    Profile profile
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    element As XmlElement, _
    profile As Profile _
) As Technique
Visual C++
public:
static Technique^ Create(
    XmlElement^ element,
    Profile^ profile
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Technique.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

profile
Type: Mogware.VisualStudio.ColladaNet.Effects..::.Profile

[Missing <param name="profile"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Technique.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.Technique.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.Profile)]

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Technique Properties

[image] [image]

Mogware's Collada.Net Class Library
Technique Properties
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Technique type exposes the following members.

Properties

Name | Description
Document | (Inherited from ParameterContainer.)
Id |
Parameters | (Inherited from ParameterContainer.)
Parent | (Overrides ParameterContainer..::.Parent.)
Profile |
Sid |

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Technique..::.Id Property
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Technique.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Parent Property

[image]

Mogware's Collada.Net Class Library
Technique..::.Parent Property
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Technique.Parent]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override ParameterContainer Parent { get; }
Visual Basic (Declaration)
Public Overrides ReadOnly Property Parent As ParameterContainer
Visual C++
public:
virtual property ParameterContainer^ Parent {
    ParameterContainer^ get () override;
}

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Profile Property

[image]

Mogware's Collada.Net Class Library
Technique..::.Profile Property
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Technique.Profile]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Profile Profile { get; set; }
Visual Basic (Declaration)
Public Property Profile As Profile
Visual C++
public:
property Profile^ Profile {
    Profile^ get ();
    void set (Profile^ value);
}

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sid Property

[image]

Mogware's Collada.Net Class Library
Technique..::.Sid Property
Technique Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.Technique.Sid]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Sid { get; set; }
Visual Basic (Declaration)
Public Property Sid As String
Visual C++
public:
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

Technique Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TechniqueList Class

[image]

Mogware's Collada.Net Class Library
TechniqueList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class TechniqueList : List<Technique>
Visual Basic (Declaration)
Public Class TechniqueList _
    Inherits List(Of Technique)
Visual C++
public ref class TechniqueList : public List<Technique^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Technique >)>)
Mogware.VisualStudio.ColladaNet.Effects..::.TechniqueList

See Also

TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


TechniqueList Members

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList Members
TechniqueList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TechniqueList type exposes the following members.

Constructors

Name | Description
TechniqueList | Initializes a new instance of the TechniqueList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Technique >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Technique >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Technique >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Technique >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Technique >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Technique >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Technique >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TechniqueList Constructor

[image]

Mogware's Collada.Net Class Library
TechniqueList Constructor
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TechniqueList class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TechniqueList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TechniqueList()

See Also

TechniqueList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TechniqueList Methods

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList Methods
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TechniqueList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Technique >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Technique >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Technique >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Technique >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Technique >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Technique >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.BinarySearch Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Technique >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Technique >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.CopyTo Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Technique >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Technique >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.Find Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Find(String) |
Find(Type) |

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
TechniqueList..::.Find Method (String)
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Technique Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Technique
Visual C++
public:
Technique^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.String)]

See Also

TechniqueList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Effects Namespace


Find Method (Type)

[image]

Mogware's Collada.Net Class Library
TechniqueList..::.Find Method (Type)
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.Type)]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Technique Find(
    Type type
)
Visual Basic (Declaration)
Public Function Find ( _
    type As Type _
) As Technique
Visual C++
public:
Technique^ Find(
    Type^ type
)

Parameters

type
Type: System..::.Type

[Missing <param name="type"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.Type)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Effects.TechniqueList.Find(System.Type)]

See Also

TechniqueList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.FindIndex Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Technique >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.FindLastIndex Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Technique >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.IndexOf Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Technique >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.LastIndexOf Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Technique >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.Reverse Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList..::.Sort Method
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Technique >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Technique >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
TechniqueList Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


TechniqueList Properties

[image] [image]

Mogware's Collada.Net Class Library
TechniqueList Properties
TechniqueList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TechniqueList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Technique >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Technique >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Technique >)>).)

See Also

TechniqueList Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Class

[image]

Mogware's Collada.Net Class Library
Texture Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.Texture]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Texture : ParameterTexture
Visual Basic (Declaration)
Public Class Texture _
    Inherits ParameterTexture
Visual C++
public ref class Texture : public ParameterTexture

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.Parameter
Mogware.VisualStudio.ColladaNet.Effects..::.ParameterTexture
Mogware.VisualStudio.ColladaNet.Effects..::.Texture

See Also

Texture Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Members

[image] [image]

Mogware's Collada.Net Class Library
Texture Members
Texture Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Texture type exposes the following members.

Constructors

Name | Description
Texture | Initializes a new instance of the Texture class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

Properties

Name | Description
Filename | (Inherited from ParameterTexture.)
Id | (Inherited from ParameterTexture.)
Name | (Inherited from ParameterTexture.)
Sid | (Inherited from Parameter.)

See Also

Texture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Constructor

[image]

Mogware's Collada.Net Class Library
Texture Constructor
Texture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Texture class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Texture(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
public:
Texture(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Texture.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.Texture.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

Texture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Fields

[image] [image]

Mogware's Collada.Net Class Library
Texture Fields
Texture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Texture type exposes the following members.

Fields

Name | Description
mContainer | (Inherited from Parameter.)
mSid | (Inherited from Parameter.)

See Also

Texture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Methods

[image] [image]

Mogware's Collada.Net Class Library
Texture Methods
Texture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Texture type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Texture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Properties

[image] [image]

Mogware's Collada.Net Class Library
Texture Properties
Texture Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Texture type exposes the following members.

Properties

Name | Description
Filename | (Inherited from ParameterTexture.)
Id | (Inherited from ParameterTexture.)
Name | (Inherited from ParameterTexture.)
Sid | (Inherited from Parameter.)

See Also

Texture Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TextureInput Class

[image]

Mogware's Collada.Net Class Library
TextureInput Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.TextureInput]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class TextureInput : ChannelInput
Visual Basic (Declaration)
Public Class TextureInput _
    Inherits ChannelInput
Visual C++
public ref class TextureInput : public ChannelInput

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Effects..::.ChannelInput
Mogware.VisualStudio.ColladaNet.Effects..::.TextureInput

See Also

TextureInput Members
Mogware.VisualStudio.ColladaNet.Effects Namespace


TextureInput Members

[image] [image]

Mogware's Collada.Net Class Library
TextureInput Members
TextureInput Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureInput type exposes the following members.

Constructors

Name | Description
TextureInput | Initializes a new instance of the TextureInput class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Sampler |
TexCoord |
Texture |

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TextureInput Constructor

[image]

Mogware's Collada.Net Class Library
TextureInput Constructor
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TextureInput class

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TextureInput(
    XmlElement element,
    ParameterContainer container
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    container As ParameterContainer _
)
Visual C++
public:
TextureInput(
    XmlElement^ element,
    ParameterContainer^ container
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.TextureInput.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

container
Type: Mogware.VisualStudio.ColladaNet.Effects..::.ParameterContainer

[Missing <param name="container"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Effects.TextureInput.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Effects.ParameterContainer)"]

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TextureInput Methods

[image] [image]

Mogware's Collada.Net Class Library
TextureInput Methods
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureInput type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TextureInput Properties

[image] [image]

Mogware's Collada.Net Class Library
TextureInput Properties
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureInput type exposes the following members.

Properties

Name | Description
Sampler |
TexCoord |
Texture |

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Sampler Property

[image]

Mogware's Collada.Net Class Library
TextureInput..::.Sampler Property
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.TextureInput.Sampler]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Sampler Sampler { get; set; }
Visual Basic (Declaration)
Public Property Sampler As Sampler
Visual C++
public:
property Sampler^ Sampler {
    Sampler^ get ();
    void set (Sampler^ value);
}

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


TexCoord Property

[image]

Mogware's Collada.Net Class Library
TextureInput..::.TexCoord Property
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.TextureInput.TexCoord]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string TexCoord { get; set; }
Visual Basic (Declaration)
Public Property TexCoord As String
Visual C++
public:
property String^ TexCoord {
    String^ get ();
    void set (String^ value);
}

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


Texture Property

[image]

Mogware's Collada.Net Class Library
TextureInput..::.Texture Property
TextureInput Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Effects.TextureInput.Texture]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ParameterTexture Texture { get; set; }
Visual Basic (Declaration)
Public Property Texture As ParameterTexture
Visual C++
public:
property ParameterTexture^ Texture {
    ParameterTexture^ get ();
    void set (ParameterTexture^ value);
}

See Also

TextureInput Class
Mogware.VisualStudio.ColladaNet.Effects Namespace


WrapMode Enumeration

[image]

Mogware's Collada.Net Class Library
WrapMode Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Effects.WrapMode]

Namespace: Mogware.VisualStudio.ColladaNet.Effects
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum WrapMode
Visual Basic (Declaration)
Public Enumeration WrapMode
Visual C++
public enum class WrapMode

Members

Member name | Description
Repeat |
Mirror |
Clamp |

See Also

Mogware.VisualStudio.ColladaNet.Effects Namespace


Mogware.VisualStudio.ColladaNet.Geometry Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Geometry Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Geometry]

Classes

Class | Description
Edge |
Geometry |
GeometryList |
Line |
LinePrimitive |
Lines |
Linestrips |
Mesh |
Normal |
Polygon |
PolygonPrimitive |
Polygons |
Polylist |
Position |
Primitive |
Ray |
TextureCoordinate |
Triangles |
Trifans |
Tristrips |
Vertex |
Vertices |

Enumerations

Enumeration | Description
PrimitiveType |


Edge Class

[image]

Mogware's Collada.Net Class Library
Edge Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Edge]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Edge
Visual Basic (Declaration)
Public Class Edge
Visual C++
public ref class Edge

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Edge

See Also

Edge Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Edge Members

[image] [image]

Mogware's Collada.Net Class Library
Edge Members
Edge Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Edge type exposes the following members.

Constructors

Name | Description
Edge | Initializes a new instance of the Edge class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
P0 |
P1 |

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Edge Constructor

[image]

Mogware's Collada.Net Class Library
Edge Constructor
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Edge class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Edge(
    Position p0,
    Position p1
)
Visual Basic (Declaration)
Public Sub New ( _
    p0 As Position, _
    p1 As Position _
)
Visual C++
public:
Edge(
    Position^ p0,
    Position^ p1
)

Parameters

p0
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Position

[Missing <param name="p0"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Edge.#ctor(Mogware.VisualStudio.ColladaNet.Geometry.Position,Mogware.VisualStudio.ColladaNet.Geometry.Position)"]

p1
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Position

[Missing <param name="p1"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Edge.#ctor(Mogware.VisualStudio.ColladaNet.Geometry.Position,Mogware.VisualStudio.ColladaNet.Geometry.Position)"]

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Edge Methods

[image] [image]

Mogware's Collada.Net Class Library
Edge Methods
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Edge type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method

[image] [image]

Mogware's Collada.Net Class Library
Edge..::.Equals Method
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Edge) |

See Also

Edge Class
Edge Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method (Edge)

[image]

Mogware's Collada.Net Class Library
Edge..::.Equals Method (Edge)
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Edge.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Edge)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Equals(
    Edge e
)
Visual Basic (Declaration)
Public Function Equals ( _
    e As Edge _
) As Boolean
Visual C++
public:
bool Equals(
    Edge^ e
)

Parameters

e
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Edge

[Missing <param name="e"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Edge.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Edge)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Edge.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Edge)]

See Also

Edge Class
Equals Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Edge Properties

[image] [image]

Mogware's Collada.Net Class Library
Edge Properties
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Edge type exposes the following members.

Properties

Name | Description
P0 |
P1 |

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


P0 Property

[image]

Mogware's Collada.Net Class Library
Edge..::.P0 Property
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Edge.P0]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Position P0 { get; set; }
Visual Basic (Declaration)
Public Property P0 As Position
Visual C++
public:
property Position^ P0 {
    Position^ get ();
    void set (Position^ value);
}

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


P1 Property

[image]

Mogware's Collada.Net Class Library
Edge..::.P1 Property
Edge Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Edge.P1]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Position P1 { get; set; }
Visual Basic (Declaration)
Public Property P1 As Position
Visual C++
public:
property Position^ P1 {
    Position^ get ();
    void set (Position^ value);
}

See Also

Edge Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Class

[image]

Mogware's Collada.Net Class Library
Geometry Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Geometry]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Geometry
Visual Basic (Declaration)
Public Class Geometry
Visual C++
public ref class Geometry

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Geometry

See Also

Geometry Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Members

[image] [image]

Mogware's Collada.Net Class Library
Geometry Members
Geometry Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Geometry type exposes the following members.

Constructors

Name | Description
Geometry | Initializes a new instance of the Geometry class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Document |
Id |
Meshes |
Name |
Vertices |
XmlElement |

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Constructor

[image]

Mogware's Collada.Net Class Library
Geometry Constructor
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Geometry class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Geometry(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
Geometry(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Methods

[image] [image]

Mogware's Collada.Net Class Library
Geometry Methods
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Geometry type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
Geometry..::.Preremove Method
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Geometry..::.Presave Method
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Properties

[image] [image]

Mogware's Collada.Net Class Library
Geometry Properties
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Geometry type exposes the following members.

Properties

Name | Description
Document |
Id |
Meshes |
Name |
Vertices |
XmlElement |

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Document Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.Document Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Document]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ColladaDocument Document { get; set; }
Visual Basic (Declaration)
Public Property Document As ColladaDocument
Visual C++
public:
property ColladaDocument^ Document {
    ColladaDocument^ get ();
    void set (ColladaDocument^ value);
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.Id Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Meshes Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.Meshes Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Meshes]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Mesh> Meshes { get; set; }
Visual Basic (Declaration)
Public Property Meshes As List(Of Mesh)
Visual C++
public:
property List<Mesh^>^ Meshes {
    List<Mesh^>^ get ();
    void set (List<Mesh^>^ value);
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.Name Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.Vertices Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.Vertices]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Vertex> Vertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertices As List(Of Vertex)
Visual C++
public:
property List<Vertex^>^ Vertices {
    List<Vertex^>^ get ();
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


XmlElement Property

[image]

Mogware's Collada.Net Class Library
Geometry..::.XmlElement Property
Geometry Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Geometry.XmlElement]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public XmlElement XmlElement { get; }
Visual Basic (Declaration)
Public ReadOnly Property XmlElement As XmlElement
Visual C++
public:
property XmlElement^ XmlElement {
    XmlElement^ get ();
}

See Also

Geometry Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GeometryList Class

[image]

Mogware's Collada.Net Class Library
GeometryList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class GeometryList : List<Geometry>
Visual Basic (Declaration)
Public Class GeometryList _
    Inherits List(Of Geometry)
Visual C++
public ref class GeometryList : public List<Geometry^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Geometry >)>)
Mogware.VisualStudio.ColladaNet.Geometry..::.GeometryList

See Also

GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GeometryList Members

[image] [image]

Mogware's Collada.Net Class Library
GeometryList Members
GeometryList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GeometryList type exposes the following members.

Constructors

Name | Description
GeometryList | Initializes a new instance of the GeometryList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
AddRange |
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Geometry >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Geometry >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Geometry >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Geometry >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
RemoveAt |
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Geometry >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Geometry >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Geometry >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GeometryList Constructor

[image]

Mogware's Collada.Net Class Library
GeometryList Constructor
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the GeometryList class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public GeometryList(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
GeometryList(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.#ctor(System.Xml.XmlElement)"]

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GeometryList Methods

[image] [image]

Mogware's Collada.Net Class Library
GeometryList Methods
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GeometryList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
AddRange |
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Geometry >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Geometry >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Geometry >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Geometry >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)
RemoveAt |
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Geometry >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Geometry >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


AddRange Method

[image]

Mogware's Collada.Net Class Library
GeometryList..::.AddRange Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.AddRange(System.Collections.Generic.IEnumerable{Mogware.VisualStudio.ColladaNet.Geometry.Geometry})]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void AddRange(
    IEnumerable<Geometry> list
)
Visual Basic (Declaration)
Public Sub AddRange ( _
    list As IEnumerable(Of Geometry) _
)
Visual C++
public:
void AddRange(
    IEnumerable<Geometry^>^ list
)

Parameters

list
Type: System.Collections.Generic..::.IEnumerable <(Of <( Geometry >)>)

[Missing <param name="list"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.AddRange(System.Collections.Generic.IEnumerable{Mogware.VisualStudio.ColladaNet.Geometry.Geometry})"]

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.BinarySearch Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Geometry >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Geometry >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.CopyTo Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Geometry >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Geometry >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.Find Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Find(String) |

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
GeometryList..::.Find Method (String)
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Geometry Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Geometry
Visual C++
public:
Geometry^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.Find(System.String)]

See Also

GeometryList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.FindIndex Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Geometry >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.FindLastIndex Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Geometry >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.IndexOf Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Geometry >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.LastIndexOf Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Geometry >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Remove Method

[image]

Mogware's Collada.Net Class Library
GeometryList..::.Remove Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.Remove(Mogware.VisualStudio.ColladaNet.Geometry.Geometry)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    Geometry item
)
Visual Basic (Declaration)
Public Sub Remove ( _
    item As Geometry _
)
Visual C++
public:
void Remove(
    Geometry^ item
)

Parameters

item
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Geometry

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.Remove(Mogware.VisualStudio.ColladaNet.Geometry.Geometry)"]

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


RemoveAt Method

[image]

Mogware's Collada.Net Class Library
GeometryList..::.RemoveAt Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.RemoveAt(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.RemoveAt(System.Int32)"]

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


RemoveRange Method

[image]

Mogware's Collada.Net Class Library
GeometryList..::.RemoveRange Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.RemoveRange(System.Int32,System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveRange(
    int start,
    int count
)
Visual Basic (Declaration)
Public Sub RemoveRange ( _
    start As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int start,
    int count
)

Parameters

start
Type: System..::.Int32

[Missing <param name="start"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.RemoveRange(System.Int32,System.Int32)"]

count
Type: System..::.Int32

[Missing <param name="count"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.GeometryList.RemoveRange(System.Int32,System.Int32)"]

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.Reverse Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
GeometryList..::.Sort Method
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Geometry >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Geometry >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
GeometryList Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GeometryList Properties

[image] [image]

Mogware's Collada.Net Class Library
GeometryList Properties
GeometryList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The GeometryList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Geometry >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Geometry >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Geometry >)>).)

See Also

GeometryList Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Class

[image]

Mogware's Collada.Net Class Library
Line Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Line]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Line
Visual Basic (Declaration)
Public Class Line
Visual C++
public ref class Line

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Line
Mogware.VisualStudio.ColladaNet.Geometry..::.Polygon

See Also

Line Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Members

[image] [image]

Mogware's Collada.Net Class Library
Line Members
Line Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Constructors

Name | Description
Line | Initializes a new instance of the Line class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mVertices |

Properties

Name | Description
BoneNames |
BoneNamesString |
Vertices |

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Constructor

[image]

Mogware's Collada.Net Class Library
Line Constructor
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Line class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Line()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Line()

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Fields

[image] [image]

Mogware's Collada.Net Class Library
Line Fields
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Fields

Name | Description
mVertices |

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mVertices Field

[image]

Mogware's Collada.Net Class Library
Line..::.mVertices Field
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Line.mVertices]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected List<Vertex> mVertices
Visual Basic (Declaration)
Protected mVertices As List(Of Vertex)
Visual C++
protected:
List<Vertex^>^ mVertices

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Methods

[image] [image]

Mogware's Collada.Net Class Library
Line Methods
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Line Properties

[image] [image]

Mogware's Collada.Net Class Library
Line Properties
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Line type exposes the following members.

Properties

Name | Description
BoneNames |
BoneNamesString |
Vertices |

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


BoneNames Property

[image]

Mogware's Collada.Net Class Library
Line..::.BoneNames Property
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Line.BoneNames]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<string> BoneNames { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoneNames As List(Of String)
Visual C++
public:
property List<String^>^ BoneNames {
    List<String^>^ get ();
}

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


BoneNamesString Property

[image]

Mogware's Collada.Net Class Library
Line..::.BoneNamesString Property
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Line.BoneNamesString]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string BoneNamesString { get; }
Visual Basic (Declaration)
Public ReadOnly Property BoneNamesString As String
Visual C++
public:
property String^ BoneNamesString {
    String^ get ();
}

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Property

[image]

Mogware's Collada.Net Class Library
Line..::.Vertices Property
Line Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Line.Vertices]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Vertex> Vertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertices As List(Of Vertex)
Visual C++
public:
property List<Vertex^>^ Vertices {
    List<Vertex^>^ get ();
}

See Also

Line Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Class

[image]

Mogware's Collada.Net Class Library
LinePrimitive Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.LinePrimitive]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class LinePrimitive : Primitive
Visual Basic (Declaration)
Public MustInherit Class LinePrimitive _
    Inherits Primitive
Visual C++
public ref class LinePrimitive abstract : public Primitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.LinePrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Lines
Mogware.VisualStudio.ColladaNet.Geometry..::.Linestrips

See Also

LinePrimitive Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Members

[image] [image]

Mogware's Collada.Net Class Library
LinePrimitive Members
LinePrimitive Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinePrimitive type exposes the following members.

Constructors

Name | Description
LinePrimitive | Initializes a new instance of the LinePrimitive class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Inherited from Primitive.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

LinePrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Constructor

[image]

Mogware's Collada.Net Class Library
LinePrimitive Constructor
LinePrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the LinePrimitive class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public LinePrimitive(
    XmlElement element,
    Mesh mesh
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh _
)
Visual C++
public:
LinePrimitive(
    XmlElement^ element,
    Mesh^ mesh
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.LinePrimitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.LinePrimitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

See Also

LinePrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Fields

[image] [image]

Mogware's Collada.Net Class Library
LinePrimitive Fields
LinePrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinePrimitive type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

LinePrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Methods

[image] [image]

Mogware's Collada.Net Class Library
LinePrimitive Methods
LinePrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinePrimitive type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Inherited from Primitive.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

See Also

LinePrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


LinePrimitive Properties

[image] [image]

Mogware's Collada.Net Class Library
LinePrimitive Properties
LinePrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The LinePrimitive type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

LinePrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Class

[image]

Mogware's Collada.Net Class Library
Lines Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Lines]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Lines : LinePrimitive
Visual Basic (Declaration)
Public Class Lines _
    Inherits LinePrimitive
Visual C++
public ref class Lines : public LinePrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.LinePrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Lines

See Also

Lines Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Members

[image] [image]

Mogware's Collada.Net Class Library
Lines Members
Lines Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lines type exposes the following members.

Constructors

Name | Description
Lines | Initializes a new instance of the Lines class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Constructor

[image]

Mogware's Collada.Net Class Library
Lines Constructor
Lines Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Lines class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Lines(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Lines(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Lines.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Lines.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Lines.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Fields

[image] [image]

Mogware's Collada.Net Class Library
Lines Fields
Lines Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lines type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Methods

[image] [image]

Mogware's Collada.Net Class Library
Lines Methods
Lines Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lines type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Lines..::.Presave Method
Lines Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Lines.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Lines Properties

[image] [image]

Mogware's Collada.Net Class Library
Lines Properties
Lines Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Lines type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Lines Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Class

[image]

Mogware's Collada.Net Class Library
Linestrips Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Linestrips]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Linestrips : LinePrimitive
Visual Basic (Declaration)
Public Class Linestrips _
    Inherits LinePrimitive
Visual C++
public ref class Linestrips : public LinePrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.LinePrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Linestrips

See Also

Linestrips Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Members

[image] [image]

Mogware's Collada.Net Class Library
Linestrips Members
Linestrips Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linestrips type exposes the following members.

Constructors

Name | Description
Linestrips | Initializes a new instance of the Linestrips class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Constructor

[image]

Mogware's Collada.Net Class Library
Linestrips Constructor
Linestrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Linestrips class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Linestrips(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Linestrips(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Linestrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Linestrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Linestrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Fields

[image] [image]

Mogware's Collada.Net Class Library
Linestrips Fields
Linestrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linestrips type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Methods

[image] [image]

Mogware's Collada.Net Class Library
Linestrips Methods
Linestrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linestrips type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources | (Inherited from Primitive.)

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Linestrips..::.Presave Method
Linestrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Linestrips.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Linestrips Properties

[image] [image]

Mogware's Collada.Net Class Library
Linestrips Properties
Linestrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Linestrips type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Linestrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mesh Class

[image]

Mogware's Collada.Net Class Library
Mesh Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Mesh]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Mesh
Visual Basic (Declaration)
Public Class Mesh
Visual C++
public ref class Mesh

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

See Also

Mesh Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mesh Members

[image] [image]

Mogware's Collada.Net Class Library
Mesh Members
Mesh Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Mesh type exposes the following members.

Constructors

Name | Description
Mesh | Initializes a new instance of the Mesh class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAdjacency |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeCoincidentNormals |
Presave |
RemoveNonOccludedPolygons |
RemoveOccludedPolygons |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Geometry |
PolygonCount |
Primitives |
Sources |
Vertices |

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mesh Constructor

[image]

Mogware's Collada.Net Class Library
Mesh Constructor
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Mesh class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Mesh(
    XmlElement element,
    Geometry geometry
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    geometry As Geometry _
)
Visual C++
public:
Mesh(
    XmlElement^ element,
    Geometry^ geometry
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Geometry)"]

geometry
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Geometry

[Missing <param name="geometry"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Geometry)"]

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mesh Methods

[image] [image]

Mogware's Collada.Net Class Library
Mesh Methods
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Mesh type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GenerateAdjacency |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
MergeCoincidentNormals |
Presave |
RemoveNonOccludedPolygons |
RemoveOccludedPolygons |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GenerateAdjacency Method

[image]

Mogware's Collada.Net Class Library
Mesh..::.GenerateAdjacency Method
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.GenerateAdjacency]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void GenerateAdjacency()
Visual Basic (Declaration)
Public Sub GenerateAdjacency
Visual C++
public:
void GenerateAdjacency()

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


MergeCoincidentNormals Method

[image]

Mogware's Collada.Net Class Library
Mesh..::.MergeCoincidentNormals Method
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.MergeCoincidentNormals]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void MergeCoincidentNormals()
Visual Basic (Declaration)
Public Sub MergeCoincidentNormals
Visual C++
public:
void MergeCoincidentNormals()

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Mesh..::.Presave Method
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


RemoveNonOccludedPolygons Method

[image]

Mogware's Collada.Net Class Library
Mesh..::.RemoveNonOccludedPolygons Method
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int RemoveNonOccludedPolygons(
    List<Geometry> occludingGeometries,
    bool bUseFaceNormals,
    bool bUseVertexNormals,
    UIUpdate..::.UIUpdateEvent UIupdate
)
Visual Basic (Declaration)
Public Function RemoveNonOccludedPolygons ( _
    occludingGeometries As List(Of Geometry), _
    bUseFaceNormals As Boolean, _
    bUseVertexNormals As Boolean, _
    UIupdate As UIUpdate..::.UIUpdateEvent _
) As Integer
Visual C++
public:
int RemoveNonOccludedPolygons(
    List<Geometry^>^ occludingGeometries,
    bool bUseFaceNormals,
    bool bUseVertexNormals,
    UIUpdate..::.UIUpdateEvent^ UIupdate
)

Parameters

occludingGeometries
Type: System.Collections.Generic..::.List <(Of <( Geometry >)>)

[Missing <param name="occludingGeometries"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

bUseFaceNormals
Type: System..::.Boolean

[Missing <param name="bUseFaceNormals"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

bUseVertexNormals
Type: System..::.Boolean

[Missing <param name="bUseVertexNormals"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

UIupdate
Type: Mogware.VisualStudio.ColladaNet..::.UIUpdate..::.UIUpdateEvent

[Missing <param name="UIupdate"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveNonOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)]

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


RemoveOccludedPolygons Method

[image]

Mogware's Collada.Net Class Library
Mesh..::.RemoveOccludedPolygons Method
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int RemoveOccludedPolygons(
    List<Geometry> occludingGeometries,
    bool bUseFaceNormals,
    bool bUseVertexNormals,
    UIUpdate..::.UIUpdateEvent UIupdate
)
Visual Basic (Declaration)
Public Function RemoveOccludedPolygons ( _
    occludingGeometries As List(Of Geometry), _
    bUseFaceNormals As Boolean, _
    bUseVertexNormals As Boolean, _
    UIupdate As UIUpdate..::.UIUpdateEvent _
) As Integer
Visual C++
public:
int RemoveOccludedPolygons(
    List<Geometry^>^ occludingGeometries,
    bool bUseFaceNormals,
    bool bUseVertexNormals,
    UIUpdate..::.UIUpdateEvent^ UIupdate
)

Parameters

occludingGeometries
Type: System.Collections.Generic..::.List <(Of <( Geometry >)>)

[Missing <param name="occludingGeometries"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

bUseFaceNormals
Type: System..::.Boolean

[Missing <param name="bUseFaceNormals"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

bUseVertexNormals
Type: System..::.Boolean

[Missing <param name="bUseVertexNormals"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

UIupdate
Type: Mogware.VisualStudio.ColladaNet..::.UIUpdate..::.UIUpdateEvent

[Missing <param name="UIupdate"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.RemoveOccludedPolygons(System.Collections.Generic.List{Mogware.VisualStudio.ColladaNet.Geometry.Geometry},System.Boolean,System.Boolean,Mogware.VisualStudio.ColladaNet.UIUpdate.UIUpdateEvent)]

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mesh Properties

[image] [image]

Mogware's Collada.Net Class Library
Mesh Properties
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Mesh type exposes the following members.

Properties

Name | Description
Geometry |
PolygonCount |
Primitives |
Sources |
Vertices |

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Geometry Property

[image]

Mogware's Collada.Net Class Library
Mesh..::.Geometry Property
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.Geometry]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Geometry Geometry { get; set; }
Visual Basic (Declaration)
Public Property Geometry As Geometry
Visual C++
public:
property Geometry^ Geometry {
    Geometry^ get ();
    void set (Geometry^ value);
}

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonCount Property

[image]

Mogware's Collada.Net Class Library
Mesh..::.PolygonCount Property
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.PolygonCount]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int PolygonCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property PolygonCount As Integer
Visual C++
public:
property int PolygonCount {
    int get ();
}

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitives Property

[image]

Mogware's Collada.Net Class Library
Mesh..::.Primitives Property
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.Primitives]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Primitive> Primitives { get; }
Visual Basic (Declaration)
Public ReadOnly Property Primitives As List(Of Primitive)
Visual C++
public:
property List<Primitive^>^ Primitives {
    List<Primitive^>^ get ();
}

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Sources Property

[image]

Mogware's Collada.Net Class Library
Mesh..::.Sources Property
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.Sources]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SourceList Sources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sources As SourceList
Visual C++
public:
property SourceList^ Sources {
    SourceList^ get ();
}

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Property

[image]

Mogware's Collada.Net Class Library
Mesh..::.Vertices Property
Mesh Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Mesh.Vertices]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vertices Vertices { get; }
Visual Basic (Declaration)
Public ReadOnly Property Vertices As Vertices
Visual C++
public:
property Vertices^ Vertices {
    Vertices^ get ();
}

See Also

Mesh Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Class

[image]

Mogware's Collada.Net Class Library
Normal Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Normal]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Normal : Position
Visual Basic (Declaration)
Public Class Normal _
    Inherits Position
Visual C++
public ref class Normal : public Position

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Position
Mogware.VisualStudio.ColladaNet.Geometry..::.Normal

See Also

Normal Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Members

[image] [image]

Mogware's Collada.Net Class Library
Normal Members
Normal Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Normal type exposes the following members.

Constructors

Name | Description
Normal | Overloaded.

Methods

Name | Description
Distance | (Inherited from Position.)
DistanceSquared | (Inherited from Position.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Normalize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mIndex | (Inherited from Position.)
mVector | (Inherited from Position.)

Properties

Name | Description
Elements | (Inherited from Position.)
Index | (Inherited from Position.)
Vector | (Inherited from Position.)
X | (Inherited from Position.)
Y | (Inherited from Position.)
Z | (Inherited from Position.)

See Also

Normal Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Constructor

[image] [image]

Mogware's Collada.Net Class Library
Normal Constructor
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Normal(List<(Of <(Object>)>)) | Initializes a new instance of the Normal class
Normal(Single, Single, Single) | Initializes a new instance of the Normal class

See Also

Normal Class
Normal Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Constructor (List(Object))

[image]

Mogware's Collada.Net Class Library
Normal Constructor (List<(Of <(Object>)>))
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Normal class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Normal(
    List<Object> parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As List(Of Object) _
)
Visual C++
public:
Normal(
    List<Object^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="parameters"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Normal.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

Normal Class
Normal Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Constructor (Single, Single, Single)

[image]

Mogware's Collada.Net Class Library
Normal Constructor (Single, Single, Single)
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Normal class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Normal(
    float x,
    float y,
    float z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
Normal(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Normal.#ctor(System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Normal.#ctor(System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Normal.#ctor(System.Single,System.Single,System.Single)"]

See Also

Normal Class
Normal Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Fields

[image] [image]

Mogware's Collada.Net Class Library
Normal Fields
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Normal type exposes the following members.

Fields

Name | Description
mIndex | (Inherited from Position.)
mVector | (Inherited from Position.)

See Also

Normal Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Methods

[image] [image]

Mogware's Collada.Net Class Library
Normal Methods
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Normal type exposes the following members.

Methods

Name | Description
Distance | (Inherited from Position.)
DistanceSquared | (Inherited from Position.)
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Normalize |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Normal Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method

[image] [image]

Mogware's Collada.Net Class Library
Normal..::.Equals Method
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Position) | (Inherited from Position.)

See Also

Normal Class
Normal Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normalize Method

[image]

Mogware's Collada.Net Class Library
Normal..::.Normalize Method
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Normal.Normalize]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Normalize()
Visual Basic (Declaration)
Public Sub Normalize
Visual C++
public:
void Normalize()

See Also

Normal Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Properties

[image] [image]

Mogware's Collada.Net Class Library
Normal Properties
Normal Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Normal type exposes the following members.

Properties

Name | Description
Elements | (Inherited from Position.)
Index | (Inherited from Position.)
Vector | (Inherited from Position.)
X | (Inherited from Position.)
Y | (Inherited from Position.)
Z | (Inherited from Position.)

See Also

Normal Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Class

[image]

Mogware's Collada.Net Class Library
Polygon Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Polygon]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Polygon : Line
Visual Basic (Declaration)
Public Class Polygon _
    Inherits Line
Visual C++
public ref class Polygon : public Line

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Line
Mogware.VisualStudio.ColladaNet.Geometry..::.Polygon

See Also

Polygon Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Members

[image] [image]

Mogware's Collada.Net Class Library
Polygon Members
Polygon Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygon type exposes the following members.

Constructors

Name | Description
Polygon | Initializes a new instance of the Polygon class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mVertices | (Inherited from Line.)

Properties

Name | Description
AdjacencyList |
BoneNames | (Inherited from Line.)
BoneNamesString | (Inherited from Line.)
Normal |
Vertices | (Inherited from Line.)

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Constructor

[image]

Mogware's Collada.Net Class Library
Polygon Constructor
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Polygon class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Polygon()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Polygon()

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Fields

[image] [image]

Mogware's Collada.Net Class Library
Polygon Fields
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygon type exposes the following members.

Fields

Name | Description
mVertices | (Inherited from Line.)

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Methods

[image] [image]

Mogware's Collada.Net Class Library
Polygon Methods
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygon type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygon Properties

[image] [image]

Mogware's Collada.Net Class Library
Polygon Properties
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygon type exposes the following members.

Properties

Name | Description
AdjacencyList |
BoneNames | (Inherited from Line.)
BoneNamesString | (Inherited from Line.)
Normal |
Vertices | (Inherited from Line.)

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


AdjacencyList Property

[image]

Mogware's Collada.Net Class Library
Polygon..::.AdjacencyList Property
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Polygon.AdjacencyList]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Polygon> AdjacencyList { get; set; }
Visual Basic (Declaration)
Public Property AdjacencyList As List(Of Polygon)
Visual C++
public:
property List<Polygon^>^ AdjacencyList {
    List<Polygon^>^ get ();
    void set (List<Polygon^>^ value);
}

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normal Property

[image]

Mogware's Collada.Net Class Library
Polygon..::.Normal Property
Polygon Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Polygon.Normal]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 Normal { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normal As Vector3
Visual C++
public:
property Vector3 Normal {
    Vector3 get ();
}

See Also

Polygon Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Class

[image]

Mogware's Collada.Net Class Library
PolygonPrimitive Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.PolygonPrimitive]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class PolygonPrimitive : Primitive
Visual Basic (Declaration)
Public MustInherit Class PolygonPrimitive _
    Inherits Primitive
Visual C++
public ref class PolygonPrimitive abstract : public Primitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Polygons
Mogware.VisualStudio.ColladaNet.Geometry..::.Polylist
Mogware.VisualStudio.ColladaNet.Geometry..::.Triangles
Mogware.VisualStudio.ColladaNet.Geometry..::.Tristrips

See Also

PolygonPrimitive Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Members

[image] [image]

Mogware's Collada.Net Class Library
PolygonPrimitive Members
PolygonPrimitive Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PolygonPrimitive type exposes the following members.

Constructors

Name | Description
PolygonPrimitive | Overloaded.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Inherited from Primitive.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate |
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

PolygonPrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Constructor

[image] [image]

Mogware's Collada.Net Class Library
PolygonPrimitive Constructor
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
PolygonPrimitive()()() | Initializes a new instance of the PolygonPrimitive class
PolygonPrimitive(XmlElement, Mesh) | Initializes a new instance of the PolygonPrimitive class

See Also

PolygonPrimitive Class
PolygonPrimitive Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Constructor

[image]

Mogware's Collada.Net Class Library
PolygonPrimitive Constructor
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the PolygonPrimitive class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public PolygonPrimitive()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
PolygonPrimitive()

See Also

PolygonPrimitive Class
PolygonPrimitive Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Constructor (XmlElement, Mesh)

[image]

Mogware's Collada.Net Class Library
PolygonPrimitive Constructor (XmlElement, Mesh)
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the PolygonPrimitive class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public PolygonPrimitive(
    XmlElement element,
    Mesh mesh
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh _
)
Visual C++
public:
PolygonPrimitive(
    XmlElement^ element,
    Mesh^ mesh
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.PolygonPrimitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.PolygonPrimitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

See Also

PolygonPrimitive Class
PolygonPrimitive Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Fields

[image] [image]

Mogware's Collada.Net Class Library
PolygonPrimitive Fields
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PolygonPrimitive type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

PolygonPrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Methods

[image] [image]

Mogware's Collada.Net Class Library
PolygonPrimitive Methods
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PolygonPrimitive type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Inherited from Primitive.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate |
UpdateSources | (Inherited from Primitive.)

See Also

PolygonPrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangulate Method

[image]

Mogware's Collada.Net Class Library
PolygonPrimitive..::.Triangulate Method
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.PolygonPrimitive.Triangulate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract Triangles Triangulate()
Visual Basic (Declaration)
Public MustOverride Function Triangulate As Triangles
Visual C++
public:
virtual Triangles^ Triangulate() abstract

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.PolygonPrimitive.Triangulate]

See Also

PolygonPrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PolygonPrimitive Properties

[image] [image]

Mogware's Collada.Net Class Library
PolygonPrimitive Properties
PolygonPrimitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The PolygonPrimitive type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

PolygonPrimitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Class

[image]

Mogware's Collada.Net Class Library
Polygons Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Polygons]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Polygons : PolygonPrimitive
Visual Basic (Declaration)
Public Class Polygons _
    Inherits PolygonPrimitive
Visual C++
public ref class Polygons : public PolygonPrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Polygons

See Also

Polygons Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Members

[image] [image]

Mogware's Collada.Net Class Library
Polygons Members
Polygons Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygons type exposes the following members.

Constructors

Name | Description
Polygons | Initializes a new instance of the Polygons class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Constructor

[image]

Mogware's Collada.Net Class Library
Polygons Constructor
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Polygons class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Polygons(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Polygons(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Fields

[image] [image]

Mogware's Collada.Net Class Library
Polygons Fields
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygons type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Methods

[image] [image]

Mogware's Collada.Net Class Library
Polygons Methods
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygons type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Polygons..::.Presave Method
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangulate Method

[image]

Mogware's Collada.Net Class Library
Polygons..::.Triangulate Method
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.Triangulate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override Triangles Triangulate()
Visual Basic (Declaration)
Public Overrides Function Triangulate As Triangles
Visual C++
public:
virtual Triangles^ Triangulate() override

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polygons.Triangulate]

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Properties

[image] [image]

Mogware's Collada.Net Class Library
Polygons Properties
Polygons Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polygons type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Polygons Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Class

[image]

Mogware's Collada.Net Class Library
Polylist Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Polylist]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Polylist : PolygonPrimitive
Visual Basic (Declaration)
Public Class Polylist _
    Inherits PolygonPrimitive
Visual C++
public ref class Polylist : public PolygonPrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Polylist

See Also

Polylist Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Members

[image] [image]

Mogware's Collada.Net Class Library
Polylist Members
Polylist Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polylist type exposes the following members.

Constructors

Name | Description
Polylist | Initializes a new instance of the Polylist class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Constructor

[image]

Mogware's Collada.Net Class Library
Polylist Constructor
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Polylist class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Polylist(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Polylist(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Fields

[image] [image]

Mogware's Collada.Net Class Library
Polylist Fields
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polylist type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Methods

[image] [image]

Mogware's Collada.Net Class Library
Polylist Methods
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polylist type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Polylist..::.Presave Method
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangulate Method

[image]

Mogware's Collada.Net Class Library
Polylist..::.Triangulate Method
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.Triangulate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override Triangles Triangulate()
Visual Basic (Declaration)
Public Overrides Function Triangulate As Triangles
Visual C++
public:
virtual Triangles^ Triangulate() override

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Polylist.Triangulate]

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polylist Properties

[image] [image]

Mogware's Collada.Net Class Library
Polylist Properties
Polylist Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Polylist type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Polylist Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Class

[image]

Mogware's Collada.Net Class Library
Position Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Position]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Position
Visual Basic (Declaration)
Public Class Position
Visual C++
public ref class Position

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Position
Mogware.VisualStudio.ColladaNet.Geometry..::.Normal

See Also

Position Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Members

[image] [image]

Mogware's Collada.Net Class Library
Position Members
Position Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Position type exposes the following members.

Constructors

Name | Description
Position | Overloaded.

Methods

Name | Description
Distance |
DistanceSquared |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mIndex |
mVector |

Properties

Name | Description
Elements |
Index |
Vector |
X |
Y |
Z |

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Constructor

[image] [image]

Mogware's Collada.Net Class Library
Position Constructor
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Position(Vector3) | Initializes a new instance of the Position class
Position(List<(Of <(Object>)>)) | Initializes a new instance of the Position class
Position(Single, Single, Single) | Initializes a new instance of the Position class

See Also

Position Class
Position Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Constructor ()

[image]

Mogware's Collada.Net Class Library
Position Constructor ()
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Position class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Position(
    Vector3 vec
)
Visual Basic (Declaration)
Public Sub New ( _
    vec As Vector3 _
)
Visual C++
public:
Position(
    Vector3 vec
)

Parameters

vec
Type: Vector3

[Missing <param name="vec"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.#ctor(Microsoft.DirectX.Vector3)"]

See Also

Position Class
Position Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Constructor (List(Object))

[image]

Mogware's Collada.Net Class Library
Position Constructor (List<(Of <(Object>)>))
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Position class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Position(
    List<Object> parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As List(Of Object) _
)
Visual C++
public:
Position(
    List<Object^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="parameters"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

Position Class
Position Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Constructor (Single, Single, Single)

[image]

Mogware's Collada.Net Class Library
Position Constructor (Single, Single, Single)
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Position class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Position(
    float x,
    float y,
    float z
)
Visual Basic (Declaration)
Public Sub New ( _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
Position(
    float x,
    float y,
    float z
)

Parameters

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.#ctor(System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.#ctor(System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.#ctor(System.Single,System.Single,System.Single)"]

See Also

Position Class
Position Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Fields

[image] [image]

Mogware's Collada.Net Class Library
Position Fields
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Position type exposes the following members.

Fields

Name | Description
mIndex |
mVector |

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mIndex Field

[image]

Mogware's Collada.Net Class Library
Position..::.mIndex Field
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Position.mIndex]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected int mIndex
Visual Basic (Declaration)
Protected mIndex As Integer
Visual C++
protected:
int mIndex

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mVector Field

[image]

Mogware's Collada.Net Class Library
Position..::.mVector Field
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Position.mVector]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected Vector3 mVector
Visual Basic (Declaration)
Protected mVector As Vector3
Visual C++
protected:
Vector3 mVector

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Methods

[image] [image]

Mogware's Collada.Net Class Library
Position Methods
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Position type exposes the following members.

Methods

Name | Description
Distance |
DistanceSquared |
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Distance Method

[image]

Mogware's Collada.Net Class Library
Position..::.Distance Method
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Distance(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Distance(
    Position p
)
Visual Basic (Declaration)
Public Function Distance ( _
    p As Position _
) As Single
Visual C++
public:
float Distance(
    Position^ p
)

Parameters

p
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Position

[Missing <param name="p"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Distance(Mogware.VisualStudio.ColladaNet.Geometry.Position)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Distance(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


DistanceSquared Method

[image]

Mogware's Collada.Net Class Library
Position..::.DistanceSquared Method
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.DistanceSquared(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float DistanceSquared(
    Position p
)
Visual Basic (Declaration)
Public Function DistanceSquared ( _
    p As Position _
) As Single
Visual C++
public:
float DistanceSquared(
    Position^ p
)

Parameters

p
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Position

[Missing <param name="p"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.DistanceSquared(Mogware.VisualStudio.ColladaNet.Geometry.Position)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.DistanceSquared(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method

[image] [image]

Mogware's Collada.Net Class Library
Position..::.Equals Method
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Position) |

See Also

Position Class
Position Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method (Position)

[image]

Mogware's Collada.Net Class Library
Position..::.Equals Method (Position)
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Equals(
    Position p
)
Visual Basic (Declaration)
Public Function Equals ( _
    p As Position _
) As Boolean
Visual C++
public:
bool Equals(
    Position^ p
)

Parameters

p
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Position

[Missing <param name="p"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Position)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Position.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Position)]

See Also

Position Class
Equals Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Properties

[image] [image]

Mogware's Collada.Net Class Library
Position Properties
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Position type exposes the following members.

Properties

Name | Description
Elements |
Index |
Vector |
X |
Y |
Z |

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Elements Property

[image]

Mogware's Collada.Net Class Library
Position..::.Elements Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.Elements]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float[] Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As Single()
Visual C++
public:
property array<float>^ Elements {
    array<float>^ get ();
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Index Property

[image]

Mogware's Collada.Net Class Library
Position..::.Index Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.Index]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vector Property

[image]

Mogware's Collada.Net Class Library
Position..::.Vector Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.Vector]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 Vector { get; set; }
Visual Basic (Declaration)
Public Property Vector As Vector3
Visual C++
public:
property Vector3 Vector {
    Vector3 get ();
    void set (Vector3 value);
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


X Property

[image]

Mogware's Collada.Net Class Library
Position..::.X Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.X]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float X { get; set; }
Visual Basic (Declaration)
Public Property X As Single
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Y Property

[image]

Mogware's Collada.Net Class Library
Position..::.Y Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.Y]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Single
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Z Property

[image]

Mogware's Collada.Net Class Library
Position..::.Z Property
Position Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Position.Z]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Z { get; set; }
Visual Basic (Declaration)
Public Property Z As Single
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

Position Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Class

[image]

Mogware's Collada.Net Class Library
Primitive Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Primitive]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract class Primitive
Visual Basic (Declaration)
Public MustInherit Class Primitive
Visual C++
public ref class Primitive abstract

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.LinePrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive

See Also

Primitive Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Members

[image] [image]

Mogware's Collada.Net Class Library
Primitive Members
Primitive Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Primitive type exposes the following members.

Constructors

Name | Description
Primitive | Overloaded.

Methods

Name | Description
Combine |
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources |

Fields

Name | Description
mCount |
mInputs |
mMaterial |
mP |
mPElements |
mPolygons |
mPrimitiveElement |
mVCount |
mVCountElement |

Properties

Name | Description
Material |
Polygons |

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Constructor

[image] [image]

Mogware's Collada.Net Class Library
Primitive Constructor
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Primitive()()() | Initializes a new instance of the Primitive class
Primitive(XmlElement, Mesh) | Initializes a new instance of the Primitive class

See Also

Primitive Class
Primitive Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Constructor

[image]

Mogware's Collada.Net Class Library
Primitive Constructor
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Primitive class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Primitive()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Primitive()

See Also

Primitive Class
Primitive Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Constructor (XmlElement, Mesh)

[image]

Mogware's Collada.Net Class Library
Primitive Constructor (XmlElement, Mesh)
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Primitive class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Primitive(
    XmlElement element,
    Mesh mesh
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh _
)
Visual C++
public:
Primitive(
    XmlElement^ element,
    Mesh^ mesh
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

See Also

Primitive Class
Primitive Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Fields

[image] [image]

Mogware's Collada.Net Class Library
Primitive Fields
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Primitive type exposes the following members.

Fields

Name | Description
mCount |
mInputs |
mMaterial |
mP |
mPElements |
mPolygons |
mPrimitiveElement |
mVCount |
mVCountElement |

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mCount Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mCount Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mCount]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected int mCount
Visual Basic (Declaration)
Protected mCount As Integer
Visual C++
protected:
int mCount

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mInputs Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mInputs Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mInputs]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected InputList mInputs
Visual Basic (Declaration)
Protected mInputs As InputList
Visual C++
protected:
InputList^ mInputs

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mMaterial Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mMaterial Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mMaterial]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected Material mMaterial
Visual Basic (Declaration)
Protected mMaterial As Material
Visual C++
protected:
Material^ mMaterial

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mP Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mP Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mP]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected List<List<int>> mP
Visual Basic (Declaration)
Protected mP As List(Of List(Of Integer))
Visual C++
protected:
List<List<int>^>^ mP

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mPElements Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mPElements Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mPElements]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected List<XmlElement> mPElements
Visual Basic (Declaration)
Protected mPElements As List(Of XmlElement)
Visual C++
protected:
List<XmlElement^>^ mPElements

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mPolygons Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mPolygons Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mPolygons]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected List<Polygon> mPolygons
Visual Basic (Declaration)
Protected mPolygons As List(Of Polygon)
Visual C++
protected:
List<Polygon^>^ mPolygons

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mPrimitiveElement Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mPrimitiveElement Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mPrimitiveElement]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected XmlElement mPrimitiveElement
Visual Basic (Declaration)
Protected mPrimitiveElement As XmlElement
Visual C++
protected:
XmlElement^ mPrimitiveElement

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mVCount Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mVCount Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mVCount]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected List<int> mVCount
Visual Basic (Declaration)
Protected mVCount As List(Of Integer)
Visual C++
protected:
List<int>^ mVCount

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mVCountElement Field

[image]

Mogware's Collada.Net Class Library
Primitive..::.mVCountElement Field
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.mVCountElement]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected XmlElement mVCountElement
Visual Basic (Declaration)
Protected mVCountElement As XmlElement
Visual C++
protected:
XmlElement^ mVCountElement

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Methods

[image] [image]

Mogware's Collada.Net Class Library
Primitive Methods
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Primitive type exposes the following members.

Methods

Name | Description
Combine |
Create |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)
UpdateSources |

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Combine Method

[image]

Mogware's Collada.Net Class Library
Primitive..::.Combine Method
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Combine(Mogware.VisualStudio.ColladaNet.Geometry.Primitive)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Combine(
    Primitive prim
)
Visual Basic (Declaration)
Public Sub Combine ( _
    prim As Primitive _
)
Visual C++
public:
void Combine(
    Primitive^ prim
)

Parameters

prim
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive

[Missing <param name="prim"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Combine(Mogware.VisualStudio.ColladaNet.Geometry.Primitive)"]

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Create Method

[image]

Mogware's Collada.Net Class Library
Primitive..::.Create Method
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public static Primitive Create(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Shared Function Create ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
) As Primitive
Visual C++
public:
static Primitive^ Create(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Create(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)]

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Primitive..::.Presave Method
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public abstract void Presave()
Visual Basic (Declaration)
Public MustOverride Sub Presave
Visual C++
public:
virtual void Presave() abstract

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


UpdateSources Method

[image]

Mogware's Collada.Net Class Library
Primitive..::.UpdateSources Method
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.UpdateSources]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected void UpdateSources()
Visual Basic (Declaration)
Protected Sub UpdateSources
Visual C++
protected:
void UpdateSources()

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Primitive Properties

[image] [image]

Mogware's Collada.Net Class Library
Primitive Properties
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Primitive type exposes the following members.

Properties

Name | Description
Material |
Polygons |

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Material Property

[image]

Mogware's Collada.Net Class Library
Primitive..::.Material Property
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Material]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Material Material { get; set; }
Visual Basic (Declaration)
Public Property Material As Material
Visual C++
public:
property Material^ Material {
    Material^ get ();
    void set (Material^ value);
}

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Polygons Property

[image]

Mogware's Collada.Net Class Library
Primitive..::.Polygons Property
Primitive Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Primitive.Polygons]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Polygon> Polygons { get; }
Visual Basic (Declaration)
Public ReadOnly Property Polygons As List(Of Polygon)
Visual C++
public:
property List<Polygon^>^ Polygons {
    List<Polygon^>^ get ();
}

See Also

Primitive Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


PrimitiveType Enumeration

[image]

Mogware's Collada.Net Class Library
PrimitiveType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.PrimitiveType]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum PrimitiveType
Visual Basic (Declaration)
Public Enumeration PrimitiveType
Visual C++
public enum class PrimitiveType

Members

Member name | Description
lines |
linestrips |
polygons |
polylist |
triangles |
trifans |
tristrips |

See Also

Mogware.VisualStudio.ColladaNet.Geometry Namespace


Ray Class

[image]

Mogware's Collada.Net Class Library
Ray Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Ray]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Ray
Visual Basic (Declaration)
Public Class Ray
Visual C++
public ref class Ray

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Ray

See Also

Ray Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Ray Members

[image] [image]

Mogware's Collada.Net Class Library
Ray Members
Ray Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Ray type exposes the following members.

Constructors

Name | Description
Ray | Initializes a new instance of the Ray class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersects |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Direction |
Position |

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Ray Constructor

[image]

Mogware's Collada.Net Class Library
Ray Constructor
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Ray class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Ray(
    Vector3 pos,
    Vector3 dir
)
Visual Basic (Declaration)
Public Sub New ( _
    pos As Vector3, _
    dir As Vector3 _
)
Visual C++
public:
Ray(
    Vector3 pos,
    Vector3 dir
)

Parameters

pos
Type: Vector3

[Missing <param name="pos"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.#ctor(Microsoft.DirectX.Vector3,Microsoft.DirectX.Vector3)"]

dir
Type: Vector3

[Missing <param name="dir"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.#ctor(Microsoft.DirectX.Vector3,Microsoft.DirectX.Vector3)"]

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Ray Methods

[image] [image]

Mogware's Collada.Net Class Library
Ray Methods
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Ray type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
Intersects |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Intersects Method

[image]

Mogware's Collada.Net Class Library
Ray..::.Intersects Method
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Intersects(Mogware.VisualStudio.ColladaNet.Geometry.Polygon,Microsoft.DirectX.Vector3@)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Intersects(
    Polygon polygon,
    ref Vector3 intersection
)
Visual Basic (Declaration)
Public Function Intersects ( _
    polygon As Polygon, _
    ByRef intersection As Vector3 _
) As Boolean
Visual C++
public:
bool Intersects(
    Polygon^ polygon,
    Vector3% intersection
)

Parameters

polygon
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Polygon

[Missing <param name="polygon"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Intersects(Mogware.VisualStudio.ColladaNet.Geometry.Polygon,Microsoft.DirectX.Vector3@)"]

intersection
Type: Vector3 %

[Missing <param name="intersection"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Intersects(Mogware.VisualStudio.ColladaNet.Geometry.Polygon,Microsoft.DirectX.Vector3@)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Intersects(Mogware.VisualStudio.ColladaNet.Geometry.Polygon,Microsoft.DirectX.Vector3@)]

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Ray Properties

[image] [image]

Mogware's Collada.Net Class Library
Ray Properties
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Ray type exposes the following members.

Properties

Name | Description
Direction |
Position |

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Direction Property

[image]

Mogware's Collada.Net Class Library
Ray..::.Direction Property
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Direction]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 Direction { get; set; }
Visual Basic (Declaration)
Public Property Direction As Vector3
Visual C++
public:
property Vector3 Direction {
    Vector3 get ();
    void set (Vector3 value);
}

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Position Property

[image]

Mogware's Collada.Net Class Library
Ray..::.Position Property
Ray Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Ray.Position]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 Position { get; set; }
Visual Basic (Declaration)
Public Property Position As Vector3
Visual C++
public:
property Vector3 Position {
    Vector3 get ();
    void set (Vector3 value);
}

See Also

Ray Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Class

[image]

Mogware's Collada.Net Class Library
TextureCoordinate Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class TextureCoordinate
Visual Basic (Declaration)
Public Class TextureCoordinate
Visual C++
public ref class TextureCoordinate

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.TextureCoordinate

See Also

TextureCoordinate Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Members

[image] [image]

Mogware's Collada.Net Class Library
TextureCoordinate Members
TextureCoordinate Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureCoordinate type exposes the following members.

Constructors

Name | Description
TextureCoordinate | Initializes a new instance of the TextureCoordinate class

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mIndex |

Properties

Name | Description
DimensionCount |
Elements |
Index |
U |
V |
W |

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Constructor

[image]

Mogware's Collada.Net Class Library
TextureCoordinate Constructor
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TextureCoordinate class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TextureCoordinate(
    List<Object> parameters
)
Visual Basic (Declaration)
Public Sub New ( _
    parameters As List(Of Object) _
)
Visual C++
public:
TextureCoordinate(
    List<Object^>^ parameters
)

Parameters

parameters
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="parameters"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Fields

[image] [image]

Mogware's Collada.Net Class Library
TextureCoordinate Fields
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureCoordinate type exposes the following members.

Fields

Name | Description
mIndex |

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


mIndex Field

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.mIndex Field
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.mIndex]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected int mIndex
Visual Basic (Declaration)
Protected mIndex As Integer
Visual C++
protected:
int mIndex

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Methods

[image] [image]

Mogware's Collada.Net Class Library
TextureCoordinate Methods
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureCoordinate type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method

[image] [image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.Equals Method
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(TextureCoordinate) |

See Also

TextureCoordinate Class
TextureCoordinate Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method (TextureCoordinate)

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.Equals Method (TextureCoordinate)
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.Equals(Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Equals(
    TextureCoordinate t
)
Visual Basic (Declaration)
Public Function Equals ( _
    t As TextureCoordinate _
) As Boolean
Visual C++
public:
bool Equals(
    TextureCoordinate^ t
)

Parameters

t
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.TextureCoordinate

[Missing <param name="t"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.Equals(Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.Equals(Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate)]

See Also

TextureCoordinate Class
Equals Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinate Properties

[image] [image]

Mogware's Collada.Net Class Library
TextureCoordinate Properties
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TextureCoordinate type exposes the following members.

Properties

Name | Description
DimensionCount |
Elements |
Index |
U |
V |
W |

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


DimensionCount Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.DimensionCount Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.DimensionCount]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int DimensionCount { get; set; }
Visual Basic (Declaration)
Public Property DimensionCount As Integer
Visual C++
public:
property int DimensionCount {
    int get ();
    void set (int value);
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Elements Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.Elements Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.Elements]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float[] Elements { get; }
Visual Basic (Declaration)
Public ReadOnly Property Elements As Single()
Visual C++
public:
property array<float>^ Elements {
    array<float>^ get ();
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Index Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.Index Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.Index]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


U Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.U Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.U]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float U { get; set; }
Visual Basic (Declaration)
Public Property U As Single
Visual C++
public:
property float U {
    float get ();
    void set (float value);
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


V Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.V Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.V]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float V { get; set; }
Visual Basic (Declaration)
Public Property V As Single
Visual C++
public:
property float V {
    float get ();
    void set (float value);
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


W Property

[image]

Mogware's Collada.Net Class Library
TextureCoordinate..::.W Property
TextureCoordinate Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.TextureCoordinate.W]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float W { get; set; }
Visual Basic (Declaration)
Public Property W As Single
Visual C++
public:
property float W {
    float get ();
    void set (float value);
}

See Also

TextureCoordinate Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Class

[image]

Mogware's Collada.Net Class Library
Triangles Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Triangles]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Triangles : PolygonPrimitive
Visual Basic (Declaration)
Public Class Triangles _
    Inherits PolygonPrimitive
Visual C++
public ref class Triangles : public PolygonPrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Triangles

See Also

Triangles Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Members

[image] [image]

Mogware's Collada.Net Class Library
Triangles Members
Triangles Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Triangles type exposes the following members.

Constructors

Name | Description
Triangles | Overloaded.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Constructor

[image] [image]

Mogware's Collada.Net Class Library
Triangles Constructor
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Triangles(XmlElement, InputList) | Initializes a new instance of the Triangles class
Triangles(XmlElement, Mesh, Skin) | Initializes a new instance of the Triangles class

See Also

Triangles Class
Triangles Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Constructor (XmlElement, InputList)

[image]

Mogware's Collada.Net Class Library
Triangles Constructor (XmlElement, InputList)
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Triangles class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Triangles(
    XmlElement primitiveElement,
    InputList inputs
)
Visual Basic (Declaration)
Public Sub New ( _
    primitiveElement As XmlElement, _
    inputs As InputList _
)
Visual C++
public:
Triangles(
    XmlElement^ primitiveElement,
    InputList^ inputs
)

Parameters

primitiveElement
Type: System.Xml..::.XmlElement

[Missing <param name="primitiveElement"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.InputList)"]

inputs
Type: Mogware.VisualStudio.ColladaNet..::.InputList

[Missing <param name="inputs"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.InputList)"]

See Also

Triangles Class
Triangles Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Constructor (XmlElement, Mesh, Skin)

[image]

Mogware's Collada.Net Class Library
Triangles Constructor (XmlElement, Mesh, Skin)
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Triangles class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Triangles(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Triangles(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Triangles Class
Triangles Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Fields

[image] [image]

Mogware's Collada.Net Class Library
Triangles Fields
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Triangles type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Methods

[image] [image]

Mogware's Collada.Net Class Library
Triangles Methods
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Triangles type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Triangles..::.Presave Method
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangulate Method

[image]

Mogware's Collada.Net Class Library
Triangles..::.Triangulate Method
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.Triangulate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override Triangles Triangulate()
Visual Basic (Declaration)
Public Overrides Function Triangulate As Triangles
Visual C++
public:
virtual Triangles^ Triangulate() override

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Triangles.Triangulate]

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangles Properties

[image] [image]

Mogware's Collada.Net Class Library
Triangles Properties
Triangles Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Triangles type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Triangles Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Class

[image]

Mogware's Collada.Net Class Library
Trifans Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Trifans]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Trifans : Tristrips
Visual Basic (Declaration)
Public Class Trifans _
    Inherits Tristrips
Visual C++
public ref class Trifans : public Tristrips

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Tristrips
Mogware.VisualStudio.ColladaNet.Geometry..::.Trifans

See Also

Trifans Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Members

[image] [image]

Mogware's Collada.Net Class Library
Trifans Members
Trifans Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Trifans type exposes the following members.

Constructors

Name | Description
Trifans | Initializes a new instance of the Trifans class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Tristrips..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Inherited from Tristrips.)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Constructor

[image]

Mogware's Collada.Net Class Library
Trifans Constructor
Trifans Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Trifans class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Trifans(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Trifans(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Trifans.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Trifans.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Trifans.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Fields

[image] [image]

Mogware's Collada.Net Class Library
Trifans Fields
Trifans Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Trifans type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Methods

[image] [image]

Mogware's Collada.Net Class Library
Trifans Methods
Trifans Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Trifans type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Tristrips..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Inherited from Tristrips.)
UpdateSources | (Inherited from Primitive.)

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Trifans..::.Presave Method
Trifans Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Trifans.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Trifans Properties

[image] [image]

Mogware's Collada.Net Class Library
Trifans Properties
Trifans Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Trifans type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Trifans Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Class

[image]

Mogware's Collada.Net Class Library
Tristrips Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Tristrips : PolygonPrimitive
Visual Basic (Declaration)
Public Class Tristrips _
    Inherits PolygonPrimitive
Visual C++
public ref class Tristrips : public PolygonPrimitive

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Primitive
Mogware.VisualStudio.ColladaNet.Geometry..::.PolygonPrimitive
Mogware.VisualStudio.ColladaNet.Geometry..::.Tristrips
Mogware.VisualStudio.ColladaNet.Geometry..::.Trifans

See Also

Tristrips Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Members

[image] [image]

Mogware's Collada.Net Class Library
Tristrips Members
Tristrips Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tristrips type exposes the following members.

Constructors

Name | Description
Tristrips | Initializes a new instance of the Tristrips class

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Constructor

[image]

Mogware's Collada.Net Class Library
Tristrips Constructor
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Tristrips class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Tristrips(
    XmlElement element,
    Mesh mesh,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh, _
    skin As Skin _
)
Visual C++
public:
Tristrips(
    XmlElement^ element,
    Mesh^ mesh,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Fields

[image] [image]

Mogware's Collada.Net Class Library
Tristrips Fields
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tristrips type exposes the following members.

Fields

Name | Description
mCount | (Inherited from Primitive.)
mInputs | (Inherited from Primitive.)
mMaterial | (Inherited from Primitive.)
mP | (Inherited from Primitive.)
mPElements | (Inherited from Primitive.)
mPolygons | (Inherited from Primitive.)
mPrimitiveElement | (Inherited from Primitive.)
mVCount | (Inherited from Primitive.)
mVCountElement | (Inherited from Primitive.)

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Methods

[image] [image]

Mogware's Collada.Net Class Library
Tristrips Methods
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tristrips type exposes the following members.

Methods

Name | Description
Combine | (Inherited from Primitive.)
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave | (Overrides Primitive..::.Presave()()().)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
Triangulate | (Overrides PolygonPrimitive..::.Triangulate()()().)
UpdateSources | (Inherited from Primitive.)

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Tristrips..::.Presave Method
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override void Presave()
Visual Basic (Declaration)
Public Overrides Sub Presave
Visual C++
public:
virtual void Presave() override

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Triangulate Method

[image]

Mogware's Collada.Net Class Library
Tristrips..::.Triangulate Method
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.Triangulate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public override Triangles Triangulate()
Visual Basic (Declaration)
Public Overrides Function Triangulate As Triangles
Visual C++
public:
virtual Triangles^ Triangulate() override

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Tristrips.Triangulate]

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Tristrips Properties

[image] [image]

Mogware's Collada.Net Class Library
Tristrips Properties
Tristrips Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Tristrips type exposes the following members.

Properties

Name | Description
Material | (Inherited from Primitive.)
Polygons | (Inherited from Primitive.)

See Also

Tristrips Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Class

[image]

Mogware's Collada.Net Class Library
Vertex Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Vertex]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Vertex : WeightedObject
Visual Basic (Declaration)
Public Class Vertex _
    Inherits WeightedObject
Visual C++
public ref class Vertex : public WeightedObject

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.WeightedObject
Mogware.VisualStudio.ColladaNet.Geometry..::.Vertex

See Also

Vertex Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Members

[image] [image]

Mogware's Collada.Net Class Library
Vertex Members
Vertex Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertex type exposes the following members.

Constructors

Name | Description
Vertex | Overloaded.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeWeights | (Inherited from WeightedObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mInfluences | (Inherited from WeightedObject.)

Properties

Name | Description
Influences | (Inherited from WeightedObject.)
IsDuplicate |
Normals |
Positions |
TextureCoordinates |

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Constructor

[image] [image]

Mogware's Collada.Net Class Library
Vertex Constructor
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Vertex(Vertex) | Initializes a new instance of the Vertex class
Vertex(List<(Of <(Object>)>)) | Initializes a new instance of the Vertex class

See Also

Vertex Class
Vertex Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Constructor (Vertex)

[image]

Mogware's Collada.Net Class Library
Vertex Constructor (Vertex)
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Vertex class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vertex(
    Vertex other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As Vertex _
)
Visual C++
public:
Vertex(
    Vertex^ other
)

Parameters

other
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Vertex

[Missing <param name="other"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.#ctor(Mogware.VisualStudio.ColladaNet.Geometry.Vertex)"]

See Also

Vertex Class
Vertex Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Constructor (List(Object))

[image]

Mogware's Collada.Net Class Library
Vertex Constructor (List<(Of <(Object>)>))
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Vertex class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vertex(
    List<Object> args
)
Visual Basic (Declaration)
Public Sub New ( _
    args As List(Of Object) _
)
Visual C++
public:
Vertex(
    List<Object^>^ args
)

Parameters

args
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="args"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

Vertex Class
Vertex Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Fields

[image] [image]

Mogware's Collada.Net Class Library
Vertex Fields
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertex type exposes the following members.

Fields

Name | Description
mInfluences | (Inherited from WeightedObject.)

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Methods

[image] [image]

Mogware's Collada.Net Class Library
Vertex Methods
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertex type exposes the following members.

Methods

Name | Description
Equals | Overloaded.
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeWeights | (Inherited from WeightedObject.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method

[image] [image]

Mogware's Collada.Net Class Library
Vertex..::.Equals Method
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Equals(Vertex) |

See Also

Vertex Class
Vertex Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Equals Method (Vertex)

[image]

Mogware's Collada.Net Class Library
Vertex..::.Equals Method (Vertex)
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Vertex)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Equals(
    Vertex vertex
)
Visual Basic (Declaration)
Public Function Equals ( _
    vertex As Vertex _
) As Boolean
Visual C++
public:
bool Equals(
    Vertex^ vertex
)

Parameters

vertex
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Vertex

[Missing <param name="vertex"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Vertex)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.Equals(Mogware.VisualStudio.ColladaNet.Geometry.Vertex)]

See Also

Vertex Class
Equals Overload
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertex Properties

[image] [image]

Mogware's Collada.Net Class Library
Vertex Properties
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertex type exposes the following members.

Properties

Name | Description
Influences | (Inherited from WeightedObject.)
IsDuplicate |
Normals |
Positions |
TextureCoordinates |

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


IsDuplicate Property

[image]

Mogware's Collada.Net Class Library
Vertex..::.IsDuplicate Property
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.IsDuplicate]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool IsDuplicate { get; set; }
Visual Basic (Declaration)
Public Property IsDuplicate As Boolean
Visual C++
public:
property bool IsDuplicate {
    bool get ();
    void set (bool value);
}

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Normals Property

[image]

Mogware's Collada.Net Class Library
Vertex..::.Normals Property
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.Normals]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Normal> Normals { get; }
Visual Basic (Declaration)
Public ReadOnly Property Normals As List(Of Normal)
Visual C++
public:
property List<Normal^>^ Normals {
    List<Normal^>^ get ();
}

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Positions Property

[image]

Mogware's Collada.Net Class Library
Vertex..::.Positions Property
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.Positions]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<Position> Positions { get; }
Visual Basic (Declaration)
Public ReadOnly Property Positions As List(Of Position)
Visual C++
public:
property List<Position^>^ Positions {
    List<Position^>^ get ();
}

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


TextureCoordinates Property

[image]

Mogware's Collada.Net Class Library
Vertex..::.TextureCoordinates Property
Vertex Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertex.TextureCoordinates]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<TextureCoordinate> TextureCoordinates { get; set; }
Visual Basic (Declaration)
Public Property TextureCoordinates As List(Of TextureCoordinate)
Visual C++
public:
property List<TextureCoordinate^>^ TextureCoordinates {
    List<TextureCoordinate^>^ get ();
    void set (List<TextureCoordinate^>^ value);
}

See Also

Vertex Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Class

[image]

Mogware's Collada.Net Class Library
Vertices Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Geometry.Vertices]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Vertices : ISource
Visual Basic (Declaration)
Public Class Vertices _
    Implements ISource
Visual C++
public ref class Vertices : ISource

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Geometry..::.Vertices

See Also

Vertices Members
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Members

[image] [image]

Mogware's Collada.Net Class Library
Vertices Members
Vertices Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertices type exposes the following members.

Constructors

Name | Description
Vertices | Initializes a new instance of the Vertices class

Methods

Name | Description
Add |
AddRange |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIndex |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Constructor

[image]

Mogware's Collada.Net Class Library
Vertices Constructor
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Vertices class

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vertices(
    XmlElement element,
    Mesh mesh
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    mesh As Mesh _
)
Visual C++
public:
Vertices(
    XmlElement^ element,
    Mesh^ mesh
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

mesh
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Mesh

[Missing <param name="mesh"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Geometry.Mesh)"]

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Methods

[image] [image]

Mogware's Collada.Net Class Library
Vertices Methods
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertices type exposes the following members.

Methods

Name | Description
Add |
AddRange |
Clear |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetIndex |
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Add Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.Add Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Add(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool Add(
    Object item
)
Visual Basic (Declaration)
Public Function Add ( _
    item As Object _
) As Boolean
Visual C++
public:
virtual bool Add(
    Object^ item
) sealed

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Add(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Add(System.Object)]

Implements

ISource..::.Add(Object)

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


AddRange Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.AddRange Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.AddRange(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int AddRange(
    IList range
)
Visual Basic (Declaration)
Public Function AddRange ( _
    range As IList _
) As Integer
Visual C++
public:
virtual int AddRange(
    IList^ range
) sealed

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.AddRange(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.AddRange(System.Collections.IList)]

Implements

ISource..::.AddRange(IList)

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Clear Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.Clear Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Clear]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
virtual void Clear() sealed

Implements

ISource..::.Clear()()()

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


GetIndex Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.GetIndex Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.GetIndex(System.Collections.IList)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int GetIndex(
    IList range
)
Visual Basic (Declaration)
Public Function GetIndex ( _
    range As IList _
) As Integer
Visual C++
public:
virtual int GetIndex(
    IList^ range
) sealed

Parameters

range
Type: System.Collections..::.IList

[Missing <param name="range"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.GetIndex(System.Collections.IList)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.GetIndex(System.Collections.IList)]

Implements

ISource..::.GetIndex(IList)

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


IndexOf Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.IndexOf Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.IndexOf(System.Object)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int IndexOf(
    Object item
)
Visual Basic (Declaration)
Public Function IndexOf ( _
    item As Object _
) As Integer
Visual C++
public:
virtual int IndexOf(
    Object^ item
) sealed

Parameters

item
Type: System..::.Object

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.IndexOf(System.Object)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.IndexOf(System.Object)]

Implements

ISource..::.IndexOf(Object)

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Vertices..::.Presave Method
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
virtual void Presave() sealed

Implements

ISource..::.Presave()()()

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Vertices Properties

[image] [image]

Mogware's Collada.Net Class Library
Vertices Properties
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Vertices type exposes the following members.

Properties

Name | Description
AllowDuplicates |
Data |
Hash |
Id |
Item |
ItemCount |
Name |

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


AllowDuplicates Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.AllowDuplicates Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.AllowDuplicates]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool AllowDuplicates { get; set; }
Visual Basic (Declaration)
Public Property AllowDuplicates As Boolean
Visual C++
public:
virtual property bool AllowDuplicates {
    bool get () sealed;
    void set (bool value) sealed;
}

Implements

ISource..::.AllowDuplicates

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Data Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.Data Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Data]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public IList<Object> Data { get; }
Visual Basic (Declaration)
Public ReadOnly Property Data As IList(Of Object)
Visual C++
public:
virtual property IList<Object^>^ Data {
    IList<Object^>^ get () sealed;
}

Implements

ISource..::.Data

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Hash Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.Hash Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Hash]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Hashtable Hash { get; }
Visual Basic (Declaration)
Public ReadOnly Property Hash As Hashtable
Visual C++
public:
virtual property Hashtable^ Hash {
    Hashtable^ get () sealed;
}

Implements

ISource..::.Hash

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.Id Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; }
Visual Basic (Declaration)
Public ReadOnly Property Id As String
Visual C++
public:
virtual property String^ Id {
    String^ get () sealed;
}

Implements

ISource..::.Id

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Item Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.Item Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Item(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Object this[
    int index
] { get; set; }
Visual Basic (Declaration)
Public Default Property Item ( _
    index As Integer _
) As Object
Visual C++
public:
virtual property Object^ default[int index] {
    Object^ get (int index) sealed;
    void set (int index, Object^ value) sealed;
}

Parameters

index
Type: System..::.Int32

Implements

ISource..::.Item[([(Int32])])

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


ItemCount Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.ItemCount Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.ItemCount]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int ItemCount { get; }
Visual Basic (Declaration)
Public ReadOnly Property ItemCount As Integer
Visual C++
public:
virtual property int ItemCount {
    int get () sealed;
}

Implements

ISource..::.ItemCount

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Vertices..::.Name Property
Vertices Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Geometry.Vertices.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Geometry
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; }
Visual Basic (Declaration)
Public ReadOnly Property Name As String
Visual C++
public:
virtual property String^ Name {
    String^ get () sealed;
}

Implements

ISource..::.Name

See Also

Vertices Class
Mogware.VisualStudio.ColladaNet.Geometry Namespace


Mogware.VisualStudio.ColladaNet.Images Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Images Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Images]

Classes

Class | Description
Image |
ImageList |


Image Class

[image]

Mogware's Collada.Net Class Library
Image Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Images.Image]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Image
Visual Basic (Declaration)
Public Class Image
Visual C++
public ref class Image

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Images..::.Image

See Also

Image Members
Mogware.VisualStudio.ColladaNet.Images Namespace


Image Members

[image] [image]

Mogware's Collada.Net Class Library
Image Members
Image Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Image type exposes the following members.

Constructors

Name | Description
Image | Initializes a new instance of the Image class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Depth |
Filename |
Id |
Name |

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Image Constructor

[image]

Mogware's Collada.Net Class Library
Image Constructor
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Image class

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Image(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Image(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Images.Image.#ctor(System.Xml.XmlElement)"]

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Image Methods

[image] [image]

Mogware's Collada.Net Class Library
Image Methods
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Image type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Image Properties

[image] [image]

Mogware's Collada.Net Class Library
Image Properties
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Image type exposes the following members.

Properties

Name | Description
Depth |
Filename |
Id |
Name |

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Depth Property

[image]

Mogware's Collada.Net Class Library
Image..::.Depth Property
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Images.Image.Depth]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Depth { get; set; }
Visual Basic (Declaration)
Public Property Depth As Integer
Visual C++
public:
property int Depth {
    int get ();
    void set (int value);
}

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Filename Property

[image]

Mogware's Collada.Net Class Library
Image..::.Filename Property
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Images.Image.Filename]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Filename { get; set; }
Visual Basic (Declaration)
Public Property Filename As String
Visual C++
public:
property String^ Filename {
    String^ get ();
    void set (String^ value);
}

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Image..::.Id Property
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Images.Image.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Image..::.Name Property
Image Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Images.Image.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Image Class
Mogware.VisualStudio.ColladaNet.Images Namespace


ImageList Class

[image]

Mogware's Collada.Net Class Library
ImageList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Images.ImageList]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ImageList : List<Image>
Visual Basic (Declaration)
Public Class ImageList _
    Inherits List(Of Image)
Visual C++
public ref class ImageList : public List<Image^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Image >)>)
Mogware.VisualStudio.ColladaNet.Images..::.ImageList

See Also

ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


ImageList Members

[image] [image]

Mogware's Collada.Net Class Library
ImageList Members
ImageList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageList type exposes the following members.

Constructors

Name | Description
ImageList | Initializes a new instance of the ImageList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Image >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Image >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
FindByFilename |
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Image >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Image >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Image >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Image >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Image >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
Mogware.VisualStudio.ColladaNet.Images Namespace


ImageList Constructor

[image]

Mogware's Collada.Net Class Library
ImageList Constructor
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ImageList class

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ImageList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ImageList()

See Also

ImageList Class
Mogware.VisualStudio.ColladaNet.Images Namespace


ImageList Methods

[image] [image]

Mogware's Collada.Net Class Library
ImageList Methods
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Image >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Image >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
FindByFilename |
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Image >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Image >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Image >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Image >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
Mogware.VisualStudio.ColladaNet.Images Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.BinarySearch Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Image >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Image >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.CopyTo Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Image >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Image >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.Find Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Find(String) |

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
ImageList..::.Find Method (String)
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Images.ImageList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Image Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Image
Visual C++
public:
Image^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Images.ImageList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Images.ImageList.Find(System.String)]

See Also

ImageList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Images Namespace


FindByFilename Method

[image]

Mogware's Collada.Net Class Library
ImageList..::.FindByFilename Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Images.ImageList.FindByFilename(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Images
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Image FindByFilename(
    string filename
)
Visual Basic (Declaration)
Public Function FindByFilename ( _
    filename As String _
) As Image
Visual C++
public:
Image^ FindByFilename(
    String^ filename
)

Parameters

filename
Type: System..::.String

[Missing <param name="filename"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Images.ImageList.FindByFilename(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Images.ImageList.FindByFilename(System.String)]

See Also

ImageList Class
Mogware.VisualStudio.ColladaNet.Images Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.FindIndex Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Image >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.FindLastIndex Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Image >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.IndexOf Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Image >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.LastIndexOf Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Image >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.Reverse Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
ImageList..::.Sort Method
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Image >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Image >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
ImageList Members
Mogware.VisualStudio.ColladaNet.Images Namespace


ImageList Properties

[image] [image]

Mogware's Collada.Net Class Library
ImageList Properties
ImageList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ImageList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Image >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Image >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Image >)>).)

See Also

ImageList Class
Mogware.VisualStudio.ColladaNet.Images Namespace


Mogware.VisualStudio.ColladaNet.Materials Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Materials Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Materials]

Classes

Class | Description
Material |
MaterialInstance |
MaterialInstanceList |
MaterialList |


Material Class

[image]

Mogware's Collada.Net Class Library
Material Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Materials.Material]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Material
Visual Basic (Declaration)
Public Class Material
Visual C++
public ref class Material

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Materials..::.Material

See Also

Material Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Material Members

[image] [image]

Mogware's Collada.Net Class Library
Material Members
Material Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Material type exposes the following members.

Constructors

Name | Description
Material | Initializes a new instance of the Material class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Effect |
Id |
Name |

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Material Constructor

[image]

Mogware's Collada.Net Class Library
Material Constructor
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Material class

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Material(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
Material(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.Material.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.Material.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Material Methods

[image] [image]

Mogware's Collada.Net Class Library
Material Methods
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Material type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Material..::.Presave Method
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Materials.Material.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Material Properties

[image] [image]

Mogware's Collada.Net Class Library
Material Properties
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Material type exposes the following members.

Properties

Name | Description
Effect |
Id |
Name |

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Effect Property

[image]

Mogware's Collada.Net Class Library
Material..::.Effect Property
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Materials.Material.Effect]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Effect Effect { get; set; }
Visual Basic (Declaration)
Public Property Effect As Effect
Visual C++
public:
property Effect^ Effect {
    Effect^ get ();
    void set (Effect^ value);
}

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Material..::.Id Property
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Materials.Material.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Material..::.Name Property
Material Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Materials.Material.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Material Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstance Class

[image]

Mogware's Collada.Net Class Library
MaterialInstance Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstance]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class MaterialInstance
Visual Basic (Declaration)
Public Class MaterialInstance
Visual C++
public ref class MaterialInstance

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Materials..::.MaterialInstance

See Also

MaterialInstance Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstance Members

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstance Members
MaterialInstance Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstance type exposes the following members.

Constructors

Name | Description
MaterialInstance | Initializes a new instance of the MaterialInstance class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Symbol |
Target |

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstance Constructor

[image]

Mogware's Collada.Net Class Library
MaterialInstance Constructor
MaterialInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the MaterialInstance class

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialInstance(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
MaterialInstance(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstance.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstance.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstance Methods

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstance Methods
MaterialInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstance Properties

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstance Properties
MaterialInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstance type exposes the following members.

Properties

Name | Description
Symbol |
Target |

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Symbol Property

[image]

Mogware's Collada.Net Class Library
MaterialInstance..::.Symbol Property
MaterialInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstance.Symbol]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Symbol { get; set; }
Visual Basic (Declaration)
Public Property Symbol As String
Visual C++
public:
property String^ Symbol {
    String^ get ();
    void set (String^ value);
}

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Target Property

[image]

Mogware's Collada.Net Class Library
MaterialInstance..::.Target Property
MaterialInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstance.Target]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Material Target { get; set; }
Visual Basic (Declaration)
Public Property Target As Material
Visual C++
public:
property Material^ Target {
    Material^ get ();
    void set (Material^ value);
}

See Also

MaterialInstance Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstanceList Class

[image]

Mogware's Collada.Net Class Library
MaterialInstanceList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstanceList]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class MaterialInstanceList : List<MaterialInstance>
Visual Basic (Declaration)
Public Class MaterialInstanceList _
    Inherits List(Of MaterialInstance)
Visual C++
public ref class MaterialInstanceList : public List<MaterialInstance^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( MaterialInstance >)>)
Mogware.VisualStudio.ColladaNet.Materials..::.MaterialInstanceList

See Also

MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstanceList Members

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList Members
MaterialInstanceList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstanceList type exposes the following members.

Constructors

Name | Description
MaterialInstanceList | Initializes a new instance of the MaterialInstanceList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( MaterialInstance >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( MaterialInstance >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( MaterialInstance >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( MaterialInstance >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( MaterialInstance >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstanceList Constructor

[image]

Mogware's Collada.Net Class Library
MaterialInstanceList Constructor
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the MaterialInstanceList class

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialInstanceList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialInstanceList()

See Also

MaterialInstanceList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstanceList Methods

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList Methods
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstanceList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( MaterialInstance >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( MaterialInstance >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( MaterialInstance >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( MaterialInstance >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.BinarySearch Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( MaterialInstance >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( MaterialInstance >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.CopyTo Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( MaterialInstance >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( MaterialInstance >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.Find Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Find(String) |

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.Find Method (String)
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstanceList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialInstance Find(
    string symbol
)
Visual Basic (Declaration)
Public Function Find ( _
    symbol As String _
) As MaterialInstance
Visual C++
public:
MaterialInstance^ Find(
    String^ symbol
)

Parameters

symbol
Type: System..::.String

[Missing <param name="symbol"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstanceList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Materials.MaterialInstanceList.Find(System.String)]

See Also

MaterialInstanceList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Materials Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.FindIndex Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( MaterialInstance >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.FindLastIndex Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.IndexOf Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( MaterialInstance >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.LastIndexOf Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.Reverse Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList..::.Sort Method
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( MaterialInstance >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( MaterialInstance >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
MaterialInstanceList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialInstanceList Properties

[image] [image]

Mogware's Collada.Net Class Library
MaterialInstanceList Properties
MaterialInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialInstanceList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( MaterialInstance >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( MaterialInstance >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( MaterialInstance >)>).)

See Also

MaterialInstanceList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialList Class

[image]

Mogware's Collada.Net Class Library
MaterialList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Materials.MaterialList]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class MaterialList : List<Material>
Visual Basic (Declaration)
Public Class MaterialList _
    Inherits List(Of Material)
Visual C++
public ref class MaterialList : public List<Material^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Material >)>)
Mogware.VisualStudio.ColladaNet.Materials..::.MaterialList

See Also

MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialList Members

[image] [image]

Mogware's Collada.Net Class Library
MaterialList Members
MaterialList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialList type exposes the following members.

Constructors

Name | Description
MaterialList | Initializes a new instance of the MaterialList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Material >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Material >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Material >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Material >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Material >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Material >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Material >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialList Constructor

[image]

Mogware's Collada.Net Class Library
MaterialList Constructor
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the MaterialList class

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MaterialList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
MaterialList()

See Also

MaterialList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialList Methods

[image] [image]

Mogware's Collada.Net Class Library
MaterialList Methods
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Material >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Material >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Material >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Material >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Material >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Material >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.BinarySearch Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Material >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Material >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.CopyTo Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Material >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Material >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.Find Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Find(String) |

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
MaterialList..::.Find Method (String)
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Materials.MaterialList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Materials
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Material Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Material
Visual C++
public:
Material^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Materials.MaterialList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Materials.MaterialList.Find(System.String)]

See Also

MaterialList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Materials Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.FindIndex Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Material >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.FindLastIndex Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Material >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.IndexOf Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Material >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.LastIndexOf Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Material >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.Reverse Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
MaterialList..::.Sort Method
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Material >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Material >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
MaterialList Members
Mogware.VisualStudio.ColladaNet.Materials Namespace


MaterialList Properties

[image] [image]

Mogware's Collada.Net Class Library
MaterialList Properties
MaterialList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MaterialList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Material >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Material >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Material >)>).)

See Also

MaterialList Class
Mogware.VisualStudio.ColladaNet.Materials Namespace


Mogware.VisualStudio.ColladaNet.Scene Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Scene Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Scene]

Classes

Class | Description
MatrixTransformation |
Node |
NodeList |
RotationTransformation |
ScaleTransformation |
Transformation |
TransformationList |
TranslationTransformation |
VisualScene |

Enumerations

Enumeration | Description
NodeType |


MatrixTransformation Class

[image]

Mogware's Collada.Net Class Library
MatrixTransformation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.MatrixTransformation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class MatrixTransformation : Transformation
Visual Basic (Declaration)
Public Class MatrixTransformation _
    Inherits Transformation
Visual C++
public ref class MatrixTransformation : public Transformation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Transformation
Mogware.VisualStudio.ColladaNet.Scene..::.MatrixTransformation

See Also

MatrixTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Members

[image] [image]

Mogware's Collada.Net Class Library
MatrixTransformation Members
MatrixTransformation Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixTransformation type exposes the following members.

Constructors

Name | Description
MatrixTransformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mSid | (Inherited from Transformation.)
mXmlElement | (Inherited from Transformation.)

Properties

Name | Description
Matrix |
Sid | (Inherited from Transformation.)

See Also

MatrixTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Constructor

[image] [image]

Mogware's Collada.Net Class Library
MatrixTransformation Constructor
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
MatrixTransformation(XmlElement) | Initializes a new instance of the MatrixTransformation class
MatrixTransformation(Node, Matrix) | Initializes a new instance of the MatrixTransformation class

See Also

MatrixTransformation Class
MatrixTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
MatrixTransformation Constructor (XmlElement)
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the MatrixTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MatrixTransformation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
MatrixTransformation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.MatrixTransformation.#ctor(System.Xml.XmlElement)"]

See Also

MatrixTransformation Class
MatrixTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Constructor (Node, Matrix)

[image]

Mogware's Collada.Net Class Library
MatrixTransformation Constructor (Node, Matrix)
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the MatrixTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public MatrixTransformation(
    Node node,
    Matrix m
)
Visual Basic (Declaration)
Public Sub New ( _
    node As Node, _
    m As Matrix _
)
Visual C++
public:
MatrixTransformation(
    Node^ node,
    Matrix^ m
)

Parameters

node
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="node"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.MatrixTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,Mogware.VisualStudio.ColladaNet.Matrix)"]

m
Type: Mogware.VisualStudio.ColladaNet..::.Matrix

[Missing <param name="m"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.MatrixTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,Mogware.VisualStudio.ColladaNet.Matrix)"]

See Also

MatrixTransformation Class
MatrixTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Fields

[image] [image]

Mogware's Collada.Net Class Library
MatrixTransformation Fields
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixTransformation type exposes the following members.

Fields

Name | Description
mSid | (Inherited from Transformation.)
mXmlElement | (Inherited from Transformation.)

See Also

MatrixTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Methods

[image] [image]

Mogware's Collada.Net Class Library
MatrixTransformation Methods
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixTransformation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

MatrixTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


MatrixTransformation Properties

[image] [image]

Mogware's Collada.Net Class Library
MatrixTransformation Properties
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The MatrixTransformation type exposes the following members.

Properties

Name | Description
Matrix |
Sid | (Inherited from Transformation.)

See Also

MatrixTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Matrix Property

[image]

Mogware's Collada.Net Class Library
MatrixTransformation..::.Matrix Property
MatrixTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.MatrixTransformation.Matrix]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix Matrix { get; set; }
Visual Basic (Declaration)
Public Property Matrix As Matrix
Visual C++
public:
property Matrix^ Matrix {
    Matrix^ get ();
    void set (Matrix^ value);
}

See Also

MatrixTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Node Class

[image]

Mogware's Collada.Net Class Library
Node Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.Node]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Node
Visual Basic (Declaration)
Public Class Node
Visual C++
public ref class Node

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Node

See Also

Node Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Node Members

[image] [image]

Mogware's Collada.Net Class Library
Node Members
Node Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Node type exposes the following members.

Constructors

Name | Description
Node | Initializes a new instance of the Node class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotation |
GetRotationMatrix |
GetScale |
GetTransformationMatrix |
GetTranslation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorldTransformationMatrix |
IsSubnodeOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
SubsumeTree |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
IsSkeleton |
Name |
Nodes |
ParentNode |
Sid |
Transformations |
Type |
XmlElement |

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Node Constructor

[image]

Mogware's Collada.Net Class Library
Node Constructor
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Node class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Node(
    XmlElement element,
    Node parent
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    parent As Node _
)
Visual C++
public:
Node(
    XmlElement^ element,
    Node^ parent
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Node.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Scene.Node)"]

parent
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="parent"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Node.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Scene.Node)"]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Node Methods

[image] [image]

Mogware's Collada.Net Class Library
Node Methods
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Node type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRotation |
GetRotationMatrix |
GetScale |
GetTransformationMatrix |
GetTranslation |
GetType | Gets the Type of the current instance. (Inherited from Object.)
GetWorldTransformationMatrix |
IsSubnodeOf |
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
SubsumeTree |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetRotation Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetRotation Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetRotation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetRotation()
Visual Basic (Declaration)
Public Function GetRotation As Vector3
Visual C++
public:
Vector3 GetRotation()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetRotation]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetRotationMatrix Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetRotationMatrix Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetRotationMatrix]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix GetRotationMatrix()
Visual Basic (Declaration)
Public Function GetRotationMatrix As Matrix
Visual C++
public:
Matrix GetRotationMatrix()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetRotationMatrix]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetScale Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetScale Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetScale]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetScale()
Visual Basic (Declaration)
Public Function GetScale As Vector3
Visual C++
public:
Vector3 GetScale()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetScale]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetTransformationMatrix Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetTransformationMatrix Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetTransformationMatrix]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix GetTransformationMatrix()
Visual Basic (Declaration)
Public Function GetTransformationMatrix As Matrix
Visual C++
public:
Matrix GetTransformationMatrix()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetTransformationMatrix]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetTranslation Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetTranslation Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetTranslation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Vector3 GetTranslation()
Visual Basic (Declaration)
Public Function GetTranslation As Vector3
Visual C++
public:
Vector3 GetTranslation()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetTranslation]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


GetWorldTransformationMatrix Method

[image]

Mogware's Collada.Net Class Library
Node..::.GetWorldTransformationMatrix Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetWorldTransformationMatrix]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix GetWorldTransformationMatrix()
Visual Basic (Declaration)
Public Function GetWorldTransformationMatrix As Matrix
Visual C++
public:
Matrix GetWorldTransformationMatrix()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.GetWorldTransformationMatrix]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


IsSubnodeOf Method

[image]

Mogware's Collada.Net Class Library
Node..::.IsSubnodeOf Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.IsSubnodeOf(Mogware.VisualStudio.ColladaNet.Scene.Node)]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool IsSubnodeOf(
    Node root
)
Visual Basic (Declaration)
Public Function IsSubnodeOf ( _
    root As Node _
) As Boolean
Visual C++
public:
bool IsSubnodeOf(
    Node^ root
)

Parameters

root
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="root"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Node.IsSubnodeOf(Mogware.VisualStudio.ColladaNet.Scene.Node)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.IsSubnodeOf(Mogware.VisualStudio.ColladaNet.Scene.Node)]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
Node..::.Preremove Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Node..::.Presave Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


SubsumeTree Method

[image]

Mogware's Collada.Net Class Library
Node..::.SubsumeTree Method
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Node.SubsumeTree(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Collections.Generic.Dictionary{System.String,System.String})]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void SubsumeTree(
    Node secondTree,
    Dictionary<string, string> nameMap
)
Visual Basic (Declaration)
Public Sub SubsumeTree ( _
    secondTree As Node, _
    nameMap As Dictionary(Of String, String) _
)
Visual C++
public:
void SubsumeTree(
    Node^ secondTree,
    Dictionary<String^, String^>^ nameMap
)

Parameters

secondTree
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="secondTree"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Node.SubsumeTree(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Collections.Generic.Dictionary{System.String,System.String})"]

nameMap
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)

[Missing <param name="nameMap"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Node.SubsumeTree(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Node Properties

[image] [image]

Mogware's Collada.Net Class Library
Node Properties
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Node type exposes the following members.

Properties

Name | Description
Id |
IsSkeleton |
Name |
Nodes |
ParentNode |
Sid |
Transformations |
Type |
XmlElement |

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Node..::.Id Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


IsSkeleton Property

[image]

Mogware's Collada.Net Class Library
Node..::.IsSkeleton Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.IsSkeleton]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public bool IsSkeleton { get; }
Visual Basic (Declaration)
Public ReadOnly Property IsSkeleton As Boolean
Visual C++
public:
property bool IsSkeleton {
    bool get ();
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Node..::.Name Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Nodes Property

[image]

Mogware's Collada.Net Class Library
Node..::.Nodes Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Nodes]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public NodeList Nodes { get; set; }
Visual Basic (Declaration)
Public Property Nodes As NodeList
Visual C++
public:
property NodeList^ Nodes {
    NodeList^ get ();
    void set (NodeList^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


ParentNode Property

[image]

Mogware's Collada.Net Class Library
Node..::.ParentNode Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.ParentNode]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Node ParentNode { get; set; }
Visual Basic (Declaration)
Public Property ParentNode As Node
Visual C++
public:
property Node^ ParentNode {
    Node^ get ();
    void set (Node^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Sid Property

[image]

Mogware's Collada.Net Class Library
Node..::.Sid Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Sid]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Sid { get; set; }
Visual Basic (Declaration)
Public Property Sid As String
Visual C++
public:
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformations Property

[image]

Mogware's Collada.Net Class Library
Node..::.Transformations Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Transformations]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TransformationList Transformations { get; }
Visual Basic (Declaration)
Public ReadOnly Property Transformations As TransformationList
Visual C++
public:
property TransformationList^ Transformations {
    TransformationList^ get ();
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Type Property

[image]

Mogware's Collada.Net Class Library
Node..::.Type Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.Type]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public NodeType Type { get; set; }
Visual Basic (Declaration)
Public Property Type As NodeType
Visual C++
public:
property NodeType Type {
    NodeType get ();
    void set (NodeType value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


XmlElement Property

[image]

Mogware's Collada.Net Class Library
Node..::.XmlElement Property
Node Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Node.XmlElement]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public XmlElement XmlElement { get; set; }
Visual Basic (Declaration)
Public Property XmlElement As XmlElement
Visual C++
public:
property XmlElement^ XmlElement {
    XmlElement^ get ();
    void set (XmlElement^ value);
}

See Also

Node Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeList Class

[image]

Mogware's Collada.Net Class Library
NodeList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.NodeList]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class NodeList : List<Node>
Visual Basic (Declaration)
Public Class NodeList _
    Inherits List(Of Node)
Visual C++
public ref class NodeList : public List<Node^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Node >)>)
Mogware.VisualStudio.ColladaNet.Scene..::.NodeList

See Also

NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeList Members

[image] [image]

Mogware's Collada.Net Class Library
NodeList Members
NodeList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeList type exposes the following members.

Constructors

Name | Description
NodeList | Initializes a new instance of the NodeList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Node >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Node >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Node >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Node >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
RemoveAt |
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Node >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Node >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Node >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeList Constructor

[image]

Mogware's Collada.Net Class Library
NodeList Constructor
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the NodeList class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public NodeList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
NodeList()

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeList Methods

[image] [image]

Mogware's Collada.Net Class Library
NodeList Methods
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Node >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Node >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Node >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Node >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)
RemoveAt |
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Node >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Node >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.BinarySearch Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Node >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Node >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.CopyTo Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Node >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Node >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.Find Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Find(String) |

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
NodeList..::.Find Method (String)
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Node Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Node
Visual C++
public:
Node^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.Find(System.String)]

See Also

NodeList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.FindIndex Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Node >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.FindLastIndex Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Node >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.IndexOf Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Node >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.LastIndexOf Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Node >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Remove Method

[image]

Mogware's Collada.Net Class Library
NodeList..::.Remove Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.Remove(Mogware.VisualStudio.ColladaNet.Scene.Node)]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    Node item
)
Visual Basic (Declaration)
Public Sub Remove ( _
    item As Node _
)
Visual C++
public:
void Remove(
    Node^ item
)

Parameters

item
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="item"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.Remove(Mogware.VisualStudio.ColladaNet.Scene.Node)"]

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


RemoveAt Method

[image]

Mogware's Collada.Net Class Library
NodeList..::.RemoveAt Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.RemoveAt(System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveAt(
    int index
)
Visual Basic (Declaration)
Public Sub RemoveAt ( _
    index As Integer _
)
Visual C++
public:
void RemoveAt(
    int index
)

Parameters

index
Type: System..::.Int32

[Missing <param name="index"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.RemoveAt(System.Int32)"]

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


RemoveRange Method

[image]

Mogware's Collada.Net Class Library
NodeList..::.RemoveRange Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.RemoveRange(System.Int32,System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveRange(
    int start,
    int count
)
Visual Basic (Declaration)
Public Sub RemoveRange ( _
    start As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int start,
    int count
)

Parameters

start
Type: System..::.Int32

[Missing <param name="start"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.RemoveRange(System.Int32,System.Int32)"]

count
Type: System..::.Int32

[Missing <param name="count"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.NodeList.RemoveRange(System.Int32,System.Int32)"]

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.Reverse Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
NodeList..::.Sort Method
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Node >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Node >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
NodeList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeList Properties

[image] [image]

Mogware's Collada.Net Class Library
NodeList Properties
NodeList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The NodeList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Node >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Node >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Node >)>).)

See Also

NodeList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


NodeType Enumeration

[image]

Mogware's Collada.Net Class Library
NodeType Enumeration
See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.NodeType]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public enum NodeType
Visual Basic (Declaration)
Public Enumeration NodeType
Visual C++
public enum class NodeType

Members

Member name | Description
NODE |
JOINT |

See Also

Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Class

[image]

Mogware's Collada.Net Class Library
RotationTransformation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class RotationTransformation : Transformation
Visual Basic (Declaration)
Public Class RotationTransformation _
    Inherits Transformation
Visual C++
public ref class RotationTransformation : public Transformation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Transformation
Mogware.VisualStudio.ColladaNet.Scene..::.RotationTransformation

See Also

RotationTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Members

[image] [image]

Mogware's Collada.Net Class Library
RotationTransformation Members
RotationTransformation Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RotationTransformation type exposes the following members.

Constructors

Name | Description
RotationTransformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

Properties

Name | Description
Sid | (Inherited from Transformation.)
W |
X |
Y |
Z |

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Constructor

[image] [image]

Mogware's Collada.Net Class Library
RotationTransformation Constructor
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
RotationTransformation(XmlElement) | Initializes a new instance of the RotationTransformation class
RotationTransformation(Node, Single, Single, Single, Single) | Initializes a new instance of the RotationTransformation class

See Also

RotationTransformation Class
RotationTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
RotationTransformation Constructor (XmlElement)
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the RotationTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public RotationTransformation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
RotationTransformation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(System.Xml.XmlElement)"]

See Also

RotationTransformation Class
RotationTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Constructor (Node, Single, Single, Single, Single)

[image]

Mogware's Collada.Net Class Library
RotationTransformation Constructor (Node, Single, Single, Single, Single)
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the RotationTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public RotationTransformation(
    Node node,
    float x,
    float y,
    float z,
    float angle
)
Visual Basic (Declaration)
Public Sub New ( _
    node As Node, _
    x As Single, _
    y As Single, _
    z As Single, _
    angle As Single _
)
Visual C++
public:
RotationTransformation(
    Node^ node,
    float x,
    float y,
    float z,
    float angle
)

Parameters

node
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="node"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single,System.Single)"]

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single,System.Single)"]

angle
Type: System..::.Single

[Missing <param name="angle"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single,System.Single)"]

See Also

RotationTransformation Class
RotationTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Fields

[image] [image]

Mogware's Collada.Net Class Library
RotationTransformation Fields
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RotationTransformation type exposes the following members.

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mX Field

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.mX Field
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.mX]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mX
Visual Basic (Declaration)
Protected mX As Single
Visual C++
protected:
float mX

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mY Field

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.mY Field
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.mY]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mY
Visual Basic (Declaration)
Protected mY As Single
Visual C++
protected:
float mY

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mZ Field

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.mZ Field
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.mZ]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mZ
Visual Basic (Declaration)
Protected mZ As Single
Visual C++
protected:
float mZ

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Methods

[image] [image]

Mogware's Collada.Net Class Library
RotationTransformation Methods
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RotationTransformation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


RotationTransformation Properties

[image] [image]

Mogware's Collada.Net Class Library
RotationTransformation Properties
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The RotationTransformation type exposes the following members.

Properties

Name | Description
Sid | (Inherited from Transformation.)
W |
X |
Y |
Z |

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


W Property

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.W Property
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.W]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float W { get; set; }
Visual Basic (Declaration)
Public Property W As Single
Visual C++
public:
property float W {
    float get ();
    void set (float value);
}

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


X Property

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.X Property
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.X]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float X { get; set; }
Visual Basic (Declaration)
Public Property X As Single
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Y Property

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.Y Property
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.Y]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Single
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Z Property

[image]

Mogware's Collada.Net Class Library
RotationTransformation..::.Z Property
RotationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.RotationTransformation.Z]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Z { get; set; }
Visual Basic (Declaration)
Public Property Z As Single
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

RotationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Class

[image]

Mogware's Collada.Net Class Library
ScaleTransformation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ScaleTransformation : Transformation
Visual Basic (Declaration)
Public Class ScaleTransformation _
    Inherits Transformation
Visual C++
public ref class ScaleTransformation : public Transformation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Transformation
Mogware.VisualStudio.ColladaNet.Scene..::.ScaleTransformation

See Also

ScaleTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Members

[image] [image]

Mogware's Collada.Net Class Library
ScaleTransformation Members
ScaleTransformation Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScaleTransformation type exposes the following members.

Constructors

Name | Description
ScaleTransformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

Properties

Name | Description
Sid | (Inherited from Transformation.)
X |
Y |
Z |

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Constructor

[image] [image]

Mogware's Collada.Net Class Library
ScaleTransformation Constructor
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
ScaleTransformation(XmlElement) | Initializes a new instance of the ScaleTransformation class
ScaleTransformation(Node, Single, Single, Single) | Initializes a new instance of the ScaleTransformation class

See Also

ScaleTransformation Class
ScaleTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
ScaleTransformation Constructor (XmlElement)
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ScaleTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ScaleTransformation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
ScaleTransformation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.#ctor(System.Xml.XmlElement)"]

See Also

ScaleTransformation Class
ScaleTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Constructor (Node, Single, Single, Single)

[image]

Mogware's Collada.Net Class Library
ScaleTransformation Constructor (Node, Single, Single, Single)
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ScaleTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ScaleTransformation(
    Node node,
    float x,
    float y,
    float z
)
Visual Basic (Declaration)
Public Sub New ( _
    node As Node, _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
ScaleTransformation(
    Node^ node,
    float x,
    float y,
    float z
)

Parameters

node
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="node"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

See Also

ScaleTransformation Class
ScaleTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Fields

[image] [image]

Mogware's Collada.Net Class Library
ScaleTransformation Fields
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScaleTransformation type exposes the following members.

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mX Field

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.mX Field
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.mX]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mX
Visual Basic (Declaration)
Protected mX As Single
Visual C++
protected:
float mX

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mY Field

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.mY Field
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.mY]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mY
Visual Basic (Declaration)
Protected mY As Single
Visual C++
protected:
float mY

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mZ Field

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.mZ Field
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.mZ]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mZ
Visual Basic (Declaration)
Protected mZ As Single
Visual C++
protected:
float mZ

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Methods

[image] [image]

Mogware's Collada.Net Class Library
ScaleTransformation Methods
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScaleTransformation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


ScaleTransformation Properties

[image] [image]

Mogware's Collada.Net Class Library
ScaleTransformation Properties
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ScaleTransformation type exposes the following members.

Properties

Name | Description
Sid | (Inherited from Transformation.)
X |
Y |
Z |

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


X Property

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.X Property
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.X]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float X { get; set; }
Visual Basic (Declaration)
Public Property X As Single
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Y Property

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.Y Property
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.Y]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Single
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Z Property

[image]

Mogware's Collada.Net Class Library
ScaleTransformation..::.Z Property
ScaleTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.ScaleTransformation.Z]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Z { get; set; }
Visual Basic (Declaration)
Public Property Z As Single
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

ScaleTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Class

[image]

Mogware's Collada.Net Class Library
Transformation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.Transformation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Transformation
Visual Basic (Declaration)
Public Class Transformation
Visual C++
public ref class Transformation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Transformation
Mogware.VisualStudio.ColladaNet.Scene..::.MatrixTransformation
Mogware.VisualStudio.ColladaNet.Scene..::.RotationTransformation
Mogware.VisualStudio.ColladaNet.Scene..::.ScaleTransformation
Mogware.VisualStudio.ColladaNet.Scene..::.TranslationTransformation

See Also

Transformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Members

[image] [image]

Mogware's Collada.Net Class Library
Transformation Members
Transformation Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Transformation type exposes the following members.

Constructors

Name | Description
Transformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mSid |
mXmlElement |

Properties

Name | Description
Sid |

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Constructor

[image] [image]

Mogware's Collada.Net Class Library
Transformation Constructor
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Transformation()()() | Initializes a new instance of the Transformation class
Transformation(XmlElement) | Initializes a new instance of the Transformation class

See Also

Transformation Class
Transformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Constructor

[image]

Mogware's Collada.Net Class Library
Transformation Constructor
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Transformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Transformation()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
Transformation()

See Also

Transformation Class
Transformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
Transformation Constructor (XmlElement)
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Transformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Transformation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
Transformation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.Transformation.#ctor(System.Xml.XmlElement)"]

See Also

Transformation Class
Transformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Fields

[image] [image]

Mogware's Collada.Net Class Library
Transformation Fields
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Transformation type exposes the following members.

Fields

Name | Description
mSid |
mXmlElement |

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mSid Field

[image]

Mogware's Collada.Net Class Library
Transformation..::.mSid Field
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.Transformation.mSid]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected string mSid
Visual Basic (Declaration)
Protected mSid As String
Visual C++
protected:
String^ mSid

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mXmlElement Field

[image]

Mogware's Collada.Net Class Library
Transformation..::.mXmlElement Field
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.Transformation.mXmlElement]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected XmlElement mXmlElement
Visual Basic (Declaration)
Protected mXmlElement As XmlElement
Visual C++
protected:
XmlElement^ mXmlElement

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Methods

[image] [image]

Mogware's Collada.Net Class Library
Transformation Methods
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Transformation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
Transformation..::.Preremove Method
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.Transformation.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Transformation Properties

[image] [image]

Mogware's Collada.Net Class Library
Transformation Properties
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Transformation type exposes the following members.

Properties

Name | Description
Sid |

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Sid Property

[image]

Mogware's Collada.Net Class Library
Transformation..::.Sid Property
Transformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.Transformation.Sid]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Sid { get; set; }
Visual Basic (Declaration)
Public Property Sid As String
Visual C++
public:
property String^ Sid {
    String^ get ();
    void set (String^ value);
}

See Also

Transformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TransformationList Class

[image]

Mogware's Collada.Net Class Library
TransformationList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.TransformationList]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class TransformationList : List<Transformation>
Visual Basic (Declaration)
Public Class TransformationList _
    Inherits List(Of Transformation)
Visual C++
public ref class TransformationList : public List<Transformation^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Transformation >)>)
Mogware.VisualStudio.ColladaNet.Scene..::.TransformationList

See Also

TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


TransformationList Members

[image] [image]

Mogware's Collada.Net Class Library
TransformationList Members
TransformationList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TransformationList type exposes the following members.

Constructors

Name | Description
TransformationList | Initializes a new instance of the TransformationList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Transformation >)>).)
BinarySearch | Overloaded.
Clear |
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Transformation >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Transformation >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Transformation >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Transformation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Transformation >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Transformation >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TransformationList Constructor

[image]

Mogware's Collada.Net Class Library
TransformationList Constructor
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TransformationList class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TransformationList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
TransformationList()

See Also

TransformationList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TransformationList Methods

[image] [image]

Mogware's Collada.Net Class Library
TransformationList Methods
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TransformationList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Transformation >)>).)
BinarySearch | Overloaded.
Clear |
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Transformation >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Transformation >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Transformation >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Transformation >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Transformation >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.BinarySearch Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Transformation >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Transformation >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Clear Method

[image]

Mogware's Collada.Net Class Library
TransformationList..::.Clear Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.TransformationList.Clear]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Clear()
Visual Basic (Declaration)
Public Sub Clear
Visual C++
public:
void Clear()

See Also

TransformationList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.CopyTo Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Transformation >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Transformation >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.FindIndex Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Transformation >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.FindLastIndex Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Transformation >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.IndexOf Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Transformation >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.LastIndexOf Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Transformation >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.Reverse Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
TransformationList..::.Sort Method
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Transformation >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Transformation >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
TransformationList Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


TransformationList Properties

[image] [image]

Mogware's Collada.Net Class Library
TransformationList Properties
TransformationList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TransformationList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Transformation >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Transformation >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Transformation >)>).)

See Also

TransformationList Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Class

[image]

Mogware's Collada.Net Class Library
TranslationTransformation Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class TranslationTransformation : Transformation
Visual Basic (Declaration)
Public Class TranslationTransformation _
    Inherits Transformation
Visual C++
public ref class TranslationTransformation : public Transformation

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.Transformation
Mogware.VisualStudio.ColladaNet.Scene..::.TranslationTransformation

See Also

TranslationTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Members

[image] [image]

Mogware's Collada.Net Class Library
TranslationTransformation Members
TranslationTransformation Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslationTransformation type exposes the following members.

Constructors

Name | Description
TranslationTransformation | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

Properties

Name | Description
Sid | (Inherited from Transformation.)
X |
Y |
Z |

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Constructor

[image] [image]

Mogware's Collada.Net Class Library
TranslationTransformation Constructor
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
TranslationTransformation(XmlElement) | Initializes a new instance of the TranslationTransformation class
TranslationTransformation(Node, Single, Single, Single) | Initializes a new instance of the TranslationTransformation class

See Also

TranslationTransformation Class
TranslationTransformation Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Constructor (XmlElement)

[image]

Mogware's Collada.Net Class Library
TranslationTransformation Constructor (XmlElement)
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TranslationTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TranslationTransformation(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
TranslationTransformation(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.#ctor(System.Xml.XmlElement)"]

See Also

TranslationTransformation Class
TranslationTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Constructor (Node, Single, Single, Single)

[image]

Mogware's Collada.Net Class Library
TranslationTransformation Constructor (Node, Single, Single, Single)
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the TranslationTransformation class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public TranslationTransformation(
    Node node,
    float x,
    float y,
    float z
)
Visual Basic (Declaration)
Public Sub New ( _
    node As Node, _
    x As Single, _
    y As Single, _
    z As Single _
)
Visual C++
public:
TranslationTransformation(
    Node^ node,
    float x,
    float y,
    float z
)

Parameters

node
Type: Mogware.VisualStudio.ColladaNet.Scene..::.Node

[Missing <param name="node"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

x
Type: System..::.Single

[Missing <param name="x"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

y
Type: System..::.Single

[Missing <param name="y"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

z
Type: System..::.Single

[Missing <param name="z"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.#ctor(Mogware.VisualStudio.ColladaNet.Scene.Node,System.Single,System.Single,System.Single)"]

See Also

TranslationTransformation Class
TranslationTransformation Overload
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Fields

[image] [image]

Mogware's Collada.Net Class Library
TranslationTransformation Fields
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslationTransformation type exposes the following members.

Fields

Name | Description
mSid | (Inherited from Transformation.)
mX |
mXmlElement | (Inherited from Transformation.)
mY |
mZ |

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mX Field

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.mX Field
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.mX]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mX
Visual Basic (Declaration)
Protected mX As Single
Visual C++
protected:
float mX

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mY Field

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.mY Field
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.mY]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mY
Visual Basic (Declaration)
Protected mY As Single
Visual C++
protected:
float mY

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


mZ Field

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.mZ Field
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.mZ]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected float mZ
Visual Basic (Declaration)
Protected mZ As Single
Visual C++
protected:
float mZ

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Methods

[image] [image]

Mogware's Collada.Net Class Library
TranslationTransformation Methods
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslationTransformation type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove | (Inherited from Transformation.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


TranslationTransformation Properties

[image] [image]

Mogware's Collada.Net Class Library
TranslationTransformation Properties
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The TranslationTransformation type exposes the following members.

Properties

Name | Description
Sid | (Inherited from Transformation.)
X |
Y |
Z |

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


X Property

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.X Property
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.X]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float X { get; set; }
Visual Basic (Declaration)
Public Property X As Single
Visual C++
public:
property float X {
    float get ();
    void set (float value);
}

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Y Property

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.Y Property
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.Y]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Y { get; set; }
Visual Basic (Declaration)
Public Property Y As Single
Visual C++
public:
property float Y {
    float get ();
    void set (float value);
}

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Z Property

[image]

Mogware's Collada.Net Class Library
TranslationTransformation..::.Z Property
TranslationTransformation Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.TranslationTransformation.Z]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Z { get; set; }
Visual Basic (Declaration)
Public Property Z As Single
Visual C++
public:
property float Z {
    float get ();
    void set (float value);
}

See Also

TranslationTransformation Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


VisualScene Class

[image]

Mogware's Collada.Net Class Library
VisualScene Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Scene.VisualScene]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class VisualScene
Visual Basic (Declaration)
Public Class VisualScene
Visual C++
public ref class VisualScene

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Scene..::.VisualScene

See Also

VisualScene Members
Mogware.VisualStudio.ColladaNet.Scene Namespace


VisualScene Members

[image] [image]

Mogware's Collada.Net Class Library
VisualScene Members
VisualScene Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VisualScene type exposes the following members.

Constructors

Name | Description
VisualScene | Initializes a new instance of the VisualScene class

Methods

Name | Description
CombineSkeletons |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Nodes |

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


VisualScene Constructor

[image]

Mogware's Collada.Net Class Library
VisualScene Constructor
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the VisualScene class

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public VisualScene(
    XmlElement element
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement _
)
Visual C++
public:
VisualScene(
    XmlElement^ element
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.#ctor(System.Xml.XmlElement)"]

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


VisualScene Methods

[image] [image]

Mogware's Collada.Net Class Library
VisualScene Methods
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VisualScene type exposes the following members.

Methods

Name | Description
CombineSkeletons |
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


CombineSkeletons Method

[image]

Mogware's Collada.Net Class Library
VisualScene..::.CombineSkeletons Method
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.CombineSkeletons]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Dictionary<string, string> CombineSkeletons()
Visual Basic (Declaration)
Public Function CombineSkeletons As Dictionary(Of String, String)
Visual C++
public:
Dictionary<String^, String^>^ CombineSkeletons()

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.CombineSkeletons]

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
VisualScene..::.Presave Method
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.Presave]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave()
Visual Basic (Declaration)
Public Sub Presave
Visual C++
public:
void Presave()

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


VisualScene Properties

[image] [image]

Mogware's Collada.Net Class Library
VisualScene Properties
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VisualScene type exposes the following members.

Properties

Name | Description
Id |
Nodes |

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
VisualScene..::.Id Property
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Nodes Property

[image]

Mogware's Collada.Net Class Library
VisualScene..::.Nodes Property
VisualScene Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Scene.VisualScene.Nodes]

Namespace: Mogware.VisualStudio.ColladaNet.Scene
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public NodeList Nodes { get; }
Visual Basic (Declaration)
Public ReadOnly Property Nodes As NodeList
Visual C++
public:
property NodeList^ Nodes {
    NodeList^ get ();
}

See Also

VisualScene Class
Mogware.VisualStudio.ColladaNet.Scene Namespace


Mogware.VisualStudio.ColladaNet.Skinning Namespace

[image]

Mogware's Collada.Net Class Library
Mogware.VisualStudio.ColladaNet.Skinning Namespace
Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for N:Mogware.VisualStudio.ColladaNet.Skinning]

Classes

Class | Description
Controller |
ControllerInstance |
ControllerInstanceList |
ControllerList |
Influence |
InfluenceList |
Joint |
JointList |
Joints |
Skin |
VertexWeights |
Weight |
WeightedObject |


Controller Class

[image]

Mogware's Collada.Net Class Library
Controller Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Controller]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Controller
Visual Basic (Declaration)
Public Class Controller
Visual C++
public ref class Controller

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Controller

See Also

Controller Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Controller Members

[image] [image]

Mogware's Collada.Net Class Library
Controller Members
Controller Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Controller type exposes the following members.

Constructors

Name | Description
Controller | Initializes a new instance of the Controller class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Id |
Skin |
XmlElement |

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Controller Constructor

[image]

Mogware's Collada.Net Class Library
Controller Constructor
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Controller class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Controller(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
Controller(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Controller.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Controller.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Controller Methods

[image] [image]

Mogware's Collada.Net Class Library
Controller Methods
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Controller type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
Controller..::.Preremove Method
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Controller.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Controller..::.Presave Method
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Controller.Presave(Mogware.VisualStudio.ColladaNet.ColladaDocument)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave(
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub Presave ( _
    document As ColladaDocument _
)
Visual C++
public:
void Presave(
    ColladaDocument^ document
)

Parameters

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Controller.Presave(Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Controller Properties

[image] [image]

Mogware's Collada.Net Class Library
Controller Properties
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Controller type exposes the following members.

Properties

Name | Description
Id |
Skin |
XmlElement |

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Controller..::.Id Property
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Controller.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Property

[image]

Mogware's Collada.Net Class Library
Controller..::.Skin Property
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Controller.Skin]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Skin Skin { get; set; }
Visual Basic (Declaration)
Public Property Skin As Skin
Visual C++
public:
property Skin^ Skin {
    Skin^ get ();
    void set (Skin^ value);
}

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


XmlElement Property

[image]

Mogware's Collada.Net Class Library
Controller..::.XmlElement Property
Controller Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Controller.XmlElement]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public XmlElement XmlElement { get; set; }
Visual Basic (Declaration)
Public Property XmlElement As XmlElement
Visual C++
public:
property XmlElement^ XmlElement {
    XmlElement^ get ();
    void set (XmlElement^ value);
}

See Also

Controller Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstance Class

[image]

Mogware's Collada.Net Class Library
ControllerInstance Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ControllerInstance
Visual Basic (Declaration)
Public Class ControllerInstance
Visual C++
public ref class ControllerInstance

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.ControllerInstance

See Also

ControllerInstance Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstance Members

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstance Members
ControllerInstance Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstance type exposes the following members.

Constructors

Name | Description
ControllerInstance | Initializes a new instance of the ControllerInstance class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Controller |
Url |

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstance Constructor

[image]

Mogware's Collada.Net Class Library
ControllerInstance Constructor
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ControllerInstance class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerInstance(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
ControllerInstance(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstance Methods

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstance Methods
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstance type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Preremove |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Preremove Method

[image]

Mogware's Collada.Net Class Library
ControllerInstance..::.Preremove Method
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance.Preremove]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Preremove()
Visual Basic (Declaration)
Public Sub Preremove
Visual C++
public:
void Preremove()

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstance Properties

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstance Properties
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstance type exposes the following members.

Properties

Name | Description
Controller |
Url |

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Controller Property

[image]

Mogware's Collada.Net Class Library
ControllerInstance..::.Controller Property
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance.Controller]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Controller Controller { get; set; }
Visual Basic (Declaration)
Public Property Controller As Controller
Visual C++
public:
property Controller^ Controller {
    Controller^ get ();
    void set (Controller^ value);
}

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Url Property

[image]

Mogware's Collada.Net Class Library
ControllerInstance..::.Url Property
ControllerInstance Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstance.Url]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Url { get; set; }
Visual Basic (Declaration)
Public Property Url As String
Visual C++
public:
property String^ Url {
    String^ get ();
    void set (String^ value);
}

See Also

ControllerInstance Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstanceList Class

[image]

Mogware's Collada.Net Class Library
ControllerInstanceList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ControllerInstanceList : List<ControllerInstance>
Visual Basic (Declaration)
Public Class ControllerInstanceList _
    Inherits List(Of ControllerInstance)
Visual C++
public ref class ControllerInstanceList : public List<ControllerInstance^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( ControllerInstance >)>)
Mogware.VisualStudio.ColladaNet.Skinning..::.ControllerInstanceList

See Also

ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstanceList Members

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList Members
ControllerInstanceList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstanceList type exposes the following members.

Constructors

Name | Description
ControllerInstanceList | Initializes a new instance of the ControllerInstanceList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( ControllerInstance >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( ControllerInstance >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( ControllerInstance >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( ControllerInstance >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( ControllerInstance >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstanceList Constructor

[image]

Mogware's Collada.Net Class Library
ControllerInstanceList Constructor
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ControllerInstanceList class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerInstanceList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ControllerInstanceList()

See Also

ControllerInstanceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstanceList Methods

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList Methods
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstanceList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( ControllerInstance >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( ControllerInstance >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( ControllerInstance >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( ControllerInstance >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.BinarySearch Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ControllerInstance >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ControllerInstance >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.CopyTo Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( ControllerInstance >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( ControllerInstance >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Find Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Find(String) |

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Find Method (String)
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerInstance Find(
    string url
)
Visual Basic (Declaration)
Public Function Find ( _
    url As String _
) As ControllerInstance
Visual C++
public:
ControllerInstance^ Find(
    String^ url
)

Parameters

url
Type: System..::.String

[Missing <param name="url"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.Find(System.String)]

See Also

ControllerInstanceList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.FindIndex Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( ControllerInstance >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.FindLastIndex Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.IndexOf Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( ControllerInstance >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.LastIndexOf Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Remove Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Remove Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Remove(Controller) |

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Remove Method (Controller)

[image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Remove Method (Controller)
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.Remove(Mogware.VisualStudio.ColladaNet.Skinning.Controller)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    Controller controller
)
Visual Basic (Declaration)
Public Sub Remove ( _
    controller As Controller _
)
Visual C++
public:
void Remove(
    Controller^ controller
)

Parameters

controller
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Controller

[Missing <param name="controller"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.Remove(Mogware.VisualStudio.ColladaNet.Skinning.Controller)"]

See Also

ControllerInstanceList Class
Remove Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


RemoveRange Method

[image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.RemoveRange Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.RemoveRange(System.Int32,System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveRange(
    int start,
    int count
)
Visual Basic (Declaration)
Public Sub RemoveRange ( _
    start As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int start,
    int count
)

Parameters

start
Type: System..::.Int32

[Missing <param name="start"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.RemoveRange(System.Int32,System.Int32)"]

count
Type: System..::.Int32

[Missing <param name="count"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerInstanceList.RemoveRange(System.Int32,System.Int32)"]

See Also

ControllerInstanceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Reverse Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList..::.Sort Method
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( ControllerInstance >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( ControllerInstance >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
ControllerInstanceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerInstanceList Properties

[image] [image]

Mogware's Collada.Net Class Library
ControllerInstanceList Properties
ControllerInstanceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerInstanceList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( ControllerInstance >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( ControllerInstance >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( ControllerInstance >)>).)

See Also

ControllerInstanceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerList Class

[image]

Mogware's Collada.Net Class Library
ControllerList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class ControllerList : List<Controller>
Visual Basic (Declaration)
Public Class ControllerList _
    Inherits List(Of Controller)
Visual C++
public ref class ControllerList : public List<Controller^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Controller >)>)
Mogware.VisualStudio.ColladaNet.Skinning..::.ControllerList

See Also

ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerList Members

[image] [image]

Mogware's Collada.Net Class Library
ControllerList Members
ControllerList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerList type exposes the following members.

Constructors

Name | Description
ControllerList | Initializes a new instance of the ControllerList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Controller >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Controller >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
FindByGeometryName |
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Controller >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Controller >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Controller >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Controller >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Controller >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerList Constructor

[image]

Mogware's Collada.Net Class Library
ControllerList Constructor
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the ControllerList class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ControllerList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
ControllerList()

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerList Methods

[image] [image]

Mogware's Collada.Net Class Library
ControllerList Methods
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Controller >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Controller >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
FindByGeometryName |
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Controller >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Controller >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove |
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
RemoveRange |
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Controller >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Controller >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.BinarySearch Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Controller >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Controller >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.CopyTo Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Controller >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Controller >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.Find Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Find(String) |

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
ControllerList..::.Find Method (String)
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Controller Find(
    string id
)
Visual Basic (Declaration)
Public Function Find ( _
    id As String _
) As Controller
Visual C++
public:
Controller^ Find(
    String^ id
)

Parameters

id
Type: System..::.String

[Missing <param name="id"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.Find(System.String)]

See Also

ControllerList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindByGeometryName Method

[image]

Mogware's Collada.Net Class Library
ControllerList..::.FindByGeometryName Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.FindByGeometryName(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Controller FindByGeometryName(
    string geometryName
)
Visual Basic (Declaration)
Public Function FindByGeometryName ( _
    geometryName As String _
) As Controller
Visual C++
public:
Controller^ FindByGeometryName(
    String^ geometryName
)

Parameters

geometryName
Type: System..::.String

[Missing <param name="geometryName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.FindByGeometryName(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.FindByGeometryName(System.String)]

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.FindIndex Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Controller >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.FindLastIndex Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Controller >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.IndexOf Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Controller >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.LastIndexOf Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Controller >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Remove Method

[image]

Mogware's Collada.Net Class Library
ControllerList..::.Remove Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.Remove(Mogware.VisualStudio.ColladaNet.Skinning.Controller)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    Controller controller
)
Visual Basic (Declaration)
Public Sub Remove ( _
    controller As Controller _
)
Visual C++
public:
void Remove(
    Controller^ controller
)

Parameters

controller
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Controller

[Missing <param name="controller"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.Remove(Mogware.VisualStudio.ColladaNet.Skinning.Controller)"]

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


RemoveRange Method

[image]

Mogware's Collada.Net Class Library
ControllerList..::.RemoveRange Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.RemoveRange(System.Int32,System.Int32)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RemoveRange(
    int start,
    int count
)
Visual Basic (Declaration)
Public Sub RemoveRange ( _
    start As Integer, _
    count As Integer _
)
Visual C++
public:
void RemoveRange(
    int start,
    int count
)

Parameters

start
Type: System..::.Int32

[Missing <param name="start"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.RemoveRange(System.Int32,System.Int32)"]

count
Type: System..::.Int32

[Missing <param name="count"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.ControllerList.RemoveRange(System.Int32,System.Int32)"]

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.Reverse Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
ControllerList..::.Sort Method
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Controller >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Controller >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
ControllerList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


ControllerList Properties

[image] [image]

Mogware's Collada.Net Class Library
ControllerList Properties
ControllerList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The ControllerList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Controller >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Controller >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Controller >)>).)

See Also

ControllerList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Class

[image]

Mogware's Collada.Net Class Library
Influence Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Influence]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Influence
Visual Basic (Declaration)
Public Class Influence
Visual C++
public ref class Influence

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Influence

See Also

Influence Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Members

[image] [image]

Mogware's Collada.Net Class Library
Influence Members
Influence Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Influence type exposes the following members.

Constructors

Name | Description
Influence | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Joint |
Weight |

See Also

Influence Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Constructor

[image] [image]

Mogware's Collada.Net Class Library
Influence Constructor
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Influence(List<(Of <(Object>)>), Skin) | Initializes a new instance of the Influence class
Influence(String, Single, Skin) | Initializes a new instance of the Influence class

See Also

Influence Class
Influence Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Constructor (List(Object), Skin)

[image]

Mogware's Collada.Net Class Library
Influence Constructor (List<(Of <(Object>)>), Skin)
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Influence class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Influence(
    List<Object> args,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    args As List(Of Object), _
    skin As Skin _
)
Visual C++
public:
Influence(
    List<Object^>^ args,
    Skin^ skin
)

Parameters

args
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="args"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Influence.#ctor(System.Collections.Generic.List{System.Object},Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Influence.#ctor(System.Collections.Generic.List{System.Object},Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Influence Class
Influence Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Constructor (String, Single, Skin)

[image]

Mogware's Collada.Net Class Library
Influence Constructor (String, Single, Skin)
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Influence class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Influence(
    string jointName,
    float weight,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    jointName As String, _
    weight As Single, _
    skin As Skin _
)
Visual C++
public:
Influence(
    String^ jointName,
    float weight,
    Skin^ skin
)

Parameters

jointName
Type: System..::.String

[Missing <param name="jointName"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Influence.#ctor(System.String,System.Single,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

weight
Type: System..::.Single

[Missing <param name="weight"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Influence.#ctor(System.String,System.Single,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Influence.#ctor(System.String,System.Single,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Influence Class
Influence Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Methods

[image] [image]

Mogware's Collada.Net Class Library
Influence Methods
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Influence type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Influence Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influence Properties

[image] [image]

Mogware's Collada.Net Class Library
Influence Properties
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Influence type exposes the following members.

Properties

Name | Description
Joint |
Weight |

See Also

Influence Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Property

[image]

Mogware's Collada.Net Class Library
Influence..::.Joint Property
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Influence.Joint]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joint Joint { get; set; }
Visual Basic (Declaration)
Public Property Joint As Joint
Visual C++
public:
property Joint^ Joint {
    Joint^ get ();
    void set (Joint^ value);
}

See Also

Influence Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Property

[image]

Mogware's Collada.Net Class Library
Influence..::.Weight Property
Influence Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Influence.Weight]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Weight Weight { get; set; }
Visual Basic (Declaration)
Public Property Weight As Weight
Visual C++
public:
property Weight^ Weight {
    Weight^ get ();
    void set (Weight^ value);
}

See Also

Influence Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InfluenceList Class

[image]

Mogware's Collada.Net Class Library
InfluenceList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.InfluenceList]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class InfluenceList : List<Influence>
Visual Basic (Declaration)
Public Class InfluenceList _
    Inherits List(Of Influence)
Visual C++
public ref class InfluenceList : public List<Influence^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Influence >)>)
Mogware.VisualStudio.ColladaNet.Skinning..::.InfluenceList

See Also

InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InfluenceList Members

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList Members
InfluenceList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InfluenceList type exposes the following members.

Constructors

Name | Description
InfluenceList | Initializes a new instance of the InfluenceList class

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Influence >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Influence >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Influence >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Influence >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Influence >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Influence >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Influence >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InfluenceList Constructor

[image]

Mogware's Collada.Net Class Library
InfluenceList Constructor
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the InfluenceList class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InfluenceList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
InfluenceList()

See Also

InfluenceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InfluenceList Methods

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList Methods
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InfluenceList type exposes the following members.

Methods

Name | Description
Add | Adds an object to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Influence >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Influence >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Influence >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Influence >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Influence >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Influence >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.BinarySearch Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Influence >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Influence >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.CopyTo Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Influence >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Influence >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.Find Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Find(Joint) |

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method (Joint)

[image]

Mogware's Collada.Net Class Library
InfluenceList..::.Find Method (Joint)
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.InfluenceList.Find(Mogware.VisualStudio.ColladaNet.Skinning.Joint)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Influence Find(
    Joint joint
)
Visual Basic (Declaration)
Public Function Find ( _
    joint As Joint _
) As Influence
Visual C++
public:
Influence^ Find(
    Joint^ joint
)

Parameters

joint
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Joint

[Missing <param name="joint"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.InfluenceList.Find(Mogware.VisualStudio.ColladaNet.Skinning.Joint)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.InfluenceList.Find(Mogware.VisualStudio.ColladaNet.Skinning.Joint)]

See Also

InfluenceList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.FindIndex Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Influence >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.FindLastIndex Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Influence >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.IndexOf Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Influence >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.LastIndexOf Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Influence >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.Reverse Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList..::.Sort Method
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Influence >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Influence >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
InfluenceList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InfluenceList Properties

[image] [image]

Mogware's Collada.Net Class Library
InfluenceList Properties
InfluenceList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The InfluenceList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Influence >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Influence >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Influence >)>).)

See Also

InfluenceList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Class

[image]

Mogware's Collada.Net Class Library
Joint Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Joint]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Joint
Visual Basic (Declaration)
Public Class Joint
Visual C++
public ref class Joint

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Joint

See Also

Joint Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Members

[image] [image]

Mogware's Collada.Net Class Library
Joint Members
Joint Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joint type exposes the following members.

Constructors

Name | Description
Joint | Initializes a new instance of the Joint class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index |
InverseBindMatrix |
Name |

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Constructor

[image]

Mogware's Collada.Net Class Library
Joint Constructor
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Joint class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joint(
    string name,
    Matrix inverseBind
)
Visual Basic (Declaration)
Public Sub New ( _
    name As String, _
    inverseBind As Matrix _
)
Visual C++
public:
Joint(
    String^ name,
    Matrix^ inverseBind
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joint.#ctor(System.String,Mogware.VisualStudio.ColladaNet.Matrix)"]

inverseBind
Type: Mogware.VisualStudio.ColladaNet..::.Matrix

[Missing <param name="inverseBind"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joint.#ctor(System.String,Mogware.VisualStudio.ColladaNet.Matrix)"]

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Methods

[image] [image]

Mogware's Collada.Net Class Library
Joint Methods
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joint type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joint Properties

[image] [image]

Mogware's Collada.Net Class Library
Joint Properties
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joint type exposes the following members.

Properties

Name | Description
Index |
InverseBindMatrix |
Name |

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Index Property

[image]

Mogware's Collada.Net Class Library
Joint..::.Index Property
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Joint.Index]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


InverseBindMatrix Property

[image]

Mogware's Collada.Net Class Library
Joint..::.InverseBindMatrix Property
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Joint.InverseBindMatrix]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Matrix InverseBindMatrix { get; set; }
Visual Basic (Declaration)
Public Property InverseBindMatrix As Matrix
Visual C++
public:
property Matrix^ InverseBindMatrix {
    Matrix^ get ();
    void set (Matrix^ value);
}

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Name Property

[image]

Mogware's Collada.Net Class Library
Joint..::.Name Property
Joint Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Joint.Name]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Name { get; set; }
Visual Basic (Declaration)
Public Property Name As String
Visual C++
public:
property String^ Name {
    String^ get ();
    void set (String^ value);
}

See Also

Joint Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Class

[image]

Mogware's Collada.Net Class Library
JointList Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.JointList]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class JointList : List<Joint>
Visual Basic (Declaration)
Public Class JointList _
    Inherits List(Of Joint)
Visual C++
public ref class JointList : public List<Joint^>

Inheritance Hierarchy

System..::.Object
System.Collections.Generic..::.List <(Of <( Joint >)>)
Mogware.VisualStudio.ColladaNet.Skinning..::.JointList

See Also

JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Members

[image] [image]

Mogware's Collada.Net Class Library
JointList Members
JointList Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JointList type exposes the following members.

Constructors

Name | Description
JointList | Initializes a new instance of the JointList class

Methods

Name | Description
Add |
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Joint >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Joint >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Joint >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Joint >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Joint >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Joint >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Joint >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Constructor

[image]

Mogware's Collada.Net Class Library
JointList Constructor
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the JointList class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public JointList()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
JointList()

See Also

JointList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Methods

[image] [image]

Mogware's Collada.Net Class Library
JointList Methods
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JointList type exposes the following members.

Methods

Name | Description
Add |
AddRange | Adds the elements of the specified collection to the end of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
AsReadOnly | Returns a read-only IList<(Of <(T>)>) wrapper for the current collection. (Inherited from List <(Of <( Joint >)>).)
BinarySearch | Overloaded.
Clear | Removes all elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Contains | Determines whether an element is in the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
ConvertAll<(Of <(TOutput>)>) | Converts the elements in the current List<(Of <(T>)>) to another type, and returns a list containing the converted elements. (Inherited from List <(Of <( Joint >)>).)
CopyTo | Overloaded.
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Exists | Determines whether the List<(Of <(T>)>) contains elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find | Overloaded.
FindAll | Retrieves all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
FindIndex | Overloaded.
FindLast | Searches for an element that matches the conditions defined by the specified predicate, and returns the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
FindLastIndex | Overloaded.
ForEach | Performs the specified action on each element of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetEnumerator | Returns an enumerator that iterates through the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetRange | Creates a shallow copy of a range of elements in the source List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
GetType | Gets the Type of the current instance. (Inherited from Object.)
IndexOf | Overloaded.
Insert | Inserts an element into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Joint >)>).)
InsertRange | Inserts the elements of a collection into the List<(Of <(T>)>) at the specified index. (Inherited from List <(Of <( Joint >)>).)
LastIndexOf | Overloaded.
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Remove | Overloaded.
RemoveAll | Removes the all the elements that match the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)
RemoveAt | Removes the element at the specified index of the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
RemoveRange | Removes a range of elements from the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Reverse | Overloaded.
Sort | Overloaded.
ToArray | Copies the elements of the List<(Of <(T>)>) to a new array. (Inherited from List <(Of <( Joint >)>).)
ToString | Returns a String that represents the current Object. (Inherited from Object.)
TrimExcess | Sets the capacity to the actual number of elements in the List<(Of <(T>)>), if that number is less than a threshold value. (Inherited from List <(Of <( Joint >)>).)
TrueForAll | Determines whether every element in the List<(Of <(T>)>) matches the conditions defined by the specified predicate. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Add Method

[image]

Mogware's Collada.Net Class Library
JointList..::.Add Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Add(Mogware.VisualStudio.ColladaNet.Skinning.Joint)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Add(
    Joint joint
)
Visual Basic (Declaration)
Public Sub Add ( _
    joint As Joint _
)
Visual C++
public:
void Add(
    Joint^ joint
)

Parameters

joint
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Joint

[Missing <param name="joint"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Add(Mogware.VisualStudio.ColladaNet.Skinning.Joint)"]

See Also

JointList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


BinarySearch Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.BinarySearch Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
BinarySearch(T) | Searches the entire sorted List<(Of <(T>)>) for an element using the default comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Joint >)>).)
BinarySearch(T, IComparer<(Of <(T>)>)) | Searches the entire sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Joint >)>).)
BinarySearch(Int32, Int32, T, IComparer<(Of <(T>)>)) | Searches a range of elements in the sorted List<(Of <(T>)>) for an element using the specified comparer and returns the zero-based index of the element. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


CopyTo Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.CopyTo Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
CopyTo(array<T>[]()[]) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the beginning of the target array. (Inherited from List <(Of <( Joint >)>).)
CopyTo(array<T>[]()[], Int32) | Copies the entire List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Joint >)>).)
CopyTo(Int32, array<T>[]()[], Int32, Int32) | Copies a range of elements from the List<(Of <(T>)>) to a compatible one-dimensional array, starting at the specified index of the target array. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.Find Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Find(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Find(String) |

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method (String)

[image]

Mogware's Collada.Net Class Library
JointList..::.Find Method (String)
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joint Find(
    string name
)
Visual Basic (Declaration)
Public Function Find ( _
    name As String _
) As Joint
Visual C++
public:
Joint^ Find(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Find(System.String)]

See Also

JointList Class
Find Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindIndex Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.FindIndex Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
FindIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Joint >)>).)
FindIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


FindLastIndex Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.FindLastIndex Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
FindLastIndex(Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
FindLastIndex(Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Joint >)>).)
FindLastIndex(Int32, Int32, Predicate<(Of <(T>)>)) | Searches for an element that matches the conditions defined by the specified predicate, and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


IndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.IndexOf Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
IndexOf(T) | Searches for the specified object and returns the zero-based index of the first occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
IndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that extends from the specified index to the last element. (Inherited from List <(Of <( Joint >)>).)
IndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the first occurrence within the range of elements in the List<(Of <(T>)>) that starts at the specified index and contains the specified number of elements. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


LastIndexOf Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.LastIndexOf Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
LastIndexOf(T) | Searches for the specified object and returns the zero-based index of the last occurrence within the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
LastIndexOf(T, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that extends from the first element to the specified index. (Inherited from List <(Of <( Joint >)>).)
LastIndexOf(T, Int32, Int32) | Searches for the specified object and returns the zero-based index of the last occurrence within the range of elements in the List<(Of <(T>)>) that contains the specified number of elements and ends at the specified index. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Remove Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.Remove Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Remove(T) | Removes the first occurrence of a specific object from the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Remove(String) |

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Remove Method (String)

[image]

Mogware's Collada.Net Class Library
JointList..::.Remove Method (String)
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Remove(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Remove(
    string name
)
Visual Basic (Declaration)
Public Sub Remove ( _
    name As String _
)
Visual C++
public:
void Remove(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.JointList.Remove(System.String)"]

See Also

JointList Class
Remove Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Reverse Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.Reverse Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Reverse()()() | Reverses the order of the elements in the entire List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Reverse(Int32, Int32) | Reverses the order of the elements in the specified range. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Sort Method

[image] [image]

Mogware's Collada.Net Class Library
JointList..::.Sort Method
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
Sort()()() | Sorts the elements in the entire List<(Of <(T>)>) using the default comparer. (Inherited from List <(Of <( Joint >)>).)
Sort(IComparer<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Joint >)>).)
Sort(Comparison<(Of <(T>)>)) | Sorts the elements in the entire List<(Of <(T>)>) using the specified Comparison<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Sort(Int32, Int32, IComparer<(Of <(T>)>)) | Sorts the elements in a range of elements in List<(Of <(T>)>) using the specified comparer. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
JointList Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Properties

[image] [image]

Mogware's Collada.Net Class Library
JointList Properties
JointList Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The JointList type exposes the following members.

Properties

Name | Description
Capacity | Gets or sets the total number of elements the internal data structure can hold without resizing. (Inherited from List <(Of <( Joint >)>).)
Count | Gets the number of elements actually contained in the List<(Of <(T>)>). (Inherited from List <(Of <( Joint >)>).)
Item | Gets or sets the element at the specified index. (Inherited from List <(Of <( Joint >)>).)

See Also

JointList Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Class

[image]

Mogware's Collada.Net Class Library
Joints Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Joints]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Joints
Visual Basic (Declaration)
Public Class Joints
Visual C++
public ref class Joints

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Joints

See Also

Joints Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Members

[image] [image]

Mogware's Collada.Net Class Library
Joints Members
Joints Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joints type exposes the following members.

Constructors

Name | Description
Joints | Initializes a new instance of the Joints class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inputs |
JointList |

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Constructor

[image]

Mogware's Collada.Net Class Library
Joints Constructor
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Joints class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joints(
    XmlElement element,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    skin As Skin _
)
Visual C++
public:
Joints(
    XmlElement^ element,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Methods

[image] [image]

Mogware's Collada.Net Class Library
Joints Methods
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joints type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
Find |
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Find Method

[image]

Mogware's Collada.Net Class Library
Joints..::.Find Method
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Find(System.String)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joint Find(
    string name
)
Visual Basic (Declaration)
Public Function Find ( _
    name As String _
) As Joint
Visual C++
public:
Joint^ Find(
    String^ name
)

Parameters

name
Type: System..::.String

[Missing <param name="name"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Find(System.String)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Find(System.String)]

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Joints..::.Presave Method
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Presave(Mogware.VisualStudio.ColladaNet.Skinning.Skin)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave(
    Skin skin
)
Visual Basic (Declaration)
Public Sub Presave ( _
    skin As Skin _
)
Visual C++
public:
void Presave(
    Skin^ skin
)

Parameters

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Presave(Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Properties

[image] [image]

Mogware's Collada.Net Class Library
Joints Properties
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Joints type exposes the following members.

Properties

Name | Description
Inputs |
JointList |

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Inputs Property

[image]

Mogware's Collada.Net Class Library
Joints..::.Inputs Property
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Joints.Inputs]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InputList Inputs { get; set; }
Visual Basic (Declaration)
Public Property Inputs As InputList
Visual C++
public:
property InputList^ Inputs {
    InputList^ get ();
    void set (InputList^ value);
}

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


JointList Property

[image]

Mogware's Collada.Net Class Library
Joints..::.JointList Property
Joints Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Joints.JointList]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public JointList JointList { get; }
Visual Basic (Declaration)
Public ReadOnly Property JointList As JointList
Visual C++
public:
property JointList^ JointList {
    JointList^ get ();
}

See Also

Joints Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Class

[image]

Mogware's Collada.Net Class Library
Skin Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Skin]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Skin
Visual Basic (Declaration)
Public Class Skin
Visual C++
public ref class Skin

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

See Also

Skin Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Members

[image] [image]

Mogware's Collada.Net Class Library
Skin Members
Skin Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Skin type exposes the following members.

Constructors

Name | Description
Skin | Initializes a new instance of the Skin class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSource |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
RenameJoints |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
GeometryName |
Id |
Joints |
Sources |
VertexWeights |

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Constructor

[image]

Mogware's Collada.Net Class Library
Skin Constructor
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Skin class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Skin(
    XmlElement element,
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    document As ColladaDocument _
)
Visual C++
public:
Skin(
    XmlElement^ element,
    ColladaDocument^ document
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Methods

[image] [image]

Mogware's Collada.Net Class Library
Skin Methods
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Skin type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetSource |
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
RenameJoints |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


GetSource Method

[image]

Mogware's Collada.Net Class Library
Skin..::.GetSource Method
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.GetSource(Mogware.VisualStudio.ColladaNet.InputSemantic)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public ISource GetSource(
    InputSemantic semantic
)
Visual Basic (Declaration)
Public Function GetSource ( _
    semantic As InputSemantic _
) As ISource
Visual C++
public:
ISource^ GetSource(
    InputSemantic semantic
)

Parameters

semantic
Type: Mogware.VisualStudio.ColladaNet..::.InputSemantic

[Missing <param name="semantic"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.GetSource(Mogware.VisualStudio.ColladaNet.InputSemantic)"]

Return Value

[Missing <returns> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.GetSource(Mogware.VisualStudio.ColladaNet.InputSemantic)]

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
Skin..::.Presave Method
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.Presave(Mogware.VisualStudio.ColladaNet.ColladaDocument)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave(
    ColladaDocument document
)
Visual Basic (Declaration)
Public Sub Presave ( _
    document As ColladaDocument _
)
Visual C++
public:
void Presave(
    ColladaDocument^ document
)

Parameters

document
Type: Mogware.VisualStudio.ColladaNet..::.ColladaDocument

[Missing <param name="document"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.Presave(Mogware.VisualStudio.ColladaNet.ColladaDocument)"]

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


RenameJoints Method

[image]

Mogware's Collada.Net Class Library
Skin..::.RenameJoints Method
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.RenameJoints(System.Collections.Generic.Dictionary{System.String,System.String})]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void RenameJoints(
    Dictionary<string, string> nameMap
)
Visual Basic (Declaration)
Public Sub RenameJoints ( _
    nameMap As Dictionary(Of String, String) _
)
Visual C++
public:
void RenameJoints(
    Dictionary<String^, String^>^ nameMap
)

Parameters

nameMap
Type: System.Collections.Generic..::.Dictionary <(Of <( String, String >)>)

[Missing <param name="nameMap"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Skin.RenameJoints(System.Collections.Generic.Dictionary{System.String,System.String})"]

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Skin Properties

[image] [image]

Mogware's Collada.Net Class Library
Skin Properties
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Skin type exposes the following members.

Properties

Name | Description
GeometryName |
Id |
Joints |
Sources |
VertexWeights |

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


GeometryName Property

[image]

Mogware's Collada.Net Class Library
Skin..::.GeometryName Property
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Skin.GeometryName]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string GeometryName { get; set; }
Visual Basic (Declaration)
Public Property GeometryName As String
Visual C++
public:
property String^ GeometryName {
    String^ get ();
    void set (String^ value);
}

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Id Property

[image]

Mogware's Collada.Net Class Library
Skin..::.Id Property
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Skin.Id]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public string Id { get; set; }
Visual Basic (Declaration)
Public Property Id As String
Visual C++
public:
property String^ Id {
    String^ get ();
    void set (String^ value);
}

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Joints Property

[image]

Mogware's Collada.Net Class Library
Skin..::.Joints Property
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Skin.Joints]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Joints Joints { get; }
Visual Basic (Declaration)
Public ReadOnly Property Joints As Joints
Visual C++
public:
property Joints^ Joints {
    Joints^ get ();
}

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Sources Property

[image]

Mogware's Collada.Net Class Library
Skin..::.Sources Property
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Skin.Sources]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public SourceList Sources { get; }
Visual Basic (Declaration)
Public ReadOnly Property Sources As SourceList
Visual C++
public:
property SourceList^ Sources {
    SourceList^ get ();
}

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Property

[image]

Mogware's Collada.Net Class Library
Skin..::.VertexWeights Property
Skin Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Skin.VertexWeights]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public VertexWeights VertexWeights { get; }
Visual Basic (Declaration)
Public ReadOnly Property VertexWeights As VertexWeights
Visual C++
public:
property VertexWeights^ VertexWeights {
    VertexWeights^ get ();
}

See Also

Skin Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Class

[image]

Mogware's Collada.Net Class Library
VertexWeights Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class VertexWeights
Visual Basic (Declaration)
Public Class VertexWeights
Visual C++
public ref class VertexWeights

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.VertexWeights

See Also

VertexWeights Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Members

[image] [image]

Mogware's Collada.Net Class Library
VertexWeights Members
VertexWeights Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VertexWeights type exposes the following members.

Constructors

Name | Description
VertexWeights | Initializes a new instance of the VertexWeights class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Inputs |
Vertices |

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Constructor

[image]

Mogware's Collada.Net Class Library
VertexWeights Constructor
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the VertexWeights class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public VertexWeights(
    XmlElement element,
    Skin skin
)
Visual Basic (Declaration)
Public Sub New ( _
    element As XmlElement, _
    skin As Skin _
)
Visual C++
public:
VertexWeights(
    XmlElement^ element,
    Skin^ skin
)

Parameters

element
Type: System.Xml..::.XmlElement

[Missing <param name="element"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.#ctor(System.Xml.XmlElement,Mogware.VisualStudio.ColladaNet.Skinning.Skin)"]

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Methods

[image] [image]

Mogware's Collada.Net Class Library
VertexWeights Methods
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VertexWeights type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
Presave |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Presave Method

[image]

Mogware's Collada.Net Class Library
VertexWeights..::.Presave Method
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.Presave(Mogware.VisualStudio.ColladaNet.Skinning.Skin,Mogware.VisualStudio.ColladaNet.Geometry.Geometry)]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void Presave(
    Skin skin,
    Geometry geometry
)
Visual Basic (Declaration)
Public Sub Presave ( _
    skin As Skin, _
    geometry As Geometry _
)
Visual C++
public:
void Presave(
    Skin^ skin,
    Geometry^ geometry
)

Parameters

skin
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.Skin

[Missing <param name="skin"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.Presave(Mogware.VisualStudio.ColladaNet.Skinning.Skin,Mogware.VisualStudio.ColladaNet.Geometry.Geometry)"]

geometry
Type: Mogware.VisualStudio.ColladaNet.Geometry..::.Geometry

[Missing <param name="geometry"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.Presave(Mogware.VisualStudio.ColladaNet.Skinning.Skin,Mogware.VisualStudio.ColladaNet.Geometry.Geometry)"]

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


VertexWeights Properties

[image] [image]

Mogware's Collada.Net Class Library
VertexWeights Properties
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The VertexWeights type exposes the following members.

Properties

Name | Description
Inputs |
Vertices |

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Inputs Property

[image]

Mogware's Collada.Net Class Library
VertexWeights..::.Inputs Property
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.Inputs]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InputList Inputs { get; }
Visual Basic (Declaration)
Public ReadOnly Property Inputs As InputList
Visual C++
public:
property InputList^ Inputs {
    InputList^ get ();
}

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Vertices Property

[image]

Mogware's Collada.Net Class Library
VertexWeights..::.Vertices Property
VertexWeights Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.VertexWeights.Vertices]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public List<WeightedObject> Vertices { get; set; }
Visual Basic (Declaration)
Public Property Vertices As List(Of WeightedObject)
Visual C++
public:
property List<WeightedObject^>^ Vertices {
    List<WeightedObject^>^ get ();
    void set (List<WeightedObject^>^ value);
}

See Also

VertexWeights Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Class

[image]

Mogware's Collada.Net Class Library
Weight Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.Weight]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class Weight
Visual Basic (Declaration)
Public Class Weight
Visual C++
public ref class Weight

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.Weight

See Also

Weight Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Members

[image] [image]

Mogware's Collada.Net Class Library
Weight Members
Weight Class Constructors Methods Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Weight type exposes the following members.

Constructors

Name | Description
Weight | Initializes a new instance of the Weight class

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Properties

Name | Description
Index |
Value |

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Constructor

[image]

Mogware's Collada.Net Class Library
Weight Constructor
Weight Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the Weight class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public Weight(
    float value
)
Visual Basic (Declaration)
Public Sub New ( _
    value As Single _
)
Visual C++
public:
Weight(
    float value
)

Parameters

value
Type: System..::.Single

[Missing <param name="value"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.Weight.#ctor(System.Single)"]

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Methods

[image] [image]

Mogware's Collada.Net Class Library
Weight Methods
Weight Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Weight type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Weight Properties

[image] [image]

Mogware's Collada.Net Class Library
Weight Properties
Weight Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The Weight type exposes the following members.

Properties

Name | Description
Index |
Value |

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Index Property

[image]

Mogware's Collada.Net Class Library
Weight..::.Index Property
Weight Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Weight.Index]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public int Index { get; set; }
Visual Basic (Declaration)
Public Property Index As Integer
Visual C++
public:
property int Index {
    int get ();
    void set (int value);
}

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Value Property

[image]

Mogware's Collada.Net Class Library
Weight..::.Value Property
Weight Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.Weight.Value]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public float Value { get; set; }
Visual Basic (Declaration)
Public Property Value As Single
Visual C++
public:
property float Value {
    float get ();
    void set (float value);
}

See Also

Weight Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Class

[image]

Mogware's Collada.Net Class Library
WeightedObject Class
Members See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for T:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public class WeightedObject
Visual Basic (Declaration)
Public Class WeightedObject
Visual C++
public ref class WeightedObject

Inheritance Hierarchy

System..::.Object
Mogware.VisualStudio.ColladaNet.Skinning..::.WeightedObject
Mogware.VisualStudio.ColladaNet.Geometry..::.Vertex

See Also

WeightedObject Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Members

[image] [image]

Mogware's Collada.Net Class Library
WeightedObject Members
WeightedObject Class Constructors Methods Fields Properties See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WeightedObject type exposes the following members.

Constructors

Name | Description
WeightedObject | Overloaded.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeWeights |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

Fields

Name | Description
mInfluences |

Properties

Name | Description
Influences |

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Constructor

[image] [image]

Mogware's Collada.Net Class Library
WeightedObject Constructor
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

Overload List

Name | Description
WeightedObject()()() | Initializes a new instance of the WeightedObject class
WeightedObject(WeightedObject) | Initializes a new instance of the WeightedObject class
WeightedObject(List<(Of <(Object>)>)) | Initializes a new instance of the WeightedObject class

See Also

WeightedObject Class
WeightedObject Members
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Constructor

[image]

Mogware's Collada.Net Class Library
WeightedObject Constructor
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the WeightedObject class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public WeightedObject()
Visual Basic (Declaration)
Public Sub New
Visual C++
public:
WeightedObject()

See Also

WeightedObject Class
WeightedObject Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Constructor (WeightedObject)

[image]

Mogware's Collada.Net Class Library
WeightedObject Constructor (WeightedObject)
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the WeightedObject class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public WeightedObject(
    WeightedObject other
)
Visual Basic (Declaration)
Public Sub New ( _
    other As WeightedObject _
)
Visual C++
public:
WeightedObject(
    WeightedObject^ other
)

Parameters

other
Type: Mogware.VisualStudio.ColladaNet.Skinning..::.WeightedObject

[Missing <param name="other"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject.#ctor(Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject)"]

See Also

WeightedObject Class
WeightedObject Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Constructor (List(Object))

[image]

Mogware's Collada.Net Class Library
WeightedObject Constructor (List<(Of <(Object>)>))
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]
Initializes a new instance of the WeightedObject class

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public WeightedObject(
    List<Object> args
)
Visual Basic (Declaration)
Public Sub New ( _
    args As List(Of Object) _
)
Visual C++
public:
WeightedObject(
    List<Object^>^ args
)

Parameters

args
Type: System.Collections.Generic..::.List <(Of <( Object >)>)

[Missing <param name="args"/> documentation for "M:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject.#ctor(System.Collections.Generic.List{System.Object})"]

See Also

WeightedObject Class
WeightedObject Overload
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Fields

[image] [image]

Mogware's Collada.Net Class Library
WeightedObject Fields
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WeightedObject type exposes the following members.

Fields

Name | Description
mInfluences |

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


mInfluences Field

[image]

Mogware's Collada.Net Class Library
WeightedObject..::.mInfluences Field
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for F:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject.mInfluences]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
protected InfluenceList mInfluences
Visual Basic (Declaration)
Protected mInfluences As InfluenceList
Visual C++
protected:
InfluenceList^ mInfluences

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Methods

[image] [image]

Mogware's Collada.Net Class Library
WeightedObject Methods
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WeightedObject type exposes the following members.

Methods

Name | Description
Equals | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
Finalize | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
GetHashCode | Serves as a hash function for a particular type. (Inherited from Object.)
GetType | Gets the Type of the current instance. (Inherited from Object.)
MemberwiseClone | Creates a shallow copy of the current Object. (Inherited from Object.)
NormalizeWeights |
ToString | Returns a String that represents the current Object. (Inherited from Object.)

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


NormalizeWeights Method

[image]

Mogware's Collada.Net Class Library
WeightedObject..::.NormalizeWeights Method
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for M:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject.NormalizeWeights]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public void NormalizeWeights()
Visual Basic (Declaration)
Public Sub NormalizeWeights
Visual C++
public:
void NormalizeWeights()

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


WeightedObject Properties

[image] [image]

Mogware's Collada.Net Class Library
WeightedObject Properties
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

The WeightedObject type exposes the following members.

Properties

Name | Description
Influences |

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace


Influences Property

[image]

Mogware's Collada.Net Class Library
WeightedObject..::.Influences Property
WeightedObject Class See Also Send Feedback

[This is preliminary documentation and is subject to change.]

[Missing <summary> documentation for P:Mogware.VisualStudio.ColladaNet.Skinning.WeightedObject.Influences]

Namespace: Mogware.VisualStudio.ColladaNet.Skinning
Assembly: Mogware.VisualStudio.ColladaNet (in Mogware.VisualStudio.ColladaNet.dll) Version: 1.0.0.3216 (1.0.0.3216)

Syntax

C#
public InfluenceList Influences { get; }
Visual Basic (Declaration)
Public ReadOnly Property Influences As InfluenceList
Visual C++
public:
property InfluenceList^ Influences {
    InfluenceList^ get ();
}

See Also

WeightedObject Class
Mogware.VisualStudio.ColladaNet.Skinning Namespace